EM TuningAH Fabrications
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By jjmurphy21187

Thread: WITSON Aftermarket Headunit? (GPS, DVD, MP3, USB, iPod, BT etc)

  1. #1
    jjmurphy21187's Avatar
    Tiptronic

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Nottingham, UK
    Posts
    756

    WITSON Aftermarket Headunit? (GPS, DVD, MP3, USB, iPod, BT etc)

    Main thread in the audio section, but I'm looking for something model specific so if you guys have any input that'd be great!

    Aftermarket HU A4 B7 Options

    Car: 2007 A4 3.0TDI Quattro S-Line Cabriolet
    Mods: Pipercross Panel Filter, Smarttop, LED Plate Bulbs, LED Interior Bulbs, Blue LED Needles, Remap, EGR Delete, Custom Stainless Exhaust (4" Slash Tips), Cupra-R Splitter, Embossed Number Plates, 19" BBS CH Reps & Vredestein Ultra Sessanta's, 12mm TPI Spacers, -30m H&R Springs, MTEC Black Edition Brakes (Dimpled & Grooved), Mintex Pads, RS4 RARB, Vibe Square Subwoofer in Ski-pass & Alpine MRP-350 Amp

    VCDS - PM for details (East Midlands)

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    jjmurphy21187's Avatar
    Tiptronic

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Nottingham, UK
    Posts
    756
    Specifically hi2gav and Viceroy as I know you guys have this brand of unit...
    Last edited by jjmurphy21187; 28th April 2012 at 17:07.
    Gates likes this.

    Car: 2007 A4 3.0TDI Quattro S-Line Cabriolet
    Mods: Pipercross Panel Filter, Smarttop, LED Plate Bulbs, LED Interior Bulbs, Blue LED Needles, Remap, EGR Delete, Custom Stainless Exhaust (4" Slash Tips), Cupra-R Splitter, Embossed Number Plates, 19" BBS CH Reps & Vredestein Ultra Sessanta's, 12mm TPI Spacers, -30m H&R Springs, MTEC Black Edition Brakes (Dimpled & Grooved), Mintex Pads, RS4 RARB, Vibe Square Subwoofer in Ski-pass & Alpine MRP-350 Amp

    VCDS - PM for details (East Midlands)

  4. #3
    Noob

    Status
    Offline
    Join Date
    Apr 2012
    Location
    North West London
    Posts
    22
    Hey,

    Slow to see this, sorry pal.

    So mine is installed after a bit of bother. Its been 12 years since i last installed a head unit but i gave it a go anyway. Not a good idea!

    After hooking it all up outside the dash it worked. After fitting it in the dash, it did not. Worse the backlight was on permanently so i that meant pulling the fuse. When i went to remove the HU and investigate it was utterly stuck. Left it 2 weeks as sooo busy - no tunes at all - horrendous.

    So i got a pro in and with far higher quality tools he managed to remove it to discover that two of the wires had broken as they were very very small. Some solder and glue later and it went back in (after he discovered that i had also failed to remove the transit screws from the dvd drive).

    What do i think?

    Ok, so the unit looks the nuts (i will post pics but not got any with me right now) plastics match the rest of the dash and there are no gaps or anything. All the steering wheel controls work fine but there is no output to the in dash DIS (between the dials) for the stereo.
    Definitely looks OEM no doubt. Backlights all red to match the rest of the dash.

    Now i must say you do get a lot for your money in terms of functionality (but remember the TV is analogue so you will need an additional DVB-T tuner). But the software is pretty naff and rather slow (i suppose i am just used to a speedy smartphone these days) but it is more or less all there. Its just very 'Chinese' if i can say that without intending to cause any offence, the UI looks great but it doesnt work all that brilliantly (for example loading the contents of my SD CARD every time i switch to that function and it takes a couple of minutes). Again, you just cannot compare the experience to Android or iPhone which is i think my issue.

    All in all i think its great value for money in terms of functionality. The GPS signal is superb and the bluetooth hands free functionality works a treat even with the roof down etc. I've only had it installed for a couple of days so not road tested it all that significantly yet.

    There is however an issue. The output is at 2v and so far i have power in the dash tweeters but the rest of the speakers give a very low volume so the sound quality is poor. Not sure if it is how i have it setup or if i need line drivers to the doors or something. Either way it can be rectified with a bit more work and money!

    Will follow up with pics/vid when i can but feel free to ask me specific question if you want

  5. #4
    jjmurphy21187's Avatar
    Tiptronic

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Nottingham, UK
    Posts
    756
    Hi Gav, thanks a lot for your reply.

    Sounds like you had some bad luck with the install! Also sounds like the quality of the kit isn't great, which to be honest isn't completely unexpected.

    I never look at the DIS anyway, 8 characters (or whatever it displays) is pretty pointless anyway. I've spoke to Viceroy via PM also and he says it fits into the dash well, OEM look etc so that's a firm concensus! I know exactly what you mean by 'Chinese', again no offense to anyone, just feel a bit lacking in design and all the functionality is thrown together with not much thought (quantity over quality every time). What SD card are you using? Capacity and speed class?

    Do you have the DTV tuner box? How do you find the reception? I was wondering where I could mount the ariels... I thought (as I have a cab also), I could put them under the plastic cover at the top of the windscreen, no idea how to take it off though? Either that or tun a lead and mount them under hood cover at the rear? Really don't want them visible if possible.

    When you say the 'output' is 2v, is that the pre-out voltage? Do you have BOSE? The poor sound quality is probably the deciding factor for me, I think I could live with slightly awkward UI quirks in exchange for the price and range of functionality, but if it sounds s**te then it doesn't matter what it can play!

    Pics and and resolution to the problems you're experiencing would be great. Which model is it that you have? Also, did you buy it direct from their website? They are asking for 6% extra to pay via paypal... don't fancy sending the bext part of £300 via western union, sounds like a scam to me :/

    Thanks again for your help!

    Car: 2007 A4 3.0TDI Quattro S-Line Cabriolet
    Mods: Pipercross Panel Filter, Smarttop, LED Plate Bulbs, LED Interior Bulbs, Blue LED Needles, Remap, EGR Delete, Custom Stainless Exhaust (4" Slash Tips), Cupra-R Splitter, Embossed Number Plates, 19" BBS CH Reps & Vredestein Ultra Sessanta's, 12mm TPI Spacers, -30m H&R Springs, MTEC Black Edition Brakes (Dimpled & Grooved), Mintex Pads, RS4 RARB, Vibe Square Subwoofer in Ski-pass & Alpine MRP-350 Amp

    VCDS - PM for details (East Midlands)

  6. #5
    Noob

    Status
    Offline
    Join Date
    Apr 2012
    Location
    North West London
    Posts
    22
    No worries. Yeh i will do a vid when i can but mad busy over past couple of days and not even been in the car! So to answer your questions as best i can today:

    What type sd card? - Kingston Class 4 SD HC 8gb

    DTV tuner? - Yep got one of these (the lower power one that works when stationary but not so much when moving fast). The aerial is thin piece of plastic about 10cm long and less than 1cm wide with sticky on one side and wire down to the unit. I have had it installed and i can see the menus through the Head Unit aux function but i am getting no signal whatsoever. The fitting was sort of done in two stages so i think it may be that the aerial hasnt actually been connected to the unit so i cant tell you much else. Its stuck to the inside of the very top of the windscreen on drivers side with cables hidden in A-pillar. It does cause some significant engine interference though (much more so than the radio). I understand this is a fairly common problem with aftermarket in car tv.

    2v - yes this is the pre-out voltage i think (based on what fitter said). I dont have Bose but someone i spoke to who is more knoweldgable than me suggested it might be that i have the subwoofer function turned on when i shouldnt. Again not tested yet.

    Purchase - i contacted them directly in China after finding it online, they gave me the details of Rob @ icebox auto in Liverpool who are their sole distributers. Good guy and helpful, he sells everything on ebay so find him there (or PM me for email). I paid £400 for unit, additional DVB-T tuner, map software and delivery. Preferred to pay a little more to use a UK based business than faff about with China, import duties etc etc. Here is the link to my exact unit : AUDI A4----ZHUHAI WITSON INDUSTRIAL CO.,LTD.---Professional Car DVD Player Manufacturer

    Interestingly, i spoke to Rob today to ask some questions, one of which was why the site said the unit had RDS but when i use the radio i only see frequency. He sent me a video that shows a hidden menu with additional functions one of which was to activate the RDS!

  7. #6
    viceroy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Johannesburg
    Posts
    198
    Quote Originally Posted by hi2gav View Post
    Interestingly, i spoke to Rob today to ask some questions, one of which was why the site said the unit had RDS but when i use the radio i only see frequency. He sent me a video that shows a hidden menu with additional functions one of which was to activate the RDS!
    Please send this to me too...
    As I mentioned to jjmurphy, the unit does have RDS, but only displays the text in the top left of the screen.
    The channels are all stored by frequency, so if there is a way to show RDS text instead of frequency, that would be great
    | 2009 A4 3.0TDI quattro tip | Ice Silver | 19" OEM RS4 style wheels | PDC | Sunroof | Black Leather | Symphony Radio | Aftermarket Navigation & DVD | RS4 mesh grille | Custom mesh fog grilles |

  8. #7
    Noob

    Status
    Offline
    Join Date
    Apr 2012
    Location
    North West London
    Posts
    22
    No problem. Havent been able to take the video yet as promised as car at the garage getting cambelt/water pump replaced!

    I assume you have the same UI as i do (the latest one i guess). Have a look at this video from the manufacturer (ignore the bluetooth thing at the beginning and just watch for entering the secret menu from the settings/info page).

    I've yet to see RDS on mine. The setting was 'on' but i am not getting it. I think the reason for this maybe that the dual-fakra to single male aerial adapter that came with the unit is a bit insufficient. I think what is really needed is one that includes amplification so i ordered this this morning.

    eBay - The UK's Online Marketplace

    I am hoping that this will boost the signal power and subsequently allow RDS. What have been your experiences with the aerial/reception? I have a Cabby by the way.

    Video - https://www.dropbox.com/s/k2n34ez2ie...secretmenu.mp4

  9. #8
    viceroy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Johannesburg
    Posts
    198
    Hmmm, its a different interface to mine.
    On mine I already have access to all the features the videographer does...
    I'll take pics for you.

    BTW, that Fakra adaptor looks correct (same as the one that was supplied with my unit)
    | 2009 A4 3.0TDI quattro tip | Ice Silver | 19" OEM RS4 style wheels | PDC | Sunroof | Black Leather | Symphony Radio | Aftermarket Navigation & DVD | RS4 mesh grille | Custom mesh fog grilles |

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    1
    Hey guys, I'm looking at getting a Witson unit as well. After a couple of months, how are your experiences?

  11. #10
    jjmurphy21187's Avatar
    Tiptronic

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Nottingham, UK
    Posts
    756
    Never got one in the end, seemed like too much expendature for little gain... Plus I found a 'Venturi Mini' which I forgot I had which allows me to use hands-free BT and MP3s from my phone, all be it slightly poor quality...

    Car: 2007 A4 3.0TDI Quattro S-Line Cabriolet
    Mods: Pipercross Panel Filter, Smarttop, LED Plate Bulbs, LED Interior Bulbs, Blue LED Needles, Remap, EGR Delete, Custom Stainless Exhaust (4" Slash Tips), Cupra-R Splitter, Embossed Number Plates, 19" BBS CH Reps & Vredestein Ultra Sessanta's, 12mm TPI Spacers, -30m H&R Springs, MTEC Black Edition Brakes (Dimpled & Grooved), Mintex Pads, RS4 RARB, Vibe Square Subwoofer in Ski-pass & Alpine MRP-350 Amp

    VCDS - PM for details (East Midlands)

 

 

Similar Threads

  1. OEM style aftermarket GPS/DVD install. Stuck!!
    By hi2gav in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 10
    Last Post: 23rd April 2012, 17:01
  2. Replies: 9
    Last Post: 17th January 2008, 05:27
  3. A3 8P Sport Head Unit MP3/USB/iPod
    By Crisis in forum In-Car Entertainment
    Replies: 2
    Last Post: 19th November 2007, 19:20
  4. aftermarket cd changer with mp3 to factory headunit???
    By Craigybaby37_A3quattro in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 26th February 2007, 22:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO