AH FabricationsJMB Retrofits
Results 1 to 12 of 12
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    4

    A4 Brake Warning Light

    Hi Guys

    Can anbody help with wiring diagram & relay details to cure this problem.
    Light comes on after cranking engine,scanned for faults & non showing,have contacted Dealer they say needs relay fitting to cicuit.
    Any help would be much appeciated.

    Regards Phil

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,096
    Scanned for faults with what?

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    4
    Scanned with VCDS & SNAPPY

  5. #4
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Online
    Join Date
    Jul 2008
    Posts
    8,487
    battery on its way out can cause this

  6. #5
    alpesh26's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    270
    As above.

    Mine did the same, no faults being thrown (checked with VAS). Changed the battery and its been fine since.
    Audi A4 B7 1.9TDi SE | Auto Lights, Wipers & Dimming Mirror | Cruise Control | DIS

    Mod's so far: Ambient light, Cupra R splitter, 4300k HID's, Painted Brake Calipers & Hubs, Dice Electronics iPod & Aux, Leather Armrest, Interior, Sidelight & Number Plate LED's, Curry Hooks, Tie Downs, Ambient Footwell LED's, Footwell Lights, Shadow Chrome S-Line (RS6) wheels, Mudflaps, Votex Rear Diffuser, RS4 Rear ARB

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    4
    Will test battery just to be sure,but seems to crank over well.

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    its a fake brake fluid level warning. the reservoir with its integral sensor needs changing.
    changed more than a few at work and they dont come back!

    theres many threads to search for on this fault.
    red_brake_warning_light_from_cold

    ive changed one since posting on the above thread. seems to have sorted it.

  9. #8
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,096
    Does the reservoir have the 2 prongs inside like the coolant version?

    If so, scratch the surface of the 2 prongs, these fixes the coolant level sender.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  10. #9
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    i dont think they do. you can pull the sensor out. but its just a black oblong bit of plastic that slides in from the side, theres a two pin plug to the cars loom.
    theres a little float and some mechanism inside the reservoir, never bothered chopping a reservoir up to find out how it works tho.

    all i know is ive fitted reservoirs, 8 or 9 in the past 2/3 years.........
    im guessing theres a bit of dirt/water in the sensor mech/float thats succeptable to cold for some reason that combinded with the drop in voltage on start up causes it to flash up.
    its not just diesels either, fitted one on a fwd red 1.8t, thats the most recent one a couple of weeks ago.

  11. #10
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,096
    Ah you see everydays a school day

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    May 2011
    Posts
    17
    mine had this fault when we bought it - the garage replaced it with one from another A4 they had in but it was still happeing so they had to take it into Audi and have a brand new unit fitted - touch wood its been fault free since.
    Audi A4 2.0 TDI Convertible (B7) in Phantom Black

  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2012
    Posts
    4
    Thanks for all the replies,will try this during the week and hope cures problem.

 

 

Similar Threads

  1. brake warning light
    By podders78 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 13th February 2012, 21:02
  2. Brake warning light
    By Goubo1 in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 4th February 2012, 13:57
  3. air bag light on and faulty brake light warning on dash ?
    By theviking in forum A4/S4 forum(B5 Chassis)
    Replies: 33
    Last Post: 5th March 2010, 17:45
  4. Brake Warning Light After Brake Pad Change
    By iddyarmin in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 1
    Last Post: 28th May 2006, 20:47
  5. Brake warning Light
    By imported_Smudge973 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 3rd January 2005, 19:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO