Monster MotorsportChris Nott
Results 1 to 22 of 22
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12

    audi a4 injector fault

    audi a4 injector fault
    hi there new to this forum i am looking at one of my frenids car he has audi a4 140 bhp engine code bre 55 reg .engine has mis fire put code reader on coming up with number 4 injector fault open ciruit.

    phoned local audi dealer and there said the engine code is not on recall list. is that correct ?

    i decided to remove injector to test it put omhs meter on it and there is a circuit am i testing it correctly ?

    if i replace the injector do i have to adjust the rocker arm nut if so what is the procedure

    any info welcome

    thanks peter

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    your lucky you have a fault code! fit an injector loom in it before doing anything else.

    if you didnt have a fault code but still a rough idle misfire.

    best procedure is to check the injector idle smoothness comparisons with the diagnostics. you'll see figures around 0.0 some maybe slightly more 0.78 or -0.65 for example.
    these need to be between 2.8 and -2.8 and as a rule within 2.0 of each other. but 2.99+/- is the max the ecu can adjust.

    if like a mk5 golf "bkd" we had in at work last week with a misfire, no.4 was bang on 2.99 after around 20 seconds of running. problem was on number 4.

    once youve nailed down which cylinder it is you need to do a compression check, you need to remove the injector rocker shaft and the glow plugs. buy a compression guage set with appropriate glow plug adaptor.
    doing the compression test after 8 compressions you should have 340-360 psi on each. if you have say 280 on the cylinder thats also out on the comparison check then its not the injector it just cant compensate enough for the lack of compression on that cylinder.

    but if all the compressions are bang on 340-360, then its highly likely its the injector thats at fault and the ecu is trying to compensate for that.

    with injectors being so expencive you need to look at the compressions first because ive seen both faulty injectors and loss of compression being a cause of a rough idle/misfire.

    that golf i mentioned it was the injector.

    reguarding adjusting the rockers you need to turn the engine till the rocker is on the peak of the cam lobe. turn the 6mm allen key till it tightens/has bottomed out on the travel of the injector. and back it off 270 degrees, 3/4 of a turn. tighten up the 18mm lock nut. move on to the next. turn the crank half a turn should see it spot on the next in the firing order.
    if you havn't got good access to the crank pulley to turn the engine. jack up the o/s/f wheel put it in top gear and turn the wheel forwards to turn the engine.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    how do i test the injector with a mulitmeter,can i test the wiring to the injectors if so what is the procedure.

    how much is the the new wiring loom

    thanks for the reply murran

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    dont think you can. aslong as its not open circuit. you could unplug one of the others thats not got a fault code and compare to the one that has?
    you can check the resistance of the injector plugs to the plug in the back of the head. rear it shows anything up tho.
    more often than not, its the little spade terminals that loose their grip on the injector pins.
    i think even a momentary loss in connection and the ecu records the fault and cuts out that injector.
    have you tried deleting the fault? does it clear or come straight back? does it still miss afterwards?

    think a new loom is about £80 ish.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    yes deleted code engine was still only running on 3 cylinders the code was p0204 injector open circuit.i have just tested all injectors with oms meter there are all the same i also checked all plug connector on all injectors all the same readings i put one lead to earth and the other lead to one pin the reading was 0.00 then i put it to the next pin connector the reading was 8.75 ,all the same could there be a machancal fault with in the number 4 injector.

  7. #6
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    Quote Originally Posted by peter donovan View Post
    could there be a machancal fault with in the number 4 injector.
    if youve established theres the same resistance thru the injector as one thats "ok" then id discount the injector as a suspect. this smells of wiring fault. if you have the tools and knowhow you could discount it totally by swapping it with, say number 3. rebuild it and run it if the fault code now changes to no.3 it is the injector, if it stays on 4 its a wiring or ecu fault.

    are you checking voltage or ohms with your multimeter? from and to where? just to earth. you need to find a wiring diagram and check it back to the ecu.
    i would fit a new head injector loom as these are a well known cause of all these problems due to the "versprung durch technic" fantastic idea of having wires, tiny weak terminals and brittle plastic plugs running in the engine oil, subjected to vast differing heat cycles, viabrations etc.

    also with the multimeter on the injector itself with it unplugged check you dont have any continuity to the head on either pin. this rules out a short to earth thru the injector. this is what causes the shut down of the injector drivers on the 170bhp tdi engines. not seen this on the bre/blb/bkd engine but worth checking reguardless of internal resistance from one pin to the other.

    i really would just fit a new injector/head loom before going any further.
    Last edited by murran; 19th February 2012 at 21:52.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    i am checking it on omhs setting i have chcked each pin to body no reading so injector would seem to be ok and not shorting to earth.if i was to swap the injectors will i have to adjust the 6mm allen on each one.or could i just put the cam back in with no adjustments or could it damage injectors.

    thanks peter

  9. #8
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    the injector should be ok if youve done those checks.
    if removing the injectors youd need to back the 6mm allen key adjustment off then unbolt the rockershaft. no need to do anything with the cam itself. theres two 6mm spline headed bolts either side of the injector unbolt these and turn the injector side to side a few times and bar it upwards (prybar it in the spring works well). the bolts holding the injector down are stretch bolts, advisable to replace them tbh. only torqued to 10-12nm i think!
    then reset the rockers in the way i posted above. pretty critical that theyre adjusted properly. and if you dont back them off before removal of the rockershaft you cant bolt it back on as the bolts arnt quite long enough.

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    hi murran swapped injector 4 with injector 3 then refitted rocker cover started engine still misfire on engine put code reader back on and come up with unit injector 4 electrical malfuntion.so i decided to buy a new wiring loom,fitted wiring loom started engine still seem fault on number 4 injector totaly pissed off put my mates snap on solus on data-smooth idle cyl 1=1.90 mg/s cyl2=0.26 mg/s cyl 3=0.21 cyl 4 =2.40 mg/s . could the fault be in the ecu.

  11. #10
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    just to clarify.
    you swapped no.4 inj. with no.3. cleared the codes, started it up, still misfired, and came back with fault on no.4?
    good atleast we know you dont need a £400 injector!

    so you fitted the new loom, cleared the codes, started it up, still misfired, and comes back up with the same fault on no.4?

    you need to rule out a wiring fault between the round plug on the back of the head and the ecu. you need a wiring diagram. or i can look it up at work and write down the pin numbers.
    the engine ecu is in the black box in the plenum on the o/s next to the servo/brake master. theres 5 or so 8mm headed bolts holding the top cover on (one is on the back edge and an arse to get to!) theres a spring clip holding down the ecu and two slidy plugs....... you need to check the resistance of the wires from the ecu plug to the round plug. also that you have no continuity to earth on either wire with both ends unplugged.
    if all is ok then then you can condemn the ecu.
    Last edited by murran; 20th February 2012 at 19:22.

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    thanks for info if you can me the pin info on the ecu to number 4 injector i will be greatfull.
    thanks peter.

    i will check tomorrow after work

  13. #12
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    boll0cks just got back from work, turned on the computer, then remembered i should have looked at the diagram for you. ive been doing a heater matrix on a 53 plate porsche boxster for most of today. my heads been on that. doh!
    sorry dude. i'll try to remember tomorrow.

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    hi murran got a wiring diagram vivid workshop data tested wires from plug on wiring loom to ecu for all four injectors all tested ok.
    its pointing to the ecu any ideas were i can send the ecu to get tested.

  15. #14
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    theres a place we send ecus to for testing at work. dont think theyre much good tho. they couldnt fault an abs ecu we sent them off an 06 plate a3 3.2q. we replaced it anyway as it was the only thing left that could be causing the wheel speed sensor fault we were getting.
    anyway it cured it.

    charged us £70 to look at the ecu and they were wrong.

  16. #15
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    North East
    Posts
    607

    Lightbulb

    Quote Originally Posted by murran View Post
    theres a place we send ecus to for testing at work. dont think theyre much good tho. they couldnt fault an abs ecu we sent them off an 06 plate a3 3.2q. we replaced it anyway as it was the only thing left that could be causing the wheel speed sensor fault we were getting.
    anyway it cured it.

    charged us £70 to look at the ecu and they were wrong.

    How about this company www.bba-reman.com
    No experience myself and no affiliation with them so its just a lead/suggestion .............


    Paul B7

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    bought one from ebay sent old one away to get codes of it to put on new one should get back on tuesday.cost me £254 cheaper than £706 + vat

  18. #17
    3rd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    North East
    Posts
    607
    Quote Originally Posted by peter donovan View Post
    bought one from ebay sent old one away to get codes of it to put on new one should get back on tuesday.cost me £254 cheaper than £706 + vat
    Two questions please;

    1) Are the ecu units specific to a specific engine code ?
    2) If the answer to the above is no and the ecu units are generic items who is taking the codes off your old ecu as you say you have sent it away ?
    Do you have to do this or can it be done with the Vagcom thingy by someone with access to such a unit ?




    Thanks

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    1,540
    yes engine ecu part numbers are specific to the engine code. but part numbers change from time to time as they are superceeded. then they need coding and the immobilizer programming.

    is someone programming the immobilizer then? its not a simple matter of transfering coding, like say an abs ecu, i dont think?

  20. #19
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    sent away to ecu express should get back on tuesday

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    12
    all sorted got ecu back running fine now

  22. #21
    Reverse Gear

    Status
    Offline
    Join Date
    May 2013
    Posts
    11
    Hey guys am new here and seen this post , I've got a 55 reg A4 2.0 TDI , BRE engine that judders at about 2k revs, had a diagnostic check done and it came back saying there is a problem with injector 2 and 3, basically one is over fuelling and the other is under fuelling

    what can be done to sort it and how can I check the ecu?

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    May 2013
    Posts
    11
    can anyone shed some light on this? if its the ECU could that be throwing the fueling out giving me the over fueling and under fueling ? would getting it re-mapped rule out it being the ECU ?

 

 

Similar Threads

  1. audi a4 injector fault
    By peter donovan in forum General Technical / How To
    Replies: 1
    Last Post: 19th February 2012, 09:29
  2. VAG reader threw up a injector fault but....
    By JDM82 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 3
    Last Post: 23rd September 2011, 08:11
  3. Audi A3 TDI injector
    By Grako in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 23rd April 2010, 12:26
  4. Diesel injector fault
    By ArdupinanAudi in forum Diesel forum
    Replies: 3
    Last Post: 13th July 2006, 21:11
  5. 1992 Audi S4 stock injector size
    By 92S4 in forum Classic Audi Forum
    Replies: 0
    Last Post: 11th August 2004, 17:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO