Badger5Sky Insurance
Results 1 to 11 of 11
  1. #1
    camscockle20vT's Avatar
    The stigs ugly brother

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1,673

    2.0tdi s-line common problems?

    Hi all

    Im a local on the old 8l section, and i have a friend that is going to buy a 2006/2007 A4 tdi s-line, and wondering if there are some tell tail signs to watch out for when viewing a few, i know the injectors are a problem, is the cambelt change a PITA? And is the gearbox reliable at 100k miles? Thanks and likes for any help also

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    39
    Injectors only a problem on the 170pd, not on the 140. But you knew that

    2007 A4 Avant 2.0pd 170 quattro S-line special edition
    1990 VW T3 Westfalia Atlantic 2.1 wasserboxer running lpg

  4. #3
    lenti's Avatar
    Sixth Gear

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Sweden
    Posts
    74
    I've had mine since 2007 and i have not changed anything at all yet :D i love the car really :D
    Audi A4 2.0TDI 2007 B7 S-Line & Proline
    Bluefin Superchip
    218HP/443NM
    RS4 Rims
    _________
    For more pics visit my FB http://www.facebook.com/MR.Doberlluka
    For all my mods visit http://www.garaget.org/lenti
    and http://www.audizine.com/forum/member.php/73213-lenti look @ my started threads

  5. #4
    camscockle20vT's Avatar
    The stigs ugly brother

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1,673
    Quote Originally Posted by SebRogers View Post
    Injectors only a problem on the 170pd, not on the 140. But you knew that
    No i didnt, thanks for the heads up

  6. #5
    camscockle20vT's Avatar
    The stigs ugly brother

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1,673
    Quote Originally Posted by lenti View Post
    I've had mine since 2007 and i have not changed anything at all yet :D i love the car really :D
    Good going then dude, iv had my 1.8t just over a year and lets leave it at that lol

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    39
    Also... multitronic seems to cause problems (not sure if the s-line spec was available with it though). I would've thought a manual gearbox of that vintage / miles should be fine, seeing as it'll have spent most of its life on the motorway. 4 cylinder cambelt change simpler and cheaper than 6, AFAIK, so the 2.0 among the cheaper engines to sort. Early 2.0 140 engines have had oil pump drive issues (see the thread near the top of the page for this) - the later ones are supposed to be better, but I'm not sure when the change from chain to gear drive was made. Injector issues on 170pd engine no longer really an issue because Audi will sort FOC. The 170's noticeably pokier and revs freely but is quite thirsty - it's not what most people would consider an economical engine to run. The 140 may be a better compromise if you're not bothered about outright grunt.

    HTH!

    2007 A4 Avant 2.0pd 170 quattro S-line special edition
    1990 VW T3 Westfalia Atlantic 2.1 wasserboxer running lpg

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    14
    had my 57 plate 20 tdi s-line(140) for 8 months, had a fair few bits need replacing but I did get it a 90k. each one was causing a problem, the list is as follows.

    vacuum pipe(ramdomly go into limp mode)
    turbo pipe(boot it hard to 4.k revs it would go into limp mode)
    egr valve(jerky setting off)
    oil level sensor(oil light would come on)

    the worst issue I had was the coolant light come on, it appeared that the oil cooler bust throwing oil into the coolant. this cost me a new thermostat, coolant bottle, oil coolant and a good flush through.

    its never driven better since, tons of torque and power, i wouldnt change it for anything.

  9. #8
    sidibear's Avatar
    Looking for Zombies !!

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Birmingham UK
    Posts
    2,007
    I have had my 140 08 B7 avant 2.0tdi auto for just over three years, 6 months old when I got it with 6200 on the clock, now showing 77500. Had the same issue with the oil cooler going bang which Audi watery Lane sorted as a courtesy. The DMF was replaced around 3k miles ago. The flap motor went in the aircon and was replaced. Also had the oil level sensor go which caused the low oil light to come on, turned out to be a broken wire though. The catch on the armrest has broke, many many miles ago.
    Cambelt changed and gearbox oil changed at when it should be, also had the brake fluid changed but will need doing again soon as the car is nearly four years old. Fuel filter also needs to be changed soon as its nearly 80k. Third set of tyres on the front, second set on the rear. A good 90% of the miles are motorway 65 / 75mph, I don't drive fast as the car is so nice to drive you never want to arrive.

    JSD 2.59
    Synergy-Solutions

  10. #9
    camscockle20vT's Avatar
    The stigs ugly brother

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1,673
    Hi all

    Thanks for all the replys. So i take it that the moral of the story is these are good engines, and if its made it to 100k then its probly had most of the common stuff sorted by then. My freind is buying one this weekend so ill post pics up when hes got it. Looking for a red, black or nagro blue sline 2.0tdi and got about 7k to spend.

  11. #10
    DJM1982's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Essex
    Posts
    392
    hi,
    I have a 2006 2.0 TDI 140 (remapped to 180bhp, ish) Sline. I bought i 2.5 years ago with 68k and it ticked over 127k today on the way home from work.
    Things i have had to replace:
    Heater Matrix (broke, and even audi themselves were shocked as they said it was very rare) £750
    Cam Belt & water pump, but this is just general maintenance.

    Thats it, apart from regular services etc.

    The only other issue i have at the moment is that mine wonders when driving, but my mechanic has informed me that its down to the shocks (being knackured). So i'll be replacing them next month to solve this issue.

    hope this helps.

    2006 Audi A4 Sline
    AMD remap to 175bhp, bilstein Shocks with Eibach 30mm lowering springs, spacers to follow very soon (then finished)

  12. #11
    camscockle20vT's Avatar
    The stigs ugly brother

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1,673
    Hi all

    Wev only gone and bought an 05 plate audi a4 2.0tdi sline for a steal its not the colour my mate was lookin for but for the money hes paid it was worth the comprimise. Heres a pic but my mate is joining asn soon so ill leav the full write up to him lol thanks again for all the help and opinions, you A4 guys aint that bad lol

 

 

Similar Threads

  1. S3 common problems
    By brads in forum A3/S3/Sportback (8P Chassis)
    Replies: 19
    Last Post: 16th October 2010, 08:26
  2. Common place for oil to leak on a 2.0tdi engine?
    By fozworth in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 0
    Last Post: 3rd September 2010, 22:22
  3. Steering Problems A4 S-Line 2.0TDi (143)
    By raymieherron in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 6
    Last Post: 15th June 2009, 20:06
  4. Remap on new A3 2.0tdi 140 Common Rail
    By frenchy2475 in forum Custom-Code UK
    Replies: 1
    Last Post: 13th February 2009, 11:14
  5. Common problems?
    By golf in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 3rd February 2007, 19:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO