AH FabricationsSky Insurance
Results 1 to 8 of 8
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2010
    Posts
    25

    Smile ESP Warning Light Fault..

    Help..

    I've got a problem with my 2005 B7 1.8T A4 (not quattro).

    The warning light on the dash is not coming on when I start the car or by pressing the ESP button. The traction control seems to be working as it should but the light does not come on when it kicks in.

    This may be unrelated but it started playing up after the car was left over the xmas break for a few days and I checked my tyre pressure's and found my two rear tyres to be low (now all at 32psi as per door pillar label.)

    I've checked the two fuses for the ESP Both okay, when I removed the 10amp one and started the car it triggered the DIS panel warning for the brake system, So it seems as though its working.

    I've checked the brake light bulbs/switch, ABS works fine, no other dash warnings, car drives fine, Battery Volts 12.2v

    Do the dash warning LED's go bad.?
    Any ideas..??
    Last edited by Ekco163; 29th December 2010 at 19:02.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    kite's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Oct 2007
    Location
    East Berks
    Posts
    659
    a vagcom scan would be a good place to start

  4. #3
    4th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    765
    How do you know that it is working?Can you see any diff by pushing the button if so I guees it must be the led I have lost some in my light switch but can live with that

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2010
    Posts
    25
    No didn't try pushing the switch. Didn't get uncontrolled wheelspin when testing the car it acts the same as before the light problem, not very scientific i know..:-). Hope its not the LED, dont fancy getting a new dash panel.

    I've not got Vagcom but starting to wonder if it would be a good investment..

  6. #5
    danotto's Avatar
    VAG HUNTER

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Berkshire
    Posts
    1,084
    i had a problem with my esp light staying on randomly and couldnt switch it off turns out it was a faulty brake pedal switch
    A4 TDI S-LINE

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Dec 2010
    Posts
    30
    sorry to butt in a little in tis thread, question for danotto. My ESP light seems to come on randomly until either reset (cleared using vag com)or somtimes when the car is switched off and on again. How did you find out it was a brake pedal switch? and where is it located?

  8. #7
    danotto's Avatar
    VAG HUNTER

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Berkshire
    Posts
    1,084
    a mate had vagcom,and it showed up brake pedal switch internal fault.so he changed it for me whilst on holiday,not 100% sure where exactly it is fitted but im guessing its on top of the brake pedal lever,as my old audi s3 was there also.
    A4 TDI S-LINE

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2010
    Posts
    25
    Update - Disconnected the battery last weekend and noticed that the esp light came on when starting the car after reconnecting, then It went out and didn't come back on even when pressing the switch. Then this morning when starting it came on and worked as normal, done about 70 miles, so it must have been sorting itself out..??
    Last edited by Ekco163; 7th January 2011 at 18:25.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO