Chris NottEM Tuning
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    20

    Exclamation Help required asap!

    Afternoon all, Merry Xmas too!

    Right basically i currently have an Audi A4 B7 2.0tdi, last night driving back from Stockton on Tees, my oil pressure light decided to pop up! So i pulled over into next service station checked the oil and it was fine.

    Drove off as soon as i got onto the motorway the oil pressure light popped up again and through the car into limp mode, and the engine management light came on. So i called Audi recovery who then brought the car home.

    Does anyone! Have any idea what this could be related to? The car was serviced about 3months ago, Oil level is fine too.

    i have been told it could be the oil pump or blockage of the oil being built up (sludge) due to the cold!

    Help please!

    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    You'd be better off asking in the B7 section, but I think the early 2.0TDi's suffered with the oil pumps failing. From memory the teeth which drive it are made of plastic and either wear or break away. I think there is a sticky in the relevant section which may help you.
    Ingolstance Read about my A6 HERE.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    20
    Thanks for the reply and sorry to be a pain by any chance can you direct me to the thread?

  5. #4
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,856

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    It looks like the post has been moved into the B7 section now, the thread is here:

    2.0 TDI oil pump / balance shaft failure?
    Ingolstance Read about my A6 HERE.

  6. #5
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,491
    i dont get why people check the oil when the oil preasure warning light pops up
    its not telling you its low on oil
    if the pump had gone or blocked its gona cost to get fixed
    unless your under warranty

  7. #6
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Pray for the warrenty fix. Good luck

  8. #7
    Wrath's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    North East, UK
    Posts
    1,185
    Sounds like the dreaded oil balancer shaft issue.
    Nathan

    Red Audi A4 B7 S-Line with Leather/Alcantara interior

    Current Mods: Painted Brake Calipers, Gear-driven oil shaft assembly, RS4 grille, Debadged, B8 MFSW, Cruise Control, RS4-style Fog Surrounds, Satin Black Cupra R Splitter, RS4 RARB, Clear Corner headlights, 2011 RNS-e, MTEC Drilled and Grooved Brake Discs.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO