AH FabricationsMonster Motorsport
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    10

    Performance probs after fitting EGR blanking plates

    2006 Audi A4 B7 2.0TDI

    I wonder if anyone can help?

    Yesterday, I had the EGR valve blanked off using two blanking plates.
    The chap that did the work is a mate that works for Audi. Admittedly, he had not performed this mod before but obviously knows where everything is, etc. Anyway, he blanked off the EGR valve and I gave the inlet manifold a thorough clean.

    Once the work was done, I drove off for a test drive. The engine warning light appears on the dash but I was half-expecting that, from having read all of the various threads about EGR blanking/delting.

    The real concern for me is that the car’s performance has taken a turn for the worse. The turbo doesn’t kick in for a lot of the time when accelerating. It comes on now and again but it is intermittent. I’m not sure but I think the car may be going in and out of ‘limp home’ mode.

    I spoke with my mate about the problem and we think the light on the dash and the performance issue are related. He thinks it may have something to do with the MAF sensor but we aren’t sure.

    I’ve read on the threads about EGR blanking that you should also remove and block a hose vac that connects from the EGR valve to a solenoid. However, on my car I couldn’t locate such a vac hose. The only vac hose I could find was connected to the turbo actuator front left of the engine cover. However, blocking this made no difference.

    I am loathe to pay a tuning company money for diagnosing the problem and cancelling the dash light if some kind soul out there could perhaps advise further, preferably someone with an A4 B7 TDI.

    Many thanks,
    Dave

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    10
    Hi everyone,

    I have an update....

    I asked Superchips if they could write in an EGR delete into my remap. They charged me Ł50 plus VAT and promptly sent me the new map. I used my Bluefin device to d/load the new map to my car.

    The engine warning light disappeared but the car was still going in and out of Limp Home Mode (LHM). Next day, I started the car up and the light was back on the dash

    I emailed Superchips, who are very helpful, to be fair. They mailed me back saying that the fault code would need to be cleared and the EGR delete in the mapping would prevent the light from reoccuring.

    Anyway, I located someone locally with VAG com. This chap scanned for fault codes and there was just the one showing:
    1 Fault Found:
    001027 - EGR Valve (N18): Malfunction
    P0403 - 000 - - - Intermittent
    Freeze Frame:
    Fault Status: 00100000
    Fault Priority: 0

    Fault Frequency: 4
    Mileage: 88859 km
    Time Indication: 0

    Freeze Frame:
    RPM: 798 /min
    Speed: 1.0 km/h

    Duty Cycle: 84.4 %
    Voltage: 13.76 V
    Mass Air / Rev.: 480.0 mg/str
    Duty Cycle: 41.4 %
    Bin. Bits: 00000000

    The fault code was promptly cleared and fingers crossed!
    I got back into my car, started it up and drove off. Right
    away, I could tell that the car was in LHM even though the
    light had gone. We tried to clear further EGR fault codes
    but it looks like they keep coming back

    I don't understand, as once the fault code is cleared, the
    ECU should now not be able to 'see' the EGR valve because it
    has been deleted out in the remap.

    I AM STUMPED!!!

    I've already asked my mate to remove the blanking plates this
    weekend and I just don't think you can do this on the B7/later
    models.

    However, I would love for someone to let me know if they have
    had any success with blanking the EGR on the later 2.0TDI.

    Thanks,
    Dave

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Sep 2011
    Location
    south yorkshire
    Posts
    30
    hi mate did you sort out the problem? what engine code do you have? ive got a bpw engine code and looking to delete the egr but they dont make a pipe so am goner have to use the plates and leave the egr on the car and get it mapped out. this is pretty much what you have done? did you remove the cooler aswell?

  5. #4
    JayD's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Bedfordshire
    Posts
    16
    Hi I've also got the BPW engine, would be great to know if you solved this and how?

  6. #5
    Heisenberg's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Manchester
    Posts
    65
    Best speaking to Rick at Unicorn Motor Developments he's on the forum, he did dpf/egr delete and remap for me and it's spot on

    Genuine Full VCDS - PM for details (Manchester)

  7. #6
    AudiB7Jay's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    374
    What do you gain from blanking the egr valve? Apart from problems

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2014
    Posts
    4
    Tuffguy I seem to be having exactly the same problems after fitting the plates, did you finally get it fixed?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO