Sky InsuranceAH Fabrications
Results 1 to 10 of 10
  1. #1
    Neutral

    Status
    Offline
    Join Date
    May 2009
    Posts
    52

    Bit broken off A3 compressor (Sanden) - Fixable???

    Hi all,

    Noticed the Econ light wasnt going off on my 8P A3 Sportback - had a feel around and basically the bit that connects to the wiring loom (I think) has broken off - dunno how this happened, but happened it has.

    I dont have a pic to hand, but its basically the black bit on the bottom right of the pic here:

    http://www.hypershop.org/proddetail.php?prod=12988

    Its broken at a 45degree angle and the bit that has come off has half of the copper connectors in it -

    Q is, do i have to replace the whole thing or would it be possible to solder/drill it back on to connect it again? The compressor itself looks fine, its just that the electric connector is broken off and cant tell the compressor to fire up!!

    Cheers in advance for the help!

    T

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,168
    Impossible to say without a picture but even if it's repairable could you get to it with a soldering iron?

    If not then the compressor would need to come off which involved recovering the refrigerant from the system, doing the repair and then filling it up again.

    Most garages would just want to replace the whole unit in that case.
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    May 2009
    Posts
    52

    Cheers Staz

    Folks, including pics of:

    1) Compressor as it should be - the bit thats broken off my un is on the bottom right hand side



    2) My compressor without the black electrical connector - basically viewing it side on compared to the previous pic



    3) The culprit - whats left of the connector



    (Hope i got those images up ok - first go (Cheers Staz))

    It appears that there may be enough to go on to fix it - the rest of the compressor is sound enough. Was thinking of soldering the two connectors together and then carefully putting a fine screw in to hold the two bits together or using some seriously strong glue.

    I would just order a new compressor but my pockets arent bulging due to shelling out for a new DMF. Failing that, does anyone know if it would be possible to remove the same bit from a broken compressor of the same type (I think i see a socket for removing that section - correct me if im wrong!) and wanging it on my one?

    Any help would be appreciated!!!

    T

  5. #4
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,168
    You did that faster than I expected! lol

    Right well thankfully there's some bare area of the pins still attached to the compressor.

    I see the bolt you mean but I'm not sure that it'll give way to being able to replace the connector.

    You could try sending a PM to H5DJR and ask if he'll graciously help you look up the compressor on his parts list and see what can be replaced. You need to include all the details about your car model and engine so he can find it.

    I don't think you'll be able to find anything though to be honest. I have tried to strip things down before and found that the bolts don't actually make things come apart like you expect.

    To do a repair it's all down to how good you are with a soldering iron and heat shrink. No garage would touch you of course! If it were me I'd have a go. I've repaired worse lol
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  6. #5
    tdisportuk's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    UK
    Posts
    459
    mate i believe its a non-serviceable 'solinoid' clip? 90% sure the unit has to be replaced. my compressor had its ups and downs i think it just needs to be regassed now and should be find but i removed my old one due to it had mind of its own worked when it wanted to work and the clip like yours broke when it was removed. my mate needed a part (the park you need) so he tried to remove the whole clip and join the two bits back together. Once he managed to remove it by breaking the sealed solinoid clip a medium sided rod came out of it with no part number, so i guess its not possible but i may be wrong!

    good luck

    managed to pick up a recon pump from ebay 75
    Audi A3 2.0 tdi sport..many mods to follow...just too fussy when it comes to making decisions!

  7. #6
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    I would straighten the pins and use some small spades to make a short loom to tie in with the OEM wiring. Once a good connection has been established maybe a dolop of hot glue to insulate/hold the spades on would be fine

  8. #7
    Neutral

    Status
    Offline
    Join Date
    May 2009
    Posts
    52

    Cheers!

    Thanks for the help folks.

    Replacing the clutch on my a3 this week (well, my mechanic brother-in law is!) and showed him the pics above. While he's in there, he said he'd take the compressor off - He seems confident that he can solder it back together again - so will keep you posted on progress!!

    On a related side note - obviously will need to regas the system - do Kwikfit still do the 50 approx offer for this? Seem to remember summat on this a few months back..

  9. #8
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,168
    It's not as simple as a regas though. If he's going to take the compressor off to work on it the whole system will need a deep vacuum before being refilled. Not sure how good quickfit are when it comes to going a bit further than just a recharge.
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

  10. #9
    Neutral

    Status
    Offline
    Join Date
    May 2009
    Posts
    52

    Update

    Guys, just an update on this..

    Bro in law fitted new DMF and clutch today (great success!) and took off the compressor. Basically said remnants of bit that had been broken off was useless, then set about soldering spade connections and wiring it into the main system, bypassing the plastic connectors. As the gas has gone (having taken off compressor) the airconditioning isn't pumping out - but as you attempt to turn it on the compressor DOES kick in, then switches off as it realises there's no gas - it didn't do this before, there was no connection at all.

    So, does this sound that it may have worked? He seems v hopeful all is ok as the error code has gone also relating to the compressor.. As staz suggested, taking this to an aircon specialist Monday, he's going to give it a weigh, vacuum out and a regas, so fingers crossed-keep you posted again!

    Cheers for all the help!

  11. #10
    Staz's Avatar
    is a retronaut

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Bristol (mostly)
    Posts
    6,168
    Sounds good mate!
    8P2 S3

    For advice on Air Con problems please read my FAQs.
    To find ASN members with VCDS check out the MAP.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO