AH FabricationsEM Tuning
Results 1 to 4 of 4
  1. #1
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2010
    Posts
    313

    A/C issue on B8 Avant - wiring problem?

    A/C doesn't work! Had gas checked and it is OK. Ran a VCDS scan and got the below.

    Should note that I had a similar issue in June 2011, fixed under warranty - I don't know the details (didn't run a scan that time) but they said it was a wire that needed replacing.

    Annoyed as the car had main dealer service and MoT in Jan while still in warranty (just) and they didn't pick up on the fault codes (dated Dec 2012) as Audi say they don't routinely run a fault code diagnostic when doing a service / health check!?!? Now they want £145 just to investigate and find out what is wrong!?

    Faults indicate a communication error between the main switch panel (J255) and the central electronics module (J519), A/C Pressure/Temperature Sensor (G395) and Air Quality Sensor (G238). Then errors between the central electronics module (J519) and the A/C Pressure/Temperature Sensor (G395) and Air Quality Sensor (G238).

    Anyone had a similar issue, know where these sensors are or how I could check them? Is it easy to take the main switch panel out and check for a loose wire behind? Would the J519 communicate with G395 and G238 via J255 (in which case it could be a dodgy bus connection on J255?

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC (J255) Labels: Redir Fail!
    Part No SW: 8T2 820 043 AF HW: 8T2 820 043 AF
    Component: KLIMA 3 ZONEN H08 0171
    Revision: D0000000 Serial number: 01111120090412
    Coding: 66140000
    Shop #: WSC 06335 000 00000
    VCID: 76E7BE01C1C445A80B0

    3 Faults Found:
    00457 - Control Module for Network (J519)
    013 - Check DTC Memory

    Date: 2012.11.22
    Time: 15:46:18

    00256 - A/C Pressure/Temperature Sensor (G395)
    008 - Implausible Signal

    Date: 2012.11.22
    Time: 15:46:18

    Freeze Frame:
    Temperature: 12.0°C

    01592 - Air Quality Sensor (G238)
    004 - No Signal/Communication

    Date: 2012.11.22
    Time: 15:46:20

    Freeze Frame:
    Temperature: 12.0°C

    -------------------------------------------------------------------------------
    Address 09: Cent. Elect. (J519) Labels: 8K0-907-063.clb
    Part No SW: 8K0 907 063 N HW: 8K0 907 063 N
    Component: BCM1 1.0 H25 0380
    Revision: 09025001 Serial number: 00000000507984
    Coding: 260050914034AF010001000000001D0D0F1D470A0001014100 0000
    Shop #: WSC 06335 000 00000
    VCID: 3A7F6A31B55CE1C82F8

    Subsystem 1 - Part No SW: 8K2 955 119 A HW: 8T2 955 119 Labels: 1KX-955-119.CLB
    Component: WWS 061109 H05 0070
    Coding: 00FD11

    Subsystem 2 - Part No SW: 8K0 955 559 HW: 8K0 955 559 Labels: 8K0-955-559.CLB
    Component: RLS H04 0003
    Coding: 025028

    Subsystem 3 - Part No SW: 8K0 941 531 AL HW: 8K0 941 531 AL
    Component: E1 - LDS H08 0090

    2 Faults Found:
    00256 - A/C Pressure/Temperature Sensor (G395)
    004 - No Signal/Communication

    Date: 2012.11.22
    Time: 15:46:00

    01592 - Air Quality Sensor (G238)
    004 - No Signal/Communication

    Date: 2012.11.22
    Time: 15:46:00
    -------------------------------------------------------------------------------

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Tankman's Avatar
    Neutral

    Status
    Offline
    Join Date
    Dec 2006
    Posts
    54
    Don't know if I have any of those fault codes as car with dealer and repairs being done under warranty. However, I had exactly the same symptoms. Temperature sensor is currently on back order so the car will be with them for a week at least.

  4. #3
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2010
    Posts
    313
    There are a number of reasons why the a/c might stop working even when gassed, my problem is that I don't know if its a faulty sensor (like yours seems to be) or a dodgy wire!

    Given the time stamps on my error codes, I think mine is more likely to be a wire as two sensors 'failed' at the same time and there is a reported comma error between two components that are working.

    If anyone has a wiring diagram of the A/C system that would help identify where likely dodgy connections might be?

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    May 2013
    Posts
    1
    Quote Originally Posted by elrao View Post
    There are a number of reasons why the a/c might stop working even when gassed, my problem is that I don't know if its a faulty sensor (like yours seems to be) or a dodgy wire!

    Given the time stamps on my error codes, I think mine is more likely to be a wire as two sensors 'failed' at the same time and there is a reported comma error between two components that are working.

    If anyone has a wiring diagram of the A/C system that would help identify where likely dodgy connections might be?

    Welcome. I am of Polish and I have the same problem was putting a new sensor, it did not work ... , (Or did you determine the cause? Greet

 

 

Similar Threads

  1. s4 avant alarm problem
    By wee ped in forum A4/S4 forum(B5 Chassis)
    Replies: 0
    Last Post: 8th February 2008, 01:38
  2. Avant trivial problem
    By JohnboyC in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 9th October 2007, 01:54
  3. A4 Avant Auto Problem
    By bullyrag in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 4
    Last Post: 14th September 2007, 16:29
  4. Wiring problem with aftermarket sub/amp/HU
    By jamies in forum In-Car Entertainment
    Replies: 1
    Last Post: 21st February 2007, 11:30
  5. A6 Avant radio problem
    By fjtwelve in forum In-Car Entertainment
    Replies: 0
    Last Post: 20th June 2006, 18:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO