Badger5AH Fabrications
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By desertstorm

Thread: RS6 won't start - fuel pump issue

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    South Bucks, UK
    Posts
    17

    My Social Networking

    Follow bigcw On Twitter

    RS6 won't start - fuel pump issue

    I have a non-starting RS6 stuck on the driveway.

    The history is that it had a water leak into the boot which destroyed the battery management module. That has now been replaced, but since then the car won't start. It just cranks over but doesn't fire.

    VCDS suggests:


    012425 - Signal Line for Fuel Pump Electronics: Electrical Malfunction
    P3089 - 002 - Lower Limit Exceeded

    Does anyone know what this actually means in real terms?

    Thanks, Chris
    My cars, in age order:
    Audi RS6 V10 | MR2 mk2 w/3.0 v6 conversion | 306 Cabrio w/3.0 v6 conversion | 87 XR2 w/2.0 Zetec | 82 XR3 w/1.8 Zetec
    Audi Remapping in Buckinghamshire by GX Tuning

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    5th Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    Heath Hayes
    Posts
    951
    19545/P3089/012425 - Ross-Tech Wiki

    19545/P3089/012425 - Signal Line for Fuel Pump Electronics: Electrical Malfunction
    Possible Solutions

    Check/Replace Transfer Fuel Pump (G6). See Special Notes
    Check/Replace Fuel Pump (FP) Control Module (J538).

    Special Notes

    When found in the M.Y. 2006 - 2007 NAR BPY 2.0T FSI engine see:
    TSB 01-08-06 -or- TPI 2017131 which mentions "updated" electric/transfer (in tank) fuel pumps.


    http://www.s4-mtm.com/images/RS6-C5StudyGuide.pdf page 26 - 28

    If you put the car details on year , engine code etc I could get you the wiring diagram off Elsa Win.


    Karl.
    Karls 312bhp A4 3.0 TDI build thread http://www.audi-sport.net/vb/audi-s4...ld-thread.html

  4. #3
    5th Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    Heath Hayes
    Posts
    951
    Just had a look at your previous threads and can see you have a new shape rs6 with the V10 not the V8 .
    Looking on Elsa Win your car also has a fuel pump control module J538 .
    Looks like it's on the back of the cover on the boot floor. So wouldn't be suprised if water has got in there and corroded a wire possibly.


    RS6 fuel pump wiring.jpg

    RS6 FUEL PUMP 1.jpg

    rs6 fuel pump 2.jpg

    rs6 fuel pump 3.JPG

    rs6 fuel pump 4.jpg

    rs6 fuel pump 5.jpg

    rs 6 fuel pump 6.jpg

    Karl.
    bigcw likes this.
    Karls 312bhp A4 3.0 TDI build thread http://www.audi-sport.net/vb/audi-s4...ld-thread.html

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    South Bucks, UK
    Posts
    17

    My Social Networking

    Follow bigcw On Twitter
    Hi Karl

    That's really helpful, thanks a lot. Yes, I have the V10 RS6 Avant, C6 shape, 2009.

    I had been told that the pump control unit was under the car between the body and the fuel pump which is why I hadn't investigated further but it looks from your instructions that it's actually accessible without getting the car up in the air. I'm sure I've opened that inspection cover already though.

    Are those instructions definitely for the Avant version? The reason I ask is that I've taken the oval inspection cover shown in the instructions out already and there was very little under there, just a hose connecting to the tank by the look of things, no sign of any electronic modules. The picture actually looks more like the cover under the rear seat where the infamous fuel tank sender plugs in.

    Is there any other (more specific) indication in Elsa as to where the J538 module is located?

    Thanks again for looking into this for me.

    Cheers, Chris
    My cars, in age order:
    Audi RS6 V10 | MR2 mk2 w/3.0 v6 conversion | 306 Cabrio w/3.0 v6 conversion | 87 XR2 w/2.0 Zetec | 82 XR3 w/1.8 Zetec
    Audi Remapping in Buckinghamshire by GX Tuning

  6. #5
    5th Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    Heath Hayes
    Posts
    951
    Had another look at Elsa Win, there are many different options for the fuel tank system on the A6 and I think I got the wrong one. Above is for the smaller petrol engined cars. Of course on the RS6 they have to make it difficult.
    It appears you have to drop the tank a bit to be able to get to the module.
    It's held on by the two bolts marked in the picture. But to be able to pull it through the hole into the car the tank has to be dropped down a bit, not removed completely just bolts undone to allow the module to be removed. I presume you have checked all the connections on the fuel tank connector already.

    RS6 J538 pump module.JPG

    If you PM me an E-mail address I will send you the correct instructions for getting the module out.

    Karl.
    Karls 312bhp A4 3.0 TDI build thread http://www.audi-sport.net/vb/audi-s4...ld-thread.html

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    South Bucks, UK
    Posts
    17

    My Social Networking

    Follow bigcw On Twitter
    That looks a lot more like what I have. I've not checked the connections yet but will go out there now as it's light and has stopped raining.

    Does Elsa have a part number for the fuel pump module? There are several on eBay, just want to check if they are the right ones.

    Will pm you my email address now.

    Thanks again for the help.

    Chris
    My cars, in age order:
    Audi RS6 V10 | MR2 mk2 w/3.0 v6 conversion | 306 Cabrio w/3.0 v6 conversion | 87 XR2 w/2.0 Zetec | 82 XR3 w/1.8 Zetec
    Audi Remapping in Buckinghamshire by GX Tuning

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    South Bucks, UK
    Posts
    17

    My Social Networking

    Follow bigcw On Twitter
    Ok, no voltage output at all to the fuel pump, which is as suspected I guess.

    The control module is wedged up above the tank, no chance of getting it out without dropping the tank down as you say. I would appreciate a copy of the instructions (have PM'd you my email address) to do that but I suspect I don't have the resources to do it here ie a ramp.

    The only thing I could do would be to undo the tape and 'pin' the wires leading to the module but I'm a bit reluctant to do that in case it has to go to Audi eventually and it upsets them that it's botched.

    Annoyingly the module, from what I can see from peering down the gap, doesn't look like any of the ones on eBay. It's in a little plastic carrier for one thing, not screwed directly to the bodywork. I can get a screwdriver in there and get it out of the holder but no chance it's going to squeeze through the gap between the body and the tank.

    The other thing I would be interested to check is where the module is powered from. I assume there will be a fuse for it. Any clues as to which one it is?

    Chris
    My cars, in age order:
    Audi RS6 V10 | MR2 mk2 w/3.0 v6 conversion | 306 Cabrio w/3.0 v6 conversion | 87 XR2 w/2.0 Zetec | 82 XR3 w/1.8 Zetec
    Audi Remapping in Buckinghamshire by GX Tuning

  9. #8
    5th Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    Heath Hayes
    Posts
    951
    According to ETKA the part number for the module J538 is 4f1906093 looks to be around the £90 mark.

    Karl.
    Karls 312bhp A4 3.0 TDI build thread http://www.audi-sport.net/vb/audi-s4...ld-thread.html

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2010
    Location
    South Bucks, UK
    Posts
    17

    My Social Networking

    Follow bigcw On Twitter
    Breathing a sigh of relief as the car has started after 10 days of being stuck on my driveway.

    For anyone reading this in the future, there is a separate fuseable link inside the battery positive terminal, yes *inside*, you need to pop the plastic cover on the terminal open to see it. This feeds power to the fuel pump controller which in turn feeds the pump.

    This link had popped although it was difficult to spot that it had done so as from a casual glance it looked in tact. I assume this had happened due to the wire being wet and shorting against the bodywork.

    The link is equivalent to a 30A fuse. I didn't have the proper link so I've wired a 20A blade fuseholder across it temporarily which cleared the issue. I'll have to go to Audi and buy the proper link at some point.

    Note that the fuse in the left side of the dash (right hand drive car) in brown position 1 just powers the pump relay not the pump itself. Your guess is as good as mine why it's a 30A in there when all it does is power a relay. Perhaps it's different on the non-RS cars where the pump controller is elsewhere.

    Huge thanks to Karl for all his help, and for finding the key bit of information in Elsa to point me towards the fuse. I was honestly about to give up and trailer the car to Audi.

    Cheers, Chris
    My cars, in age order:
    Audi RS6 V10 | MR2 mk2 w/3.0 v6 conversion | 306 Cabrio w/3.0 v6 conversion | 87 XR2 w/2.0 Zetec | 82 XR3 w/1.8 Zetec
    Audi Remapping in Buckinghamshire by GX Tuning

  11. #10
    5th Gear

    Status
    Offline
    Join Date
    Nov 2013
    Location
    Heath Hayes
    Posts
    951
    Glad you have sorted it Chris, Turned out to be a cheap and easy fix in the end which are the best ones .
    ETKA doesn't actually show a 30A fuse part number but it is N 109 241 01 looks to be about £2 .

    Sicherungen

    karl
    Karls 312bhp A4 3.0 TDI build thread http://www.audi-sport.net/vb/audi-s4...ld-thread.html

 

 

Similar Threads

  1. Odd starting. Fuel pump suspected?
    By Gops in forum A3/S3 Forum (8L Chassis)
    Replies: 18
    Last Post: 6th July 2013, 20:06
  2. S3 fuel pump issues
    By jemis in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 5th November 2011, 22:20
  3. Intermittent non-start. Fuel pump circuit (I think) HELP!!!!!!!!
    By bertracoon in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 26th May 2011, 17:02
  4. Fuel Pump issues
    By a-list in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 9th November 2010, 20:29
  5. 2.5 TDI Quat won't start - electric pump in fuel tank help !
    By RogerTDI in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 30th July 2007, 10:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO