AH FabricationsSky Insurance
Results 1 to 10 of 10
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    1

    Help required with 2006 A6 fuel gauge issues

    I have a 2006 A6, 2.0tdi 140,

    after fuelling my car last night, the gauge did not move from empty to full despite having put in 60ltrs of diesel,

    I have travelled 150 miles today with the warning symbol on and the gauge reading empty...with no performance issues.

    is this a common fault?

    what is typically the fault?

    any fault codes to look for with vag.com?

    Thanks in advance,

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Avantageous

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Hampshire
    Posts
    337
    Strange issue. All I could guess is the fuel sender gauge in the tank is faulty.

    Mine has a similar problem, but that's more down to the mpg and a heavy right foot!
    2011 Audi-Sport.net Fantasy Formula 1 Champion

    2005 Audi A6 3.2FSI S-Line Quattro Stratos Blue
    19x9 S6 / Half Leather Interior / Memory Seats / Black Headlining / S6 Paddle Wheel / S6 Exhaust
    Front & Rear Parking Sensors / TPMS / Adaptive Xenons / Actuated Boot Lid / Bose / Sat Nav / Bluetooth / Sunroof
    Double Glazing / Auto Dimming Interior & Exterior Folding Mirrors / Storage Pack / Lighting Pack

  4. #3
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    274

  5. #4
    Josh84's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leeds
    Posts
    72
    Hi, i have a 2005 2.0tdi, was showing empty and 35miles in tank, put 25quid worth of diesel in, when i started car needle didnt move and still showed 35miles left. Pump was definatly dispensing diesel so problem is with car. There was a garage next door and they plugged into it and it said something to do with a solenoid valve on the faults, does anyone have any idea whats wrong with the fuel level reader though?

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    77
    My 07 3.0TDi Quattro has this problem and it's a weird one

    If I have two heavy people in the back it sometimes works (sender units under rear seat)

    However I recently deliberately let the car run out of fuel...it took 20 mins of cranking once 15l of diesel added (priming) and then for a week the fuel guage read fine, after a week it went back to it's empty reading

    So mine looks like a combo of issues

  7. #6
    Josh84's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leeds
    Posts
    72
    I noticed it happened in mine when my daughter got out of the back, i have since fiddled about with the seat and there was a wire that seamed tp be under the edge of the seat, i pushed this back in and at the next re-fill the needle moved back up. So far the problem hasnt occured again.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    16
    This happened to me with my 2005 3.0 TD. Filled up and the gauge went to zero. After that it was intermittent for a while before I got it replaced. I was told " common fault". I also think there are two gauges as it's a saddle shaped tank. So only one has to fail.

  9. #8
    Josh84's Avatar
    Neutral

    Status
    Offline
    Join Date
    Feb 2011
    Location
    Leeds
    Posts
    72
    What did you get replaced? The guy at the garage was on about some sensor that might need replacing but its attached to a pump and the whole thing needs replacing, wasnt sure if he was trying to rip me off or not.
    2005 Audi A6 2.0TDI S Line- Black
    2004 Audi A3 2.0TDI Sport- Akoya Silver
    2006 Corsa 1.4 SXI+ -Black
    1996 Ford Fiesta (think it had an engine)

  10. #9
    5th Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    N. Wales, LL22
    Posts
    1,224
    mine has this issue, it will show empty after a refill, but after a few miles and a restart all is normal
    VCDS in North Wales
    2007 A6 3.0TDi S-Line Le Mans Avant , adaptive xenon lights, sunroof, privacy glass, towbar, led rears & randomly rear seat airbags
    1999 Honda S2000 , mcb low milage jap import, fully bushed, mugen exhaust <<< for sale! <<<
    2001 Passat TDi 130 Sport < sold!! http://img.photobucket.com/albums/v343/Ste_Nova/Passat/PB140007s.jpg

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    16
    I'm sorry I don't exactly remember as it was a year or so ago and I've passed all the receipts on when I sold it. I'm reptty sure it was just the sender unit and not the pump also. Why would you need a pump if the car still runs? I don't even think it's part of the same system, so I would question that.

 

 

Similar Threads

  1. More help required with my S4 engine issue
    By tonybolony in forum A4/S4 forum(B5 Chassis)
    Replies: 14
    Last Post: 24th July 2011, 18:05
  2. A3 Speedo/Fuel gauge issues
    By 1animal1 in forum A3/S3 Forum (8L Chassis)
    Replies: 46
    Last Post: 28th August 2010, 19:21
  3. 2006 A6 Fuel gauge reading empty.... (2.7 tdi)
    By A6Ian in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 10
    Last Post: 10th May 2010, 10:39
  4. Urgent help required with fault diagnostic codes please
    By dyce martin in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 24th February 2010, 18:47
  5. Fuel Gauge issues
    By Aky in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 23rd July 2008, 13:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO