JMB RetrofitsChris Nott
Results 1 to 22 of 22
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7

    Audi A6 2006 communications pack 1, help

    Hello everyone.
    I am after some help with my new car. I have just got an Audi a6 2.7tdi avant 2006 and I am really happy with it. I am puzzled though as it says it has a communications pack 1 installed and in the manual it mentions bluetooth but I cannot seem to find the Bluetooth connection on my phone or any phone for that matter! There is a cradle point in the front armrest, the mmi is the basic one and my phone is an iPhone 4s. If you press the TEL button it says 'telephone connecting' then changes to 'telephone unavailable'. Am I right in assuming that the car does not have Bluetooth after all and I need to get a cradle for my phone or am I missing something?
    Thanks in advance for your help.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    Hi, there is a version of comms pack which has a cradle but is for an audi/motorola handset which bluetooth only work with that...

    In armrest does it have like a pinout section in middle of it or does it have cradle on right section inside armrest??

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7
    Thanks for the reply. There is a cradle point fitted in the front armrest but there is no adapter fitted to it. All that is there is a point that you can place an adapter on and the are about a dozen pins showing if that makes sense?

  5. #4
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    Hi does it look like this


  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7

    Smile

    It looks exactly like that.

  7. #6
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    Hi then you should have BT IMO

    I would go into "Tel" menu then press "Setup" delete all paired BT devices, then switch off ignition and then AFAIK when you switch on car you have a window of 2-3 min to link something to BT...

    But I think I've also heard iPhone can be pain to link and sometimes requires MMI firmware update...

    If you have another phone available I would try that as well...

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7
    Hi, I have tried this and I am unable to access the telephone settings menu. If I press the telephone button it just says 'telephone unavailable' and you can't do anything in the menu! I'm a bit puzzled now as I was sure that it had Bluetooth as you said but I have tried an old Nokia phone as well and it does not detect anything when you search for devices! I wonder whether the mmi requires a software update maybe!

  9. #8
    5th Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    N. Wales, LL22
    Posts
    1,224
    reset the full mmi and clear everything, i did this on mine when i got it cause it had paired phones, sat nav desitnations etc etc etc

    then lock car and leave it for a few mins, unlock, jump in, turn on, search for bt devices (dont drive away while setting up and do it quickly)
    VCDS in North Wales
    2007 A6 3.0TDi S-Line Le Mans Avant , adaptive xenon lights, sunroof, privacy glass, towbar, led rears & randomly rear seat airbags
    1999 Honda S2000 , mcb low milage jap import, fully bushed, mugen exhaust <<< for sale! <<<
    2001 Passat TDi 130 Sport < sold!! http://img.photobucket.com/albums/v343/Ste_Nova/Passat/PB140007s.jpg

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7
    Hi, I've just tried that but it still says 'telephone unavailable' when you select the TEL button. You cannot access the settings menu when in the TEL function either.

  11. #10
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    You may need a scan via VCDS / VagCom to see if any faults with BT unit, etc ...

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Posts
    200
    Quote Originally Posted by mattc1 View Post
    Hello everyone.
    I am after some help with my new car. I have just got an Audi a6 2.7tdi avant 2006 and I am really happy with it. I am puzzled though as it says it has a communications pack 1 installed and in the manual it mentions bluetooth but I cannot seem to find the Bluetooth connection on my phone or any phone for that matter! There is a cradle point in the front armrest, the mmi is the basic one and my phone is an iPhone 4s. If you press the TEL button it says 'telephone connecting' then changes to 'telephone unavailable'. Am I right in assuming that the car does not have Bluetooth after all and I need to get a cradle for my phone or am I missing something?
    Thanks in advance for your help.
    Here is a link to a copy of the A6 Brochure for 2006. Under CP1 it lists CD Changer, CD Navigation and GSM Mobile Phone Prep. later in the Communications Section it lists GSM MPP as having BT Interface, however there is also an option for BT which requires MMI High and this costs more than the GSM MPP option so it may be that GSM MPP simple has the ability to have the BT module added but does not include the module itself. Retrofitting Audi BT (there are several companies that will do it) looks to cost about £450-500. The cost of a cradle for the iPhone 4S that will fit in the armrest is about £120 so a much cheaper option that whilst less convenient will also charge the phone
    Last edited by elan2s; 24th July 2012 at 10:58.
    2012 A6 Avant 2.0TDi SE
    1970 Lotus Elan +2S

  13. #12
    5th Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    N. Wales, LL22
    Posts
    1,224
    the iPhone cradle will ONLY charge the phone!
    VCDS in North Wales
    2007 A6 3.0TDi S-Line Le Mans Avant , adaptive xenon lights, sunroof, privacy glass, towbar, led rears & randomly rear seat airbags
    1999 Honda S2000 , mcb low milage jap import, fully bushed, mugen exhaust <<< for sale! <<<
    2001 Passat TDi 130 Sport < sold!! http://img.photobucket.com/albums/v343/Ste_Nova/Passat/PB140007s.jpg

  14. #13
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    It is a well documented issue with the BT preps of these cars failing between 2006/7 Audi were producing faulty ECU's with bad software which basically corrupted and although the car looks like it has BT, you cannot connect to it. At one point Audi were replacing these for fun.

    So if you get it scanned with VAG and it shows no faults, look at the Advanced section and see the ROM version etc, it may shows signs of corruption with spurious characters in the fields etc. Then again it may not.

    You may get away with simply updating the car with the the latest MMI updates and hopefully the phone ECU will update without issues and solve your problem, as it's not affecting the MMI operation there is a chance of this.

    Other than that a replacement ECU is the best way forward, avoid ebay as people are selling trashed ECU's and there is no way to tell until you get it delivered.

    I could not make head nor tail of Elan2s's post, nonsensical, you simply have a phone pre with bluetooth that should work with an Iphone, but it's faulty.

    Only one other thing tio mention is the fact you have an Avant and water can get under the front passenger floor and damage the phone ECU, the water pipe has a break just ahead of the ECU plastic housing, but this usually takes down the MMI when water is at fault. So maybe a red herring, but worth baring in mind.

  15. #14
    1st Gear

    Status
    Offline
    Join Date
    Aug 2009
    Posts
    200
    Quote Originally Posted by s8craig View Post

    I could not make head nor tail of Elan2s's post, nonsensical, you simply have a phone pre with bluetooth that should work with an Iphone, but it's faulty.
    I was only querying if they fitted Bluetooth as part of the GSM preparation option, as the price for the Bluetooth module (which could also only be selected with MMI High) in the 06 A6 brochure I linked to was more than cost of the GSM Prep as a standalone and that only referred to "Bluetooth Interface" plus the cradle location point in the armrest rather than full Bluetooth functionality. I however bow to your greater knowledge on these things as presumably Audi's pricing was completely daft at the time.
    2012 A6 Avant 2.0TDi SE
    1970 Lotus Elan +2S

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7
    Hi guys, just a quick update on the state of the hands free! I have contacted Audi and they say that they can't confirm if the car had Bluetooth or not unless they have the car in for a diagnostic check! I have managed to try an iPhone cradle in the car and it does absolutely nothing, doesn't even charge the phone
    I am now left thinking that the problems lies with the phone ecu as s8craig said! I guess the next thing to do is try and find somebody local with vagcom who can scan it or alternatively take the ecu out and have look!

  17. #16
    FactionOne's Avatar
    Administrator

    Status
    Offline
    Join Date
    May 2004
    Location
    Preston
    Posts
    3,059
    Give us a clue to your location (stick it in your profile - even something vague (like a county) if you have online security concerns)... There are always not-logged-in lurkers who might offer to lend a hand if they see they're nearby.

    If it's useful, I'm in Preston with HEX-USB+CAN. Thinking about it, with the amount of traveling I'm likely to do over the next fortnight, I may well be passing wherever you are anyway!

    I can't be certain, but I think your dealer's full of it. Granted, to tell you conclusively whether something installed is working or not (and don't forget the cradle you tried may be faulty/incompatible too (needn't be the module(s) just yet!)), they'd of course need to see the car, but if you just want to know what's on it, it's amazing what they can and can't tell you based on a VIN number, according to whim. An unnamed dealer was very quick to ask for my VIN before telling me that they wouldn't give me prices for AMI parts because I couldn't retrofit it to my car. They didn't seem particularly interested in the VIN number when I popped-in to purchase the 3.5mm lead for my neatly installed, perfectly functional and purchased elsewhere AMI.

    If they want to, they could probably find out how many cups of coffee Fritz drank while he watched the robot paint your car, based on its VIN. If they want to bill you 0.5-1.0hr labour for diagnostics, the VIN tells them nothing. Honest.

    Again, I can't be certain (that it's true for Bluetooth hardware), but for most equipment on the car which isn't fitted to every single one, there's a [PR] code on the Vehicle Data Sticker. You should have two of those - one on the inside front cover of your service schedule, and one in the spare-wheel well. Toward the bottom left of the sticker is a large block of three-character codes - it'll take a minute or two, but you can stick them all in a site like -this-, and it might yield some answers. Maybe not, but it's worth a shot before taking it in.

    It's probably worth ringing another dealer (from another group) to ask if they can advise whether the car has the equipment before paying to scan it for faults too; or better still, Audi UK customer services - Telephone: 0800 699 888 (Open Monday to Friday 8am to 7pm, Saturday 8:30am to 3pm) - they'll help with whatever information they can.

    Regards,

    Rob.
    The truth they're trying to keep from you is that IPv6 has nothing to do with address space; we're actually running out of full stops.

  18. #17
    5th Gear

    Status
    Offline
    Join Date
    Apr 2012
    Location
    N. Wales, LL22
    Posts
    1,224
    stick your vin in the myaudi.de site and it will tell you whats was fitted at factory
    VCDS in North Wales
    2007 A6 3.0TDi S-Line Le Mans Avant , adaptive xenon lights, sunroof, privacy glass, towbar, led rears & randomly rear seat airbags
    1999 Honda S2000 , mcb low milage jap import, fully bushed, mugen exhaust <<< for sale! <<<
    2001 Passat TDi 130 Sport < sold!! http://img.photobucket.com/albums/v343/Ste_Nova/Passat/PB140007s.jpg

  19. #18
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Surrey
    Posts
    7
    Well, I have finally got to the bottom of the problem! I took people's advise and found the phone module underneath the front carpet. When I opened up the box I noticed straight away that there was a bluetooth symbol on the box! I unplugged it all and took it out. Once it was out I noticed that the Bluetooth aerial was not pushed in fully so I pushed it back in! I then reconnected the phone module and tried it all again, hey presto it works I tried all the menus and I was now able to access the phone setup which I was never previously able to do! The phone connected straight away via BT and it has now been working perfectly for the past 4 days.
    I can only assume that the aerial was never originally clipped in properly and over the years it has worked its way lose and finally stopped working!
    Many thanks to everyone who has contributed to this thread and for your help

  20. #19
    1st Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    183
    Quote Originally Posted by mattc1 View Post
    Well, I have finally got to the bottom of the problem! I took people's advise and found the phone module underneath the front carpet. When I opened up the box I noticed straight away that there was a bluetooth symbol on the box! I unplugged it all and took it out. Once it was out I noticed that the Bluetooth aerial was not pushed in fully so I pushed it back in! I then reconnected the phone module and tried it all again, hey presto it works I tried all the menus and I was now able to access the phone setup which I was never previously able to do! The phone connected straight away via BT and it has now been working perfectly for the past 4 days.
    I can only assume that the aerial was never originally clipped in properly and over the years it has worked its way lose and finally stopped working!
    Many thanks to everyone who has contributed to this thread and for your help

    I have a similar problem, however in my case, the phone finds Audi phone xxxx and when I press connect I have to enter a pin so I enter 1234, then a message comes up on the screen of the mmi to enter the pin to pair the device so I enter 1234 on the mmi and wait. Nothing happens, it says "You may be asked to enter the same pin on the other device" for a couple of minutes and then goes back to "Phone switched off" which relates to the audi phone in the armrest (on the right hand side of the armrest space)

  21. #20
    gupsterg's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2012
    Location
    Lurking over a keyboard!
    Posts
    279
    I think you have the motorola/audi phone prep...




    this will only link with that phone not an aftermarket one...

  22. #21
    1st Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    183
    Ahhh, can no software update fix that?? the part number of 77 in VCDS is 4E0 910 333 F

  23. #22
    s8craig's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Manchester
    Posts
    1,557
    There is no software update to fix this, replace the phone system only with a Bluetooth equivalent. Effectively your trying to pair a phone to a phone with your existing setup, rather than a phone to a Bluetooth headset, which is what the BT kit really is.

 

 

Similar Threads

  1. Base in my Audi S3 keeps cutting out intermittently. Help!!
    By gwiz6193 in forum In-Car Entertainment
    Replies: 16
    Last Post: 7th April 2007, 09:45
  2. Audi 80 2.0 8v sport help needed
    By wayner007 in forum Classic Audi Forum
    Replies: 13
    Last Post: 5th October 2006, 10:25
  3. audi warranty on coil packs?
    By campbell in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 7th July 2006, 15:47
  4. Audi A3 Model 8P Facia Adapter..... HELP!!!
    By imported_tobycruse in forum In-Car Entertainment
    Replies: 0
    Last Post: 2nd March 2005, 17:49
  5. Audi 80 Air Conditioning packed in
    By imported_Estoril_Sport in forum Classic Audi Forum
    Replies: 4
    Last Post: 7th September 2004, 14:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO