Chris NottBadger5
Results 1 to 8 of 8
  1. #1
    amimmortal's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Dunfermline
    Posts
    226

    Emission Control System Fault

    Hi all...

    I've browsed over to some of the other posts (via the search tool) to find out some information on this.

    I've had the A6 for a couple of weeks now, and today the Emission Control System Fault light appeared in the dashboard.

    It's a 54 car, but it's only covered 29000 miles.

    I need to know what the worst case scenario is. I've not noticed anything wrong with the running of the car since the light came on, so I'm assuming it's nothing too serious, but still I don't want to be hit by a massive bill at Audi!

    Can someone give me an idea of what to expect?

    Cheers!

    A.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    amimmortal's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Dunfermline
    Posts
    226
    Hmmm...

    I just put the car through a car wash and topped up the washer bottle, then when I started the engine back up the Emission Control System warning light had disappeared, and hasn't come back on since...

    Most peculiar.

    Should I take it from this that the problem was minor and not worry about it?

    Strange that a car wash should fix it, no?

    A.

  4. #3
    amimmortal's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Dunfermline
    Posts
    226
    Ok, it came on again this morning about 5 minutes into my journey to work.

    I think I'll be taking it to Star Performance in Kirkcaldy for them to have a look at.

    Cheers,
    A.

    PS. Is anyone even looking at this thread apart from me? ;-)

  5. #4
    amimmortal's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Dunfermline
    Posts
    226
    Ok...

    My wife just called to say the light has gone off again.

    The question is - "is there something wrong or isn't there?"

    Anyone?

    A.

  6. #5
    The Slug's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    UK
    Posts
    1,853
    im reading it bud lol......ive had the abs light stay on before then switched off an back on and never done it since....maybe just a glitch??
    Vehicle wrapping specialist

    NOW SOLD S6 Avant 4.2 V8....ooooo the noise hehe

    NOW SOLD '03 A3 TDi Quatty Sport Mods so far: Aerowipers front & Rear, Type R Sting ariel, 18" RS-TT Alloys, Superchips remap, Eibach Pro Springs -40mm, Bilstein B8 dampers, R32 ARB's Front & Rear, Pipercross panel filter

  7. #6
    amimmortal's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Dunfermline
    Posts
    226
    Took the car to Star Performance in Kirkcaldy today.

    Turns out some kind of switch was faulty, resulting in the fuel mix being too rich, which accounts for the poor economy.

    Parts plus labour 56... Not too bad, given that they didn't charge for the diagnostics.

    A.

  8. #7
    The Slug's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    UK
    Posts
    1,853
    whats was it in the end then....any part numbers?
    Vehicle wrapping specialist

    NOW SOLD S6 Avant 4.2 V8....ooooo the noise hehe

    NOW SOLD '03 A3 TDi Quatty Sport Mods so far: Aerowipers front & Rear, Type R Sting ariel, 18" RS-TT Alloys, Superchips remap, Eibach Pro Springs -40mm, Bilstein B8 dampers, R32 ARB's Front & Rear, Pipercross panel filter

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2011
    Posts
    2
    Quote Originally Posted by amimmortal View Post
    Took the car to Star Performance in Kirkcaldy today.

    Turns out some kind of switch was faulty, resulting in the fuel mix being too rich, which accounts for the poor economy.

    Parts plus labour �56... Not too bad, given that they didn't charge for the diagnostics.

    A.
    Hi my emission light came on about 10 minutes after changing my 17" alloy wheels to 16" steel wheels with snow tyres. It thn went off and came back on but I have noticed the economy on the car seems to have improved somewhat. Any ideas?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO