Monster MotorsportVolks Autos
Results 1 to 13 of 13
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Posts
    8

    ECON light remains on.

    Hi All ,

    I have a Audi A6 2.5TDI. 02 plate . My ECON light has come on , and will not go off. Just been to Kwik Fit to get them to charge my aircon . Charged no probs no leaks . However the bloody thing still dosen't cool down. Stuck in ECON mode any ideas ???

    Lee

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    matt_o121's Avatar
    2.8Q

    Status
    Offline
    Join Date
    Nov 2006
    Posts
    84
    have the car checked by audi / vag com - there may be an electrical fault - for example with the pressure switch.


    Matt

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Posts
    8
    I think i will have to. Its due MOT end of the month so i will get them to look at the climate control as well .

    Cheers

  5. #4
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,720
    check this thread on 8P & I've heard of this before on others cars, check fuses before going into garage aswell as looks like compressor issue:

    Climate - Stuck on Econ

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Posts
    8
    Just been through it . No joy my end , My car was charged to 550g my bonnet says 550 +50 g was the charge good enough ?
    Tried the battery , how long should i disconnect ? I took it one lead off for about 20 secs . Do you think that was long enough ??

  7. #6
    quattrojames's Avatar
    Moderator

    Status
    Online
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,696

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Theres a thread in the Aircon section which contains some FAQ's covering this:

    http://audi-sport.net/vb/showthread.php?t=57270
    Ingolstance Read about my A6 HERE.

  8. #7
    Flying Spanner's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    30
    Hi, check the small electric fan on the radiator is running with the ac on.
    If not, the system pressure runs too high and shuts down. The motor brushes wear and the fan packs up.
    You high pressure switch mounted on the condenser could also have failed. You can replace this without discharging R134a (screwed onto schrader valve) but you will need to remove OS headlamp to remove it
    Also check the compressor clutch is engaged.
    If you have a late car and VAG com, you can check what pressure the system is running.
    Last edited by Flying Spanner; 12th October 2008 at 22:16. Reason: More info

  9. #8
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,720
    check all fuses cause this is the one that gets everyone with this fault, usually stops fans running & econ stays lit aswell.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  10. #9
    Flying Spanner's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    30
    Hi yes always start with the easy stuff first. Fuses dont just blow though, so just changing a blown fuse wont have sorted out the cause.

  11. #10
    S2
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Alconbury, Huntingdon
    Posts
    13
    Hi, Is there a way to check the high pressure switch with a meter for correct operation do you know ? I have the econ light on. It was on before I had a regas and is still on. This looked like the next thing to look at but wanted to be sure before shelling out the 40 odd quid for the switch.
    Cheers.
    Dave

  12. #11
    maxlbrown's Avatar
    Deep Blue

    Status
    Offline
    Join Date
    Jan 2006
    Location
    hampshire UK
    Posts
    248
    Also chech the compressor the clutch sheer pin may have gone. this is common and requires a new compressor so the money you just paid quick fit is wasted.

    You should have gone to an aircon speciaist and got it tested first not just topped off. in my area the professionals actually charge less than the likes of halfords or quickfit and will check the whole sytem not just dye and regas.

    M
    A6 2.4Se Man
    Bmw 520Ise Auto

  13. #12
    technics100's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Co Antrim
    Posts
    772
    I had the same thing happen on my A4, the easiest way is to check with vag-com. Mine showed a code for the G65 pressure switch, easy swop and worked fine after...


    2003 Silver A2 1.4 TDi - 65mpg & 30 a year to tax - ;-)
    2003 Atlas Grey A4 2.0 S-line - gone
    2000 Goodwood Green S6 4.2 V8 - gone

  14. #13
    martyboy's Avatar
    3rd Gear

    Status
    Online
    Join Date
    Feb 2009
    Location
    Scotland
    Posts
    524

    My Social Networking

    Add martyboy on Facebook
    Quote Originally Posted by technics100 View Post
    I had the same thing happen on my A4, the easiest way is to check with vag-com. Mine showed a code for the G65 pressure switch, easy swop and worked fine after...
    im getting the same fault code on my a3, pressure g65. started intermittently, now econ light on permanently!
    do you know where this sensor is located, i think it might be at the front of my engine, near a fan.
    and is this just a straight swap, i was told, i would need to de-pressurise the whole system before swapping!
    cheers
    Just taken delivery of my Glacier White S-Line Sportback

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO