Volks AutosChris Nott
Results 1 to 11 of 11
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    4

    Easy fix for LCD panel fading on instrument cluster!

    This was posted in the A3 forum and just wondering if anyone has tried this and had success??

    ""Dont let the Audi garages fool you, the whole cluster does not need changing. Mine did exactly the same thing, worse on hot days, better on cooler days. Audi also said change the cluster, I thought forget it! I took it out, there's 3 plugs on the back. Turn it over, there's a few torx screws, take those out, and loosen the black clips which hold the clear face to the rest of the cluster.
    What happens is the lcd display glass has a thin ribbon cable on its right hand side that powers the display, the bonding/glueing on this ribbon cable comes loose, doesn't make proper contact thats why the lines come and go.
    Over the top of the display is a metal cover plate held on by 4 legs bent on the back of the pc board. Straighten these, and it comes off. WORK GENTLY!!!
    Then you can remove the lcd glass. Be careful, don't loose the 2 pieces of plastic behind the lcd glass. IT WILL NOT WORK WITHOUT BOTH OF THESE.
    Then, either take the lcd panel to a good electronic company to re-bond the ribbon cable for you, or find a place that makes and sells lcd displays.
    Don't worry about the codes either, so long as you disconnect the cluster with the ignition off, once you plug it back, everything will work fine.

    I did mine myself, just added 2 extra strips of thin rubber strip behind the lcd on either side, and made the metal cover press down slightly harder on the ribbon cable so it makes better contact, and it works perfectly. All in all, an hour or so's work.""

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    15
    this is just what I was looking for. I've heard and seen (on the A6 just bought) and was suspecting the connection problem because of the heat issue that I hear the reason of those going out.
    when I pick up my A6. I'm going to pull it out and take a look.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2007
    Posts
    92
    I'd be really interested to hear about people's stories of trying this on their A6. I've been thinking there must be a simple solution for ages but nobody had found out what that would be.

    2010 A6 Avant TDI S-Line LeMans
    1999 A6 Avant 2.5 TDI Quattro - gone, not forgotten.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    2
    Hi,

    I'm currently experiencing the same issue with my dash on A6 (2000 year).
    But, i do not know how get to the back of the dash to fix - has anyone done this on an A6 - if so, do you need to remove all of the dash ?

    Many thanks

  6. #5
    simonwjones's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    staffs uk
    Posts
    344
    Pull the plastic cover towards you. ( the one that sits just below the clocks) You will then see 2 screws. Make sure you have the correct size screwdriver and remove these. They can be tight if never been off before.

    Easy the clocks out and stick your hand behind them from the left side. There is a clip at the far end. Pull this up and it will lever the connector off the back of the clocks. Do the same with the other one on the right.


    Pretty easy once you have done it once.


    Simon
    A6 2.5tdi Quattro Sport 180
    A6 1.9tdi Avant ................. Gladly missed
    A6 2.8 Quattro .................. Sadly missed
    Quattro 2.8 Coupe ............. Sadly missed

    RNS-E, Audi BT, Phatnoise

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    2
    excellent - i'll give it a go

    cheers,

    Jason

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    15
    yeah rest of the instruction is same.
    you need to unscrew 2 screw that on the cover behnd the volt meter and oil
    then snape the front part out.
    then snap 2 clip fo rear cover that will reveal the back of the metal casing on the LCD.
    I have tried few things haven' got it back work 100% yet.
    I think I might look for some place repair LCD and have them reglue the ribbon cable.

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2007
    Posts
    4
    So I disassembled my newly purchased 2000 audi a6 2.8 wagon dashboard to try this.

    First off...WOW that is not a procedure for beginners! Once you've gotten the gauge cluster unit out of the dash then you have to take that into three different pieces just to get to the LCD. Even then I couldn't get the LCD off. And to boot I couldn't spot any pads underneith to replace. There are ribbons on either side on the back of the lcd though. Maybe someone else will have better luck.

    And NO. Definetely will not be doing that again. Alot of delicate work for a $9000 car I've only had 11 days.


    Oh yes and all back together and working as well as ever. (mine was never really all that bad). Most mornings all my lines are intact.


  10. #9
    Neutral

    Status
    Offline
    Join Date
    Feb 2007
    Posts
    92
    Quote Originally Posted by frankinstyn
    So I disassembled my newly purchased 2000 audi a6 2.8 wagon dashboard to try this.
    ...
    Oh yes and all back together and working as well as ever. (mine was never really all that bad). Most mornings all my lines are intact.
    So has it improved things at all for you?

    I've got to ask: if it wasn't that bad, why go to the hassle of trying this?

    Thanks for reporting your findings though. I haven't had the balls to try it yet
    2010 A6 Avant TDI S-Line LeMans
    1999 A6 Avant 2.5 TDI Quattro - gone, not forgotten.

  11. #10
    please speak slowly so i'll understand !

    Status
    Offline
    Join Date
    Nov 2007
    Location
    north of the border
    Posts
    160
    mine is fine on my a6 ! but at the first sign of any bother those clocks are out ! this car doesnt know what it's in for lol .

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2007
    Posts
    4
    Quote Originally Posted by SiliconS
    So has it improved things at all for you?

    I've got to ask: if it wasn't that bad, why go to the hassle of trying this?

    Thanks for reporting your findings though. I haven't had the balls to try it yet
    Hasn't improved anything really. Exactly the same as it was.

    I tried this procedure for a friend. My friend purchased a 2000 A6 4.2 sedan a few days after I purchased mine. His display is extremely bad but he really doesn't make as much as I do and didn't want to risk the $800 it would cost to replace this cluster if he had damaged or broken it.

    I've also have much more experience with rebuilding electronic components and working on cars and mechanics in general than he has.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO