Volks AutosChris Nott
Results 1 to 1 of 1
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    1

    Calling Adamss24 (or anybody else with allroad 2.5 TDI superpowers...)!

    I'm the proud owner of a 2002 2.5 TDI allroad (AKE engine), bought with 72k mileage in September 2013. It's more fun to own and drive than I ever imagined, even though it's an automatic, but it's been a harsh mistress. Skip to the final para if you aren't interested in the backstory, just the current fault code mystery!

    In the first month, I had to get a new valve block for the suspension from Audi dealership (last one went haywire in second week) and replace the front air-springs (were Arnott Gen 1's, now Arnott Gen 2's; replaced under 3 month warranty from car dealer), so that's £1k down. This fixes the suspension error codes, leaving just an intermittent "gear selector signal implausible" and "needle lift sensor" code that I plan to deal with at some future service. Then, in an effort to get ahead of the curve, I did some preventative maintenance and had a Bosch service centre in Devon replace the cam belt and associated fittings because I was worried about an occasional high-pitched whine. The belts had already been done at 40k by the previous owner but that was 5 years ago so they were time expired (I intend to get rather more mileage out of mine!). That's when the real trouble started....

    Everything was dandy after the cambelt job. Picked the car up, drove it 200 miles to Cardiff (I work in Devon and Wales); just off the M4, on the A48M, the car stops pulling and the engine behaves like it's in neutral and then begins to smell of what turns out to be automatic transmission fluid. The curious problem I had had cleaning the rear windscreen since Newport has been a catastrophic leak of ATF, constantly spraying along the bottom of the car and up the back. By Cardiff there was not enough fluid left for any transmission to occur. Car shipped back to Bosch centre in Devon that did the cambelt, who diagnose a failed seal on the transmission cooler pipe ("I suppose we could have knocked it doing the cambelt"); seal replaced, ATF refilled, car runs fine.

    I had worried I had cooked the gearbox but seemingly not. However, the car very occasionally starts in limp mode, fixed by turning it off and on again (very Microsoft). I put this down to the known problem of moisture in the transmission control unit, caused by the quite exceptional quantities of rain we have had. My wife claims it also goes into a limp-like mode while running, like it was when the transmission fluid all fell out but which can be fixed by selecting sport mode: this never happens to me so I assume she is mistaken and it is the actual limp mode or the infamous audi rolling-stop lag or something.

    One month later, I drive the car from Devon to Sussex, where we live. There was a slight high-pitched ringing noise sound at the beginning of journey but nothing afterwards. I go to Wales by train and my wife promptly reports the car is going into limp mode / 4th gear and that the steering is vibrating and there is a whooshing sound from the front that seems throttle-related. I think: uh-oh, transmission or turbo trouble.

    She takes the car to the local Bosch Centre, who diagnose instead that (i) the power steering fluid has run dry (how did that happen?) and the pump is making the whooshing noise and vibration and independently (ii) there is probably a fault with the injector pump timing. This last diagnosis is made on the basis that two apparently completely unrelated error codes (00542 "lift needle sensor, short to ground" and no-code-number "transmission selector signal implausible") have a known common origin in the injector pump timing being slightly off. What is more, both problems probably stem from the cambelt change. The two codes were present previously so they may have begun with the previous owner's cambelt change but the IP timing should have checked after my cambelt change and this should have been caught. As for the power steering, well...! The power steering lines need moving aside to move the front service panel out and this probably wasn't done carefully enough. The upshot is the power steering has been refilled with its fluid. It is still noisy but may settle down as the fluid works in; if not, I have to live with noise until the pump packs up and I have to buy a new one for £300. T

    The Big Question - is it plausible the injector pump timing need adjusting? I've not read of the issue of the transmission selector signal and the needle lift sensor being connected by the IP timing being off but these are such complex systems, perhaps it is the right diagnosis. Has anybody else seen this? The garage said it was common and could be found on Google but not by me! Could a request for torque be incorrectly met if the IP timing is off and the transmission be briefly not able to reconcile the resulting values? If so, this could be the origin of the intermittent limp mode and pseudo-limp mode. Or is the second Bosch centre no better than the first one seemingly and I need to worry about the transmission?
    Last edited by rtah100; 7th February 2014 at 22:05.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
 

 

Similar Threads

  1. Replies: 11
    Last Post: 24th June 2007, 19:48
  2. anybody else been watching . . .
    By Khufu in forum General Chat
    Replies: 2
    Last Post: 13th December 2005, 01:26
  3. Call to action!! Anybody who has/had door lock sensor problems
    By VAGMAN1 in forum A3/S3 Forum (8L Chassis)
    Replies: 31
    Last Post: 7th October 2005, 18:03
  4. Has anybody else noticed..................
    By clcollins in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 27th September 2005, 20:22
  5. A really simple one for AndyMac or anyone else with a B5...
    By FactionOne in forum In-Car Entertainment
    Replies: 6
    Last Post: 7th September 2005, 20:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO