JMB RetrofitsMonster Motorsport
Results 1 to 11 of 11

Thread: rough idle

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    42

    rough idle

    just got back from having my 1996 t sport MOT'd and now is idling really bad, sounds a little like a subaru. but ive got no engine warning lights

    is there anything simple i can check? i havent got Vagcom

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    olds_kool's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    stoke on trent
    Posts
    1,071
    is it noisy (tappety) or eratic up and down or high
    kev
    a4 stuff http://shop.ebay.co.uk/merchant/olds_kool_gti
    99 1.8tqs black saloon
    99 1.8tqs grey avant
    90 eunos roadster

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    42
    bit more investigating carried out. its running on 3 cylinders, got no spark on no2 cylinder. ive swapped the coil packs and plugs around and they work in other cylinders. ive been told it could be the am amplifier not sending a spark to no2 cylinder. ive got it being checked early next week by someone with vag com so guess i will just have to wait till then

  5. #4
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    That sucks.

    At least you've got the problem identified though.
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    42
    bit more digging on the interweb and it looks like the n122 module that sits on the air box. apparantly looking at around 100 for a new one!

  7. #6
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    Think you might be right...! I quote from another forum...

    It turned out to be the ICM (Ignition Control Module). I had gone the route of swapping coils, plugs etc and it still kept missing on plug 3.

    You can do a quick test with a digital meter on the ICM (housed on top of the
    air intake, front left hand side of engine bay). It has 5 pins on the incoming side and 4 on the outgoing. All it really does is switch, via some transistors, the feed to each coil.

    Set the meter to Diode test.
    On the 5 pin side of the unit the middle pin is the common emitter for all 4 transistors. Each one of the other pins is the base for of each corresponding transistor - you should get around 0.6 - 0.8v between each base and ground & also between each base and collector (the output pins). Use the negative lead of the meter on the middle pin.

    If its the ICM that's gone you will see a reading on 3 of the 4 output pins (this is what causes it to miss on one plug.

    Part numbers are:
    Bosch 4D0905351 ICM
    OEM F2045=-86642

    Do a search as there is a big difference in price, real part can cost a few hundred, unknown make around one hundred.
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  8. #7
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    I'm sure you'll source one from a breakers yard though for a fraction of the price of a new one... just take your tester with you to check before buying!
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  9. #8
    olds_kool's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    stoke on trent
    Posts
    1,071
    whats the part number, ive got one from a 99 1.8t
    kev
    a4 stuff http://shop.ebay.co.uk/merchant/olds_kool_gti
    99 1.8tqs black saloon
    99 1.8tqs grey avant
    90 eunos roadster

  10. #9
    mwarrey's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2003
    Location
    Swansea
    Posts
    281
    Hi mine went a little while back. I set up a tester using this article:- http://forums.audiworld.com/showthread.php?p=1535031 Mine was gone, I had a genuine Audi one from German and Swedish for about 50. I was quoted 40 from a breaker.

  11. #10
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    Is this the thing that looks like a heat sink that sits in the top of the airbox...?
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    42
    all fixed. ICM replaced and now back on 4 cylinders. been driving the wifes seat arosa diesel to work for the last couple of days, going to be lovely to have the audi back

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO