Sky InsuranceEM Tuning
Results 1 to 10 of 10
  1. #1
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528

    I think my S4 throttle body is toast. Again..

    So about 2 years ago I replaced the throttle body. Not the boot, the body. After it went a bit, well, munched.

    So now I am getting similar behaviou and Vagcom says:
    VAG-COM Version: Release 311.2-N


    Chassis Type: 8D - Audi A4 B5
    Scan: 01,02,03,08,15,17,25,35,45,55,56

    Address 01 -------------------------------------------------------
    Controller: 8D0 907 551 C
    Component: 2.7l V6/5VT 0002
    Coding: 05611
    Shop #: WSC 00482
    6 Faults Found:
    17579 - Angle Sensor 2 for Throttle Actuator (G188) Implausible Signal
    P1171 - 35-00 - -
    17950 - Angle Sensor 1 for Throttle Actuator (G187): Implausible Signal
    P1542 - 35-10 - - - Intermittent
    17976 - Throttle Actuator (J338): Mechanical Failure
    P1568 - 35-10 - - - Intermittent
    17972 - Throttle Actuator (J338): Under-Voltage during Basic Setting
    P1564 - 35-10 - - - Intermittent
    18012 - Internal Control Module Driver Error
    P1604 - 35-10 - - - Intermittent
    17976 - Throttle Actuator (J338): Mechanical Failure
    P1568 - 35-00 - -
    Readiness: 0000 0000

    Address 03 -------------------------------------------------------
    Controller: 8E0 614 111 A
    Component: ABS/EDS 5.3 QUATTRO D10
    Coding: 0273004284
    Shop #: BB 24334
    No fault code found.

    Address 08 -------------------------------------------------------
    Controller: 8L0 82  
    Note: Excessive Comm Errors

    Skipping Address 15-Airbags

    Address 17 -------------------------------------------------------
    Controller: 8D0 919 930 K
    Component: B5-KOMBIINSTR. VDO D13
    Coding: 04462
    Shop #: WSC 00000
    IMMO-IDENTNR: AUZ7Z0W0641874
    No fault code found.

    Address 25 -------------------------------------------------------
    Controller: Bitte Adress
    Component: e 17 eingeben
    No Faults Found
    or DTCs not supported by controller
    or a communication error ocurred

    Address 35 -------------------------------------------------------
    Controller: 8L0 862 257 G
    Component: ZV-Pumpe, DWA, Funk D08
    Coding: 13130
    Shop #: WSC 06325
    No fault code found.

    Address 45 -------------------------------------------------------
    Controller: 4B0 951 173
    Component: Innenraumueberw. D03
    Coding: 00101
    Shop #: WSC 06325
    No fault code found.

    Address 55 -------------------------------------------------------
    Controller: 4B0 907 357
    Component: LEUCHTWEITEREGLER D001
    Coding: 00004
    Shop #: WSC 06325
    No fault code found.

    Address 56 -------------------------------------------------------
    Controller: 4B0 035 186
    Component: Radio 0001
    Coding: 00201
    Shop #: WSC 06335
    No fault code found.

    End -------------------------------------------------------


    Any thoughts?
    Last edited by SonicDeathmonkey; 19th February 2010 at 20:30.
    1999 S4, MIJ Performance exhaust with 100 cell cats

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    I was thinking, what about cleaning the TB with carb cleaner? resetting the TB via vagcom? does anyone know how to do this?

    would i need any new gasket if i toook tb off to clean?
    1999 S4, MIJ Performance exhaust with 100 cell cats

  4. #3
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    When craigs did that, we swapped the PCB out for one from a 1.6 seat. Its been fine ever since.

    and Ye, if you remove the TB you'll need a new gasket.

    You might even find just cleaning the PCB will sort it, its under the black cover on the side of the TB, and you can get it off without removing the TB itself.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  5. #4
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    As always, you come up with the goods. You are to B5s what Mother Teresa was to sandals! All over it like a tramp on chips!
    1999 S4, MIJ Performance exhaust with 100 cell cats

  6. #5
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    So i've had a quick look, how do i get the pcb off? there look like some silver clips holding a black cover plate in position. Is it just a simple matter of taking these clips off?

    Do I need to remove anything to gain access?
    1999 S4, MIJ Performance exhaust with 100 cell cats

  7. #6
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    Yeh just pop all those clips off. They're springy though so try not to let them dissapear into the bowels of the engine!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  8. #7
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    ok, so there is so much stuff in the way, i know my sausage fingers will not be able to get all clips off, so decided to reset throttle with vagcom and see if that helps.
    1999 S4, MIJ Performance exhaust with 100 cell cats

  9. #8
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    It might help, for a while. On craigs it was throwing codes for the throttle pots like yours. There are two pots and it uses both for redundancy. I suspect that if they're reading incorrectly it will ignore one and continue on the "good" pot, and log a code, but eventually it ends up having decided both are duff, and shuts the throttle down to idle.

    A few times craigs just dropped out, and it was curable by turning the ignition off and back on. The throttle would adapt just fine, and the fault codes would clear, but they'd creep back as soon as the car was driven again.

    On yours you have this code:
    17972 - Throttle Actuator (J338): Under-Voltage during Basic Setting

    Which means that the throttle has at some point tried to adapt itself, and failed.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  10. #9
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    Well, it seems to have fixed it, for now...

    Assuming I get all the pipework out of the way and can get the clips off, without losing them, when am I looking to do with the PCB? Give it a blast with WD40?
    1999 S4, MIJ Performance exhaust with 100 cell cats

  11. #10
    CraigG's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2008
    Posts
    188
    some electrical contact cleaner would prob be a better idea or carb cleaner

    as aragorn said, i got a whole throttle body from a 1.6 Seat for about 9quid off ebay, swapped the board over, and never had the issue since.
    Imola S4 - Bilstein B6 + Eibach Prokit, Anthracite BBS Pescara 18x7.5"

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO