Chris NottBadger5
Results 1 to 26 of 26
  1. #1
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088

    VAGcom cable question

    I want to get myself a cable so I can reset my service lights and check fault codes on my 96 A4. There are loads of different ones on E-Bay and I don't want to buy the wrong one.

    Does anybody know if the same cable can be used to read a 99 Passat?

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    132
    They will both be fine with the same cable. I have heard some bad stories about ebay ones, so I got one from Gendan and it's been fine. Bit tight to get int the plug with a B5 (as they are) but it does go in, snug. I hear some cables don't fit at all.

  4. #3
    macca's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Sussex.
    Posts
    525
    blue usb one that you find on ebay is fine, i was using one of these for ages and am just going to buy the proper rosstech vcds one. the ones on ebay are mostly k-line only, this does the older cars like you mention. new models require canbus, and you really should get the genuine article for these.
    1998 A4 1.8T Sport - For Saturdays
    2003 VW Golf MKIV R32 - For Sundays
    2000 Peugeot 406 HDi - For when it's raining
    1996 Kawasaki ZX7R - For when I'm late for work!

    Mods- Forge Dump Valve, The Engine Shop Power Plus based Engine (Low Comp. Forged pistons, Arrow H-Section Rods, Newman fast road cams, polished & ported head), 19" wheels, B&M Short Shifter, Greddy Turbo Timer, RS4 Grill, Weitec GTN coilovers, HKS modified air filter, Autobahn88 FMIC, ChippedUK custom map. Some Turbo mods ongoing.

  5. #4
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088
    Awesome, just ordered a blue cable from FleaBay from a UK seller with a CD ROM for the software.

    Many thanks

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  6. #5
    heymynameismark's Avatar
    Cool beans.

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Aberdeen/Dundee
    Posts
    126
    Got mine off Amazon with software. Doesn't cost much at all. Very snug/tight fit in my B5 'cause of the plastic around the plug itself and the centre console, but goes in fine Cleared codes and tested loads!

    Think it was one of these:

    http://www.amazon.co.uk/OBD2-OBD-II-...3379328&sr=8-1

    http://www.amazon.co.uk/Diagnostic-C...3379328&sr=8-5
    Last edited by heymynameismark; 13th January 2010 at 10:43.

  7. #6
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088
    Looks like the same pic as the one I ordered from E-Bay. Hope to have it tomorrow as there was an e-mail first thing today saying it was posted.

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Essex
    Posts
    2,366
    to get it into my s4 i had to file the top little notch off, went in easily after that. i have both the blue/clear and a black one. both needed the little notch removed

  9. #8
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088
    Next question. Is there an idiots guide available anywhere to tell me how I read and reset service lights etc?

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    87
    You can reset the services lights on the dash mate, i cant remember how thou

  11. #10
    heymynameismark's Avatar
    Cool beans.

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Aberdeen/Dundee
    Posts
    126
    If it's service or oil change indicators (where the miles usually shows up) you can do that with a couple of step-by-steps. I did it just recently

    Something like:

    A4 1998-1999
    Press and hold button on right side of instrument panel. Turn ignition to the "ON" position. "OIL" or "SERVICE OIL" will appear in display.
    Release button. Pull out button on left side of instrument panel until "---" or "SERVICE ---" appears in display. Turn ignition off.

    A4 2000-2001
    With ignition off, press and hold button on right side of instrument panel. Turn ignition to the "ON" position. Release button. "SERVICE!" or
    "SERVICE IN xxxx MI" will appear in display. Turn button on left side of instrument panel to the left until display clears. Turn ignition off.

  12. #11
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088
    Mines a '96 and I tried 2 different methods of resetting in the past and neither worked.

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  13. #12
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    nah they dont work on a '96

    You need to do it with vagcom, the instructions are on the rosstech website:

    http://www.ross-tech.com/vag-com/cars/audi_sri.html

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  14. #13
    Sno
    don't knock it til uv tried it

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Fife, Scotland
    Posts
    39

    Re: VAGcom cable question

    Ordered my Ross Tech cable on Wednesday evening. It arrived this morning (Friday).
    I considered a eBay one but read some horror stories.
    Latest software does almost all cars.
    Worth the bit extra for piece of mind.

    Chris


    Sent from my iPhone using Tapatalk
    (51) A3 1.6 Silver, (53) TT Roadster Glacier Blue Roadster 150bhp, (04) A4 Avant 1.8T Brilliant Red 215bhp, (55) S4 Avant Brilliant Black, (08) A6 2.0 TDI SE Brilliant Black
    and my dream car..... (56) RS4 Saloon Phanton Black Pearl Effect. (10) A4 2.0 TDI SE, picking up my A1 TFSI S line on Wednesday (60)


  15. #14
    heymynameismark's Avatar
    Cool beans.

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Aberdeen/Dundee
    Posts
    126
    Quote Originally Posted by Oranoco View Post
    Mines a '96 and I tried 2 different methods of resetting in the past and neither worked.
    Ah sorry dude. Didn't know yours was earlier. As said, you'll need diag tools/VAGCOM

  16. #15
    1st Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    281
    can someone help.
    i have installed the software that came with the cd and i have downloaded from ross tech as well, but when i try the test on the ross tech, it says port ok interface not found, and vag con software wont even open up. i have windows 7 and i have tried compatible mode with vista, sp1-2, and the same with xp.

  17. #16
    Oranoco's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    HertFORDshire
    Posts
    3,088
    I'm totally stuck as well. Installed CAG-com and then attached the cable as per the instructions and installed driver. VAG-com won't accept the cable and when I remove the cable and put it back in it says new hardware found and I need to install the driver. Got the arse ache now. E-mailed the seller to see if they can shed any light as I've tried it on 2 lap tops and 2 desktops and it will not function. Both the desktops threw their toys out the pram with the cable connected and turned themselves off so I'm wondering if the cable is duff.

    Life begins at 140mph
    Sell my Audi??? Kiss my rings!
    www.passionford.com

  18. #17
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    Ok theres a couple of points here.

    The cheap ebay leads are electrically in two parts. One part is the actual car interface, the other is a convertor to change the USB into Serial.

    When you attach the USB cable, windows detects the convertor, installs the driver and then allocates the convertor a COM port. You need to find out what this com port is, and thats the port you need to use inside vagcom (ie do not use "USB" mode in vagcom, because its not a USB interface)

    Sometimes, windows will allocate the com port a number greater than 4. Vagcom can only see comports 1-4, so if thats the case you'll need to go in and reset the comport to 3 or 4.

    I have a pictorial guide here on how to view and change the com port:

    http://www.lr90.org/gallery2/main.php?g2_itemId=309

    The next point is the interface itself (not the convertor) is powered from the car, so if its not plugged into the car while your trying to make it work (and the car ignition needs to be on) it wont be detected by vagcom.

    To get it to start at all in Windows 7 (and probably Vista) you need to right click on the icon, and choose "run as administrator"

    So to summarise, plug the USB in, use my guide to find (and change if required) the com port, start vagcom as an administrator, tell vagcom to use that com port, then connect to the car to test.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  19. #18
    1st Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    281
    i have done all that time and time again, i tried ports 1-4, i have run as admin, i have had it plugged into the car, with and without the ignition on, i have right clicked and done compatabilty issuses..which says software not caompaitbile, i have run in xp sp3-sp2, vista-sp1 and so on.
    forget puggin into car for a mintue.
    sorry to shout, THE SOFTWARE WILL NOT OPEN ON MY PC.

  20. #19
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    Gruf: can you find out whether your running "32bit" or "64bit" windows?

    If you go into Control Panel, and then into System, theres a line that says "System Type:" and will tell you there.

    Also if you can give me the EXACT wording of the error message you get when you try to start it without compatibility mode, i'll see if i can find anything out.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  21. #20
    1st Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    281
    64 bit.
    it goes into a screen that say programme compatibility.
    then it states...
    incompatible application
    Thanks

  22. #21
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    Sounds like its not compatible with 64bit windows then.

    64bit Windows works quite differently to 32bit in some ways, and i suspect the way rosstech accesses the com ports in these old versions isnt 64bit friendly. The newer versions of the software that ARE 64bit compatible wont work with anything other than a genuine rosstech cable.

    There are a few options, but i suspect the easiest would be to either get yourself on ebay and buy (or borrow from someone) a cheap old laptop that runs windows xp, or get yourself a genuine rosstech cable, so you can run the latest version of the software which does work on 64bit machines.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  23. #22
    1st Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    281
    i'll go for the cable, could you advise me on what i would need and the price it should be also a link to buy it.
    Thanks

  24. #23
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    http://www.ross-tech.com/Merchant2/m...ry_Code=VAGCOM

    Thats probably the one to get there.

    There are probably UK suppliers, but i'm not sure of who. Try speaking to NHN on here, he sells them or something i think.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  25. #24
    macca's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Sussex.
    Posts
    525
    mostly likely problem is 64 bit windows as drivers are different and not compatable, best get yourself onto a 32bit windows, you could do that by dual booting your laptop/pc.
    1998 A4 1.8T Sport - For Saturdays
    2003 VW Golf MKIV R32 - For Sundays
    2000 Peugeot 406 HDi - For when it's raining
    1996 Kawasaki ZX7R - For when I'm late for work!

    Mods- Forge Dump Valve, The Engine Shop Power Plus based Engine (Low Comp. Forged pistons, Arrow H-Section Rods, Newman fast road cams, polished & ported head), 19" wheels, B&M Short Shifter, Greddy Turbo Timer, RS4 Grill, Weitec GTN coilovers, HKS modified air filter, Autobahn88 FMIC, ChippedUK custom map. Some Turbo mods ongoing.

  26. #25
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,381
    Macca: Sure, or you could run a virtual machine and have 32bit windows inside, but for the average user these options are generally a lot of faff and require a bit of technical know how.

    Picking up an old laptop off ebay for 50quid seems to me a better option than messing around with operating systems on what is possibly the guys only computer.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  27. #26
    1st Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    281
    got new laptop and vag com subscription, i have done an auto scan and didnt understand a thing it was telling me, how and what can i check, how do i clear faults if i have any.
    what can i do with what i have.
    Tar

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO