AH FabricationsChris Nott
Results 1 to 18 of 18
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10

    S4 turns over but no spark :(

    Hey guys, I'm kinda in the dumps right now and need some help. I have a 2000 s4 that turns over but won't start, this happened randomly and for no apparent reason. I've tried un hooking the battery as a friend said but that didn't help. I'm wondering if this is common and what the possible problems could be. A few ideas have been tossed around mainly that it could be the ecu... or a sensor. Other than that I'm lost and some insight from you guys will help a lot. Thanks!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,930
    You need to find out if the ECU is TRYING to spark and cant, or if its not bothering to do anything. Are you getting any fuel?

    My first step would be to hook vagcom up to the ECU and see what it says, as that will undoubtedly help you track down the fault.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    good to know. so if you don't have a vagcom what would be the best bet? taking it to a shop?

  5. #4
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,930
    buy a vagcom lead?

    They aint dear, only about 10-15bucks on ebay and that will get you started.

    Thinking about it, the chances of both coil drivers failing is slim, so it would probably suggest the ecu isnt trying to spark. You might find a failed crank sensor would produce that result, although from previous cars i've had, a faulty crank sensor wouldnt stop it running as long as it had a camshaft sensor fitted.

    Vagcom would be a good place to start though, if it can talk to the ecu then you can look at what the sensors are doing, if it cant then you know its either a dead ecu or a wiring fault.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    Thanks a million!

  7. #6
    Blue_Thunder's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Feb 2007
    Location
    Liverpool
    Posts
    1,691
    Immobiliser problem? Do you see a key symbol flash up on the dash?
    Mo power, mo problems

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    I didn't really look, there's a lot of things poping up but I didn't notice a key. What really sucks is that I don't even have it near me... of course my problem happened visting grandma an hour away :/

  9. #8
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Online
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,360

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Immo probs allow the car to start still, but cut out immediatly afterwards

    Did you check all the fuses as there are fuses for the ECU/pump etc

  10. #9
    Adam-D's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2007
    Location
    wirral, merseyside
    Posts
    458
    check all fuses, then pull a plug after trying to start it, see if it smell of fuel
    if not its a fuel issue, if it smell of fuel then its a sprk issue
    crank sensor? coil packs or ecu
    stuff for sale.
    black door cards 50
    black textured "carbon" trim 30

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    Well we finally got it home to where we'll be able to work on it. Haha What a pain in the @$$ tryin to load it in the trailer! it being lowered messed us up I don't even know how many times, it kept bottoming out... finally got it in and got it home. I think we're gonna be working on it tomorrow. Over a handfull of codes poped so those are getting run down then we're goin from there. Oh, my friend took the ecu out of his same year a6 and threw it in mine... it didn't start so idk if that's a bad thing or not yet. I'll keep you guys posted though. thanks for the advice so far!!!

  12. #11
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,930
    Just swapping the ECU wont work if the car has immo.

    What were the codes?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  13. #12
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    p1458, 17866, p1606, 18014, p1569, 17977, p0322, 16706. oh and idk if this will help but the same day when all this started on the way down I tried setting the cruise control but it wouldn't work.

  14. #13
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,930
    Cant see the first one

    http://wiki.ross-tech.com/index.php/18014/P1606/005638

    http://wiki.ross-tech.com/index.php/17977/P1569/005481

    http://wiki.ross-tech.com/index.php/16706/P0322/000802

    Last one looks like the problem.

    Thats the crank sensor, mounted in the gearbox bellhousing.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    hmmm... good to know, I think you just saved me alot of time I'm off but will update tomorrow with what the plan is. Night

  16. #15
    6th Gear

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Essex
    Posts
    2,366
    crank sensor is a fantastic reason for it not to spark. go go GO!

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    ok so we're over here looking at it and there isn't much space to get down in there. You guys know the easiest way to get at it? The end is in sight!

  18. #17
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Seattle Washington, USA
    Posts
    10
    Well guys, mission complete it was that sensor and I'll be having a new one in the car in a few hours once the part's in. Thanks so much for the help and advice, I couldn't have done it without ya. haha I'll be posting up some pics one I get er all clean.

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Essex
    Posts
    2,366
    ive only recently got my s4, ive done a few jobs but ive not even seen where teh crank sensor would be. ive changed a couple on golfs in the past and theyre a PIG to get to. on an s4 id imagine its actually impossible :P

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO