Badger5AH Fabrications
Results 1 to 2 of 2
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    3

    AF FSI 2.0 Cam Sensor fault

    My FSI has just been rebuilt after the water pump seized and stripped the teeth off the belt & the top half of the engine smashed itself to bits.... thanks to the wonderful design idea to drive the water pump off the timing belt instead of an ancilliary belt- idiots!! Now that it's back together my mechanic has called to say that there is a cam sensor error code (don't know which one) and the car drives in limp mode. He says the code means wiring or bad connection rather than cam in the wrong position. Does this sound familliar to anyone - can anyone shed any light? Obviously I don't want to take the car back onto the road until I'm sure what the problem is and what should be done to fix it.

    All help and comment appreciated.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,372
    Not sure what you mean by "AF" but no B5 model A4's had an FSI engine. You might get some better ideas from the B7 or B8 A4 subforums, or the A3 ones as those models used the FSi engine!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO