AH FabricationsBadger5
Results 1 to 26 of 26
  1. #1
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077

    Ucking rear wiper!!

    Anyone breaking a B5 Avant or know of any fixes for the "mind of it's own" wiper problem?

    pulled mine off completely now, looks pretty smooth without it!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    88
    I don't have a rear wiper???

  4. #3
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    SirChumpalot: Not rear wiper on your avant? Can you see ANYTHING when its wet?

    jcb: if you open it up the problem should be obvious. It might be repairable, it might not.

    What usually happens is the pipe that carries the washer fluid thru the unit fractures, then the water leaks into the motor gearbox and gunks it all up.

    You could probably fix it by replacing the pipe, and cleaning out and regreasing the motor/gearbox.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  5. #4
    Markey's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    KENT
    Posts
    2,143
    Sounds like he problem i had where the wiper forgets where park is and keeps doing what ever it likes. Only way i solved this problem was to replace the motor.
    A4 Avant project now started ! see this thread ! http://www.audi-sport.net/vb/a4-s4-forum-b5-chassis/43296-bit-project-going.html
    If you think my post had a usefull purpose please say thanks

  6. #5
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Thats what mine was doing, but when i replaced it i dismanteld the old one to see why it had broke.

    It was full of a greasy rusty paste, covering all the gears and the electrical park contact.

    The washer pipe was split, and the tailgate cover had obvious water marks on it where it had been leaking.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  7. #6
    Adam-D's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2007
    Location
    wirral, merseyside
    Posts
    458
    would explain why mine stops in the middle. then carries on.
    stuff for sale.
    black door cards 50
    black textured "carbon" trim 30

  8. #7
    olds_kool's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    stoke on trent
    Posts
    1,071
    i think ive got one kicking about somewhere
    kev
    a4 stuff http://shop.ebay.co.uk/merchant/olds_kool_gti
    99 1.8tqs black saloon
    99 1.8tqs grey avant
    90 eunos roadster

  9. #8
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    yeah, it won't park and it also turns the washer nozzle about 45 deg when wiping.
    I actually quite like the look without the wiper.

    will have a look in teh wiper case but there is no leak that I can see. module looks brand new.

    Olds: if you can dig it out how much do you want for it? does it work? (stupid question but you would be surprised how much crap I have stored away that doesn't work.....rainy day spares!)

    cheers

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    88
    Quote Originally Posted by aragorn View Post
    SirChumpalot: Not rear wiper on your avant? Can you see ANYTHING when its wet?
    It's not an Avant. It's on my list of things to get sorted as someone has obviously de-wipered it as some point in it's life.

  11. #10
    olds_kool's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    stoke on trent
    Posts
    1,071
    saloons dont have rear wipers
    kev
    a4 stuff http://shop.ebay.co.uk/merchant/olds_kool_gti
    99 1.8tqs black saloon
    99 1.8tqs grey avant
    90 eunos roadster

  12. #11
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Aye, the aerodynamics of a saloon means the rear window stays relativley clear.

    On an avant, (or any hatchback shaped car really), you get a lot of spray and road grime kicked up onto the rear screen, and end up not being able to see anything, hence the wiper.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  13. #12
    Neutral

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    88
    That would be the reason why I don't have a rear wiper then It's rather inconvenient at times, say after it's just been raining and the car has been stationary.

  14. #13
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    just rainex'd my rear

  15. #14
    olds_kool's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    stoke on trent
    Posts
    1,071
    Quote Originally Posted by jcb View Post
    yeah, it won't park and it also turns the washer nozzle about 45 deg when wiping.
    I actually quite like the look without the wiper.

    will have a look in teh wiper case but there is no leak that I can see. module looks brand new.

    Olds: if you can dig it out how much do you want for it? does it work? (stupid question but you would be surprised how much crap I have stored away that doesn't work.....rainy day spares!)

    cheers
    un tested at the moment, its from a 97 tailgate but should fit
    ill see if i can test it over weekend
    need to look at my own as squirter has stopped squirting
    kev
    a4 stuff http://shop.ebay.co.uk/merchant/olds_kool_gti
    99 1.8tqs black saloon
    99 1.8tqs grey avant
    90 eunos roadster

  16. #15
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    pulled the motor apart, kooks brand new inside, original grease, no obvious leaks or broken parts.
    watched it twitch away like an epileptic in my hand when turned on.

    ran a multitester on the signal coming from the plug and it was all over teh shop.

    would a faulty relay cause it to stop start in what seems like an erratic cycle but I think is a pattern?

    if so what relay should I try replacing as they don't appear to be marked on teh fuse board?

    cheers

  17. #16
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    I think when a relay goes it goes. A bit tlike a fuse. You could have a dry connection somewhere... The wiring runs down the nearside interior of the boot, you can trace back to the 1st of the multi connectors from there, after that it gets a bit of a pita.... Um as for the relay I think its 208.... I'll check later, my missus is away with the car.... It's the same relay that controls the front intermittant, so you'd haved the same problem on the front.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  18. #17
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    not a relay then. feels too consistent to be a loose connection. without moving anything, i.e car stationary a cry connection would normally juct show a current drop nit the fluctuation I am getting. nothing on VAGcom either

  19. #18
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    65
    Pretty sure it will be dirty contacts inside the unit. When you pulled it apart did you see the round disk with the metal tracks on? This needs a good clean and also the pins that make contact with it, then grease it all up again and it should be fine.

    I have fixed my front wipers and the wifes A3 rear wiper using this method.

  20. #19
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    didn't seem to be.
    contacts in plug housing were spotless. inside looked new, grease was even clear like new.

    WHat pins on teh disk are you talking about? cog sits on an axle, drives an arm that drives a bigger central disc. all seemed well grease and free from corrosion/sticking

  21. #20
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Can you see the park contact?

    It might be a fault with the motor itself, but usually its the park contact that causes it to start and stop.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  22. #21
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    which one is that? There are four in teh plug IIRC.
    Is there a contact somewhere on the motor?

    stupid thing is if I hold teh stalk forward to spray it works fine, sometimes even goes back to park without a problem

  23. #22
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    if you post a pic i might be able to point it out.

    From memory there is a cam, which turns a disk thats attached to the spindle. Somewhere in there should be a contact pad, which the cam/disk touches when its at the stop, this gets all gunked up with carbon and gives a bad signal.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  24. #23
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    will pull it off again, stuck it back on now.
    as I have lived with it for a few years I will probably just ignore it.

    will have another look though when I get a chance

    cheers

  25. #24
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    65
    Its not the connection plug, its the contacts on the back of one of the big cogs, if you pull it to bits again you will see what we mean. This is how the motor works in that it does a revolution then it hits a break in the contact pad so it knows where to stop, if the contact pins are dirty (not that your eye could see) it causes small breaks in contact which causes the wipers to keep stop/starting etc. We are only talking about little sprung brass pins that after 10 years have built up some contaminates, so clean them with proper electrical stuff of very carefully with some other solvent (WD40).

  26. #25
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    so they are behind the cogs? take it I need to pull them all out then?

  27. #26
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    65
    Yup, just like a Fisher Price clock

    My front wipers started being erratic and stopping and starting quite randomly and not parking properly. Cleaned these contacts and greased it all up again and it has been fine since. Also did the wifes rear motor this weekend on her A3, which I was particulary pleased about as I could only find threads saying that the motor needed replacing.

    I bet you my socks that it fixes the problem!!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO