Volks AutosSky Insurance
Page 1 of 2 12 LastLast
Results 1 to 40 of 54
  1. #1
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130

    Here Goes Nothin!

    Just about to put the new rear ABS sensors, (courtesy of Siena, cheers mate... great service as usual) on the car!! Watch this space for cursin, questions, anxiety and hopefully jubilation!
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    let us know how you get on as i need to do mine soon,
    cheers and good luck

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    let us know how you get on as i need to do mine soon,
    cheers and good luck

  5. #4
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130

    Unhappy Oh Dear

    Well. Sensors in and all seems ok with them. Still got my 65535 internal memory fault and think that's where my problem lies.... (i) is still up.
    My module went away to BBA reman and came back with a clean bill of health,(Lengthy post in here w hile ago). I think the only way I'm gonna get to the botton of this is to get it on a specialist machine to see what it can find. It's got the MOT tomorrow so I'll see if the Garage has the correct gear and get them to have a look see.

    As for the actual sensor change. Pop in pop out. I was a bit dubious about how far the sensors go in and seems that they're just about in all the way. Maybe just over mil at the top of the sensor left. I had to grip the left rear (gentley!) with mole grips over a towel to twist it in ,(ooer!). Biggest pia is getting the flor pan gromets back in! Gonna do that with ramps later.

    So if anybody has any idea, or is in the East Lothian / Edinburgh and can maybe swap an ECU unit to help it'd be greatly appreciated! I let you all know what happens after the MOT tomorrow.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  6. #5
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Good luck with the MOT, I always get a cold sweat on even if I know there's nothing wrong...

    '98 Santorin Blue 1.8t Sport

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    do you need to reset anything after you fit the sensors?

  8. #7
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Nah... only clear the fault codes. The thing is, my ABS used to trip above 20mph, which is when the sensor kick in, the car is triggering much earlier. I'll let you all know what the craic is...
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  9. #8
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    ABS light is an MOT fail mate.

    I think you need to stop messing around with this duff ECU and get yourself another one. I suspect there MAY be another fault, that the faulty ECU is just not managing to record, however its going to take a working ECU to find it.

    One last thing that might work, is if you start the car, drive until you get the (!), then check the fault codes without shutting the engine off. If the memory in the ECU is faulty, but the ECU works, then you might get the codes out of it while they're still "fresh" as it were.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    http://cgi.ebay.co.uk/Audi-A4-2-6l-Quattro-BOSCH-ABS-ECU-MODULE_W0QQitemZ200322121939QQcmdZViewItemQQptZUK_ CarsParts_Vehicles_CarParts_SM?hash=item2003221219 39&_trksid=p3286.c0.m14&_trkparms=66:2|65:1|39:1|2 40:1318|301:0|293:1|294:50

    dunno if all quattros ecus are the same?

  11. #10
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Quote Originally Posted by aragorn View Post
    ABS light is an MOT fail mate.

    I think you need to stop messing around with this duff ECU and get yourself another one. I suspect there MAY be another fault, that the faulty ECU is just not managing to record, however its going to take a working ECU to find it.

    One last thing that might work, is if you start the car, drive until you get the (!), then check the fault codes without shutting the engine off. If the memory in the ECU is faulty, but the ECU works, then you might get the codes out of it while they're still "fresh" as it were.
    I think you're right about the unit. The sensors needed done anyway. I'll give your final fix recom. a go. I'm fully expecting it to fail but hoping the garage may be able to get more info from it than me.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  12. #11
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Quote Originally Posted by mikeya4 View Post
    http://cgi.ebay.co.uk/Audi-A4-2-6l-Quattro-BOSCH-ABS-ECU-MODULE_W0QQitemZ200322121939QQcmdZViewItemQQptZUK_ CarsParts_Vehicles_CarParts_SM?hash=item2003221219 39&_trksid=p3286.c0.m14&_trkparms=66:2|65:1|39:1|2 40:1318|301:0|293:1|294:50

    dunno if all quattros ecus are the same?
    Thanks for looking but that one won't do... Doesn't look right and the P/n's wrong. Thanks again though....
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  13. #12
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130

    Angry Results are IN!!!

    Well I knew it would fail on the ABS. I'm sourcing a replacement unit.. other fail points.
    Front off side upper, (rear) control arm excessive play... Easy fix. Providing the bolts aren't fecked!
    Nearside front indicator bulb showing white. Didn't notice this myself.

    Advisory points:
    Centre prop bearing worn. Looks easy enough, will probably do this while I'm doing the arm. Not a fail but a definate waggle in the prop shaft!
    Nearside front tyre due to be replaced.

    And thats it.. Not that bad for 242k worth of traveling... Got the Nuneaton run tomorrow and back Saturday so I'm going for a retest by next friday. The biggest unkown is if I can get me an ABS unit by then. Any body any pointers on the work I've got ahead? All looks pretty straight forward to me.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  14. #13
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    what part number is the abs module?i have one in my shed that i got but its was wrong for mine.

  15. #14
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    what part number is the module?

  16. #15
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Erm, it should be for a quattro 8E0614111A or swap the A for an E.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  17. #16
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    i'd consider looking at replacing all the arms, rather than just one.

    It will really transform how the car drives, and lets face it, if ones dead, the rest arent far behind...

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  18. #17
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    and dont buy the chocolate ones off ebay or you will be buying a set next year.thats the same number as mine.im putting a new module in mine today as its goosed.i have one that has AH at the end out an a6 quattro.it never worked in my 2000 car but may work in yours as its older?

  19. #18
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    Just over 300 for a full set of (decent) arms though...

    What was the reason for replacing the ABS sensor...? Purely because the warning light is on... or were there other contributory reasons?
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  20. #19
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    The ABS sensor were throwing fault codes, and they looked like Pooooo! Just this damn ECU to get sorted now. Ian52. Where did you get you ECU from?
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  21. #20
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    i got the one i am about to fit from doculey on here.the one from the a6 i got from my local scrapie.when you took the module bit off did it have 6 or 9 solenoids or whatever they are.when i put the a6 one in mine the light went out but sometimes the abs would come on as soon as i touched the brakes.not sure if its just that its not compatible with my car or its broken as well.

  22. #21
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Mine has 9 solenoids. I think I'm going to get a few things checked before I purchase a replacement unit. I seem to remember the fault code always being there. Even when I got the car... I've been told that the air gap in the sensors is crucial, and that while it may not throw a fault code it might be responsible for tripping the system. Just waiting for the laptop to charge up! Double check the measuring blocks and see that I'm getting good readings.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  23. #22
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    how far do you need to push the sensors in then? im really concerned about messing it up, and they certainly arn't cheap things either

  24. #23
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    what do you mean by air gaps?

  25. #24
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    I have a problem with my ABS, though I'm not sure it's the same...

    When I come to a standstill, the ABS triggers and the pedal judders. If I stop slowly, I can 'avoid' this happening...

    Any ideas? related to sensors do you think?

    Sorry to hijack your thread.
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  26. #25
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    The air gap is the distance between the end of the sensor and the ABS rotor (which is usually a toothed disc or drum) which the sensor reads as a pulsating value as the teeth run through the magnetic field of the sensor. Ideally, we should split the hub to see where the sensor is and maybe even measure it with feeler gauges. I think it's about a mill.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  27. #26
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130

    Question Upper rear suspension arm

    Is it really that hard to do the front upper rear arm. Haynes gives it 4 spanners and the link below , (which is very helpfull) makes it sound quite a handfull. While I'm willing to get stuck in I hate getting out of my depth...

    URGENT front suspension, how do you get it off?

    I've also noticed that the centre prop bearing isn't replaceable. i.e. it's the whole prop shaft as the bearing is part of the unit... anybody clarify this? and... does anybody have one lying around? Doc, have you broken this part of your car yet?

    I'm looking forward to getting stuck in, I've got a free week next week and I'm up for making the most of my time. Money is an issue but I need the car on the road.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  28. #27
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    111
    i done one on the upper front of my fwd tdi and took about 2 hours, i think the front upper rear arm has more clearance so should be easier, I didn't find it hard, just fiddly! i think it might be easier to take the strut out. thats what i would do if i had to do it again

  29. #28
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    diesel, the other common issue is the reluctor ring becoming corroded so the ABS sensor cant pick up the signal. Fixing that requires new rear CV joints afaik.

    Thats also possible to be the cause of intermittent ABS firing as in Geemans case.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  30. #29
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    just swapped my pump and no beeping or abs light.happy days.when i replaced a sensor i just pushed it in till it stopped.the old one had been touching the ring just enough to wear the end slightly.for the arm i think you will have to take the strut out to get the bolt out.its not that bad a job.the pinch bolt will be the hard bit.

  31. #30
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Ok, guys cheers. I'll have a go at resetting the sensors my self, just been on to Edinburgh Audi and it's a 'Bring it in and we'll have a look' jobby... I'm not set up tool wise for the suspension arm, (that's this years christmas!) in terms of taking the strut out so it may just go to the garage to get it done. Any thoughts on the prop shaft? Is teh bearing repairable or is it a full replacement of the whole shaft?
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  32. #31
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    Edinburgh audi arent going to tell you anything that vagcom cant, and they'll charge you a pretty penny for the privelage.

    Did you try scanning for codes without turning the car off?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  33. #32
    6th Gear

    Status
    Offline
    Join Date
    Oct 2007
    Posts
    2,597
    I've got one here, off a '98 car part number's 8E0 614 111H.

    I've also got the one off a '97 car, actually it's still fitted, but it's a FWD, so may well be different.

  34. #33
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Cheers Guys. I'm going to recheck the sensors gap. I'm getting nothing on measuring blocks... A garage thats been good to my dad told me about a curious problem with an older A4 that the red symbol was coming up but there were no fault codes... they re-adjusted the sensors and the problem was solved. Fingers crossed!
    If spin the hub by hand with a wheel attached will I be able to get it to rotate fast enough to be recorded by measuring blocks?

    I'm also in the market for a propshaft if anybody happens to have one lying around ;o)
    I'll update this thread tomorrow.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  35. #34
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    i just pushed the sensor in as far as it would go and it works fine.

  36. #35
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Hey guys, right. I've peered through the hole in the hub and am mightily confused... I can see the hub rotating but no posts or teeth. There apears to be a couple of small metal 'block's that are just floating in there....


    ...I've had a look at the diagram above and can't get enough info as to how the hub and ABS look and work... anybody tell me what I should be looking at when the hub get's split?

    http://www.youtube.com/watch?v=sENdMWknatg

    I tried to get a vid but I've not got a proper camera. Focal length on a K850i ain't that great, you can see the hub rotating insode though with nothing going round. Any chance somebody with ETKA (mine still won't play ball) could post a pic with the expanded rear hub and ABS ring? Ta!
    Last edited by dieselfitter251; 10th May 2009 at 11:56.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  37. #36
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130

    Found this on Audiworld.com



    This is what I'm expecting to see. But I can't see any teeth on the inside of my hub! WTF!?
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  38. #37
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Uh....
    Think I've just answered my own question.... I need to get the hub split though, not something within my epertise or that I have tools for.

    http://forums.audiworld.com/showthre...light=rear+abs
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  39. #38
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    YEAH!! Partial success. Check the left rear hub and that ABS ring appears to be fine, cleaned it as best I could, popped the sensor in and get a good reading from Measuring blocks! Woo!
    So, recommendations guys. The CV joint, is it replaceable by itself or is it better just to get the whole drive shaft? Ta again.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  40. #39
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Quote Originally Posted by aragorn View Post
    diesel, the other common issue is the reluctor ring becoming corroded so the ABS sensor cant pick up the signal. Fixing that requires new rear CV joints afaik.

    Thats also possible to be the cause of intermittent ABS firing as in Geemans case.
    Hey matey. Thanks for this BTW, it reminded me to take that good look into the hub and see the knackered off-side rear.
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  41. #40
    2000 a4 1.8tqs-yellow

    Status
    Offline
    Join Date
    May 2008
    Location
    perth
    Posts
    1,197
    can replace it on its own.not sure if its same as front.if so its easy to do.

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO