Volks AutosChris Nott
Page 1 of 2 12 LastLast
Results 1 to 40 of 47
  1. #1
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646

    Pounding My Vag-Com

    I now have all the required ingredients to be fully Vagged up. Cable, Software, Windahs XP laptop and extension cable because the battery's knackered.

    Can't get it working, though. The amusing little blue LED lights up on the cable, but when I do a USB port test on vag-com it shrugs its shoulders.

    So I have either a hardware problem or a lack of skill. Or both.

    I will stick with it and have a proper go this weekend. I lust after an extinguished airbag lamp.

    '98 Santorin Blue 1.8t Sport

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Fraser's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2003
    Location
    the north
    Posts
    586
    ebay or proper lead?

  4. #3
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Guess?! Yes, being a tightwad I have plumped for eBay to start with. For my purposes it out to be adequate, assuming it works....

    '98 Santorin Blue 1.8t Sport

  5. #4
    Fraser's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2003
    Location
    the north
    Posts
    586
    sounds like a driver issue maybe?

    someone will be along who has got one of these leads working, i think you need to make sure you have the correct version of vagcom for it to work

  6. #5
    Blue_Thunder's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Feb 2007
    Location
    Liverpool
    Posts
    1,693
    Do a google search for Vag* FTDI Drivers. You'll need to install these, then assign a virtual COM port to your USB port in the range COM1-COM4.

    Then, when you fire up Vagcom, you'll need to go into Options, choose the same COM port there, then click test and save.

    Job's a good 'un!
    Mo power, mo problems

  7. #6
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Quote Originally Posted by Blue_Thunder View Post
    Do a google search for Vag* FTDI Drivers. You'll need to install these, then assign a virtual COM port to your USB port in the range COM1-COM4.

    Then, when you fire up Vagcom, you'll need to go into Options, choose the same COM port there, then click test and save.

    Job's a good 'un!
    Aha! I thought I might have to do something like that. The software I have included a USB-serial driver of some sort or another but it was pretty vaguely titled.

    I shall do as you say. Cheers Thunder.

    I'm spending the weekend "Doing stuff" and "vistiting people" with my Girlfriend, so it might be a last thing on Sunday kind of job.

    '98 Santorin Blue 1.8t Sport

  8. #7
    dieselfitter251's Avatar
    Blow ma own trumpet?

    Status
    Offline
    Join Date
    Jun 2007
    Location
    High 'C's
    Posts
    1,130
    Quote Originally Posted by audinary View Post
    Aha! I thought I might have to do something like that. The software I have included a USB-serial driver of some sort or another but it was pretty vaguely titled.

    I shall do as you say. Cheers Thunder.

    I'm spending the weekend "Doing stuff" and "vistiting people" with my Girlfriend, so it might be a last thing on Sunday kind of job.

    In what order ...sorry, been a long day with 5o'clock drinkies...
    Ford Mondeo 2.0i Durtec Ghia X Estate
    Leather / Dog Hair.



    Dieselfitter 251
    A4 avant '97 1.9tdi q
    a.k.a. STINKY
    [B]250k!
    ..she's gooooonnnne!!!!

  9. #8
    docurley's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2003
    Location
    UK, London, SE
    Posts
    3,850
    Black Audi RS4 2006 Exclusive edition, Black optic option (stock for now)

  10. #9
    '98 A4 2.4 SE

    Status
    Offline
    Join Date
    Apr 2007
    Location
    Nr. Sheffield, UK
    Posts
    99
    Sorry for jumping on your topic, but I don't thing it warrants its own thread...

    Does anyone know how to make the alarm honk/beep when armed/disarmed?

    Thanks!
    Cheers

    Josh

  11. #10
    '98 A4 2.4 SE

    Status
    Offline
    Join Date
    Apr 2007
    Location
    Nr. Sheffield, UK
    Posts
    99
    Sorry for jumping on your topic, but I don't thing it warrants its own thread...

    Does anyone know how to make the alarm honk/beep when armed/disarmed?

    Thanks!
    Cheers

    Josh

  12. #11
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Quote Originally Posted by docurley View Post
    Cheers Doc, I now have the file loaded onto my XP computer, how do I go about using it? There is no .exe file in the zip. Also, how do I assign a virtual com port to my USB? Apologies for all the newbieness!

    '98 Santorin Blue 1.8t Sport

  13. #12
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Ok. I've loaded all relevant drivers, I think... And set the USB to port three. And when I test COM3 it tells me

    Port status: OK
    Interface: not found.

    Any ideas?

    '98 Santorin Blue 1.8t Sport

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Bethesda, North Wales
    Posts
    40
    any ways of getting my ebay cable to work on my xp laptop or vista??????

  15. #14
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Quote Originally Posted by s4 osh View Post
    any ways of getting my ebay cable to work on my xp laptop or vista??????
    That's what I'm trying to do. Vista will be a non-starter, Ros-Tech recommend XP. But i'm still in a distinctly it-ain't-working type situation.

    '98 Santorin Blue 1.8t Sport

  16. #15
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you take a screen shot of your device manager so i can see the USB serial bridge is set correctly?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  17. #16
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you take a screen shot of your device manager so i can see the USB serial bridge is set correctly?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  18. #17
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you get a screenshot of the device manager?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  19. #18
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you get a screenshot of the device manager?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  20. #19
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you post a screenshot of the device manager?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  21. #20
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you post a screenshot of the device manager?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  22. #21
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    can you post a screenshot of the device manager?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  23. #22
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    rofl, that'll mean the forums a bit ****ed then!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  24. #23
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    rofl, that'll mean the forums a bit ****ed then!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  25. #24
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Bethesda, North Wales
    Posts
    40
    all i get when i try to connect is that the port has been found but the interface cannot connect... ill try get the screen shot for you

  26. #25
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    what version of VAGCOM?

    ebay cables only work with 409 (or whatever it is called)

    I run an ebay special on my thinpad with XP, had the same symptoms until I downloaded the right version

  27. #26
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    I have 409 and 311 separately installed.

    Screengrabs coming up As soon as Ye Olde Windows XP laptop fires up

    '98 Santorin Blue 1.8t Sport

  28. #27
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646

    '98 Santorin Blue 1.8t Sport

  29. #28
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    assuming the vagcom lead is the only usb device plugged in that looks fine, just set vagcom to com3 (NOT USB!), and connect it to the car and see what happens (testing it off the car wont work).

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  30. #29
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Cheers Aragorn, just about to have a bath so I'll give it a go tomorrow morning. I do like a good bath, me...

    '98 Santorin Blue 1.8t Sport

  31. #30
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Bethesda, North Wales
    Posts
    40
    how do youchange between com ports??? is it as simple as plugging it somewhwere else in the laptop,, sorry if i sound dumb, and im running 409 on mine the right one for the cable. but just cannot read my car, it works on the missuses mk4 polo grrrrr

  32. #31
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,077
    if it works on one car and not the other then it is not a problem between cable and pc.
    what message do you get?

  33. #32
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    One thing to watch with the Ebay cables is that they can often change the com port they use depending on which USB port you attach it to. My laptop has 3 ports, and each time i used a different port it allocated a new com number and i had to go into the device manager and change it back to com3.

    After i changed it for all 3 ports it seems to have remembered though, which is nice :P

    This may explain why it worked on the polo and not on your car. To check what com port its on you need to go into your device manager and look under ports as shown in the screenshot above. The one listed "USB Serial Port" or sometimes "USB - Serial Bridge" will have a com port after it, which needs to match the setting you choose in vagcom.

    If they both match, and it continues to work on the polo an not on the A4 i suspect there is something wrong with the diag socket on the A4. Also make sure the ignition is on when you try, as even though it lights up the LED, a lot of the control modules dont get power if the ignition is off.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  34. #33
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Yes! Result!

    Up and running and airbag warning fault code removed!
    And auto-scan revealed no other faults. Cool.

    Thanks for your help, Aragorn.

    Now, How can I set up drive-away locking?

    '98 Santorin Blue 1.8t Sport

  35. #34
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    http://www.ross-tech.com/vag-com/cars/audiB5.html

    its under central locking in there

    +32 Auto lock/unlock of doors (Doors lock at 15 mph and unlock when key is removed)

    so basically you go into the locking module, press recode, make a note of your existing code then add 32 to it and set the value to that.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  36. #35
    Dan Glybitts's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    West Malling
    Posts
    29
    I've got the same problem with the airbag light.

    I tried to follow your posts and failed. I wouldn't have the faintest idea about where to start with this.

    Is there such thing as VAG COM for dummies?

  37. #36
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Quote Originally Posted by Dan Glybitts View Post
    Is there such thing as VAG COM for dummies?
    That would sell and sell and sell. Any software engineers reading, now is your chance to make a killing.

    I didn't have a clue either but have recently had a fear by-pass operation, so I'm not afreaid to get my hands dirty and have a go.

    Plus there are plenty of knowledgeable geezers on here only too happy to lend a sympathetic ear.

    Audi-Sport.Net. The most supportive forum in the world!

    I love you guys

    '98 Santorin Blue 1.8t Sport

  38. #37
    audinary's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2008
    Location
    Frinton-On-Sea
    Posts
    646
    Oh yeah, I now have Auto door locking and remote control windows! Worth many car-park credos points!

    '98 Santorin Blue 1.8t Sport

  39. #38
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Bethesda, North Wales
    Posts
    40

    Question

    so audinary what did you have to change to make your work and have you got a link to exactly the right 409 version to use, i finally understand how th com port works so that can be set properly, the port does work because the garage that i took it to firstly works everytime no problem...... thanks for your input

  40. #39
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    I have it running on Vista with a cheap ebay lead and no problems.

    Make sure you run it as administrator.
    1999 S4, MIJ Performance exhaust with 100 cell cats

  41. #40
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Bethesda, North Wales
    Posts
    40
    wwww. so what software are you using then???? i have tried everything in my capability to get it working but no luck as of now, but i wont give up i believe i will get this car fixed soon

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO