EM TuningBadger5
Results 1 to 13 of 13
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    171

    Air Bag light???

    Hi.

    I have managed to get my a4 on the road now. I bought it already crashed and i put a new front end on it and repaired the rear plus other little things that neaded done. When i start it up and drive the air bag light stays on for about 20 seconds then goes out. Once it is out it stays out. I was wondering if this is normal.


  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Milton Keynes UK
    Posts
    248
    20 seconds seems a long time before the light goes out.

    Might be an idea to run a diag on the airbag system to see if there is any fault codes.

  4. #3
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    its a long time yea, but the fact it goes off would imply there is no fault....

    i'd also try and get a diagnostic done on the airbags and see if anything shows up

    mine stays on for maybe 5-10secs

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  5. #4
    Bong Water's Avatar
    In two minds

    Status
    Offline
    Join Date
    Dec 2007
    Posts
    785
    just had a problem with mine staying on and it was reset on vagcom and now stays on for 5 secs when the starting the car
    Skint because of my car, the forums made me do it

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    171
    Thank you for the replies guys.

    Would a cheap vagcom cable from ebay be able to clear this or would i have to get the proper one.


  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2008
    Posts
    28
    Hi Sherry

    I'm no expert - although I feel like one now.

    I'd go with a chep one;
    1998 S4 Avant Airbag light & VAG-COM

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    171
    Thank you slipmat.

    I will get one from ebay.

    One more question though.

    I have just changed my drivers seat as it was torn. My seats don't have airbags or electrics.

    Surely this isnt anything to do with the light coming on.

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    65
    The shareware version of VagCom will definitely work as I've just been using it to sort mine out and also set up a new control module. You may have issues with the cheapo lead though as they can sometimes be problematic connecting to various modules.

    As for the seats, if your controller thinks it should have seat bags then it will show a fault if not connected to one. No idea if you can get round this.

  10. #9
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,126
    Shelly you are better of buying the full kit of vag as I have personal experiences with the cheap leads & I eventually had enough & bought authentic, they easily blow & also you dont have full access to all options, plus ross-tech support has always been free to date & updated versions free, so if you want full unrestricted access to the whole of the car then buy the full kit, trust me you wont regret a single day of doing it.

    Unless you actually unplugged any cables from the seats then it shouldnt be an issue, but are there any cables under the seats that wernt being used anyway?

    Fact it goes out suggests its not this but you never know, when you replaced front end you must have put a new bump bar that obviously ignites the airbags, maybe sensor in there has a short that is intermittant, just throwing ideas.

    Be very careful with cheap leads & vagcom, has been known to cause issues & very weary of airbags aswell.

    You can tell the car it doesnt have the seat airbags but you wont be able to do in shareware mode I dont think which is another reason to get the proper licensed lead which also entitles you to latest versions.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    171
    hi.

    i went for the cheap option and got one from ebay.

    cant afford the proper one just now.

    I can get the air bag warning light to clear but it then comes back again when the car is restarted with the laptop removed from the port.

    Any ideas please.

    I was thinking there. i have replaced the front end on the car as i bought it crashed.

    is there something on the front of the car that deploys the airbag in a crash that i havent connected up again?


  12. #11
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    you could always "fix" the shareware version...

    if you go into the airbag module and read off the fault codes it'll tell you what is triggering it.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  13. #12
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,126
    Yeah the crash bar obviously has sensors to deploy the bags so guessing something there, but without a vag list of the errors we cant help you further.

    Post the list of the error codes under airbags on here so we can see what its doing & if you can afford to replace the front end then I'm guessing you could afford the genuine kit

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Apr 2008
    Posts
    171
    thanks for the replies guys.

    i have sent the cable back. I couldnt get any error codes as the test stops and says there are too many errors to continue.

    Can someone post a pic of the unit that deploys the airbag so i can see on my car if it is connected up.


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO