Badger5Chris Nott
Results 1 to 29 of 29
  1. #1
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062

    Fuel Gauge Problem

    Hey Guys

    My car (99.5 1.8T Sport) fuel gauge seems to be acting strangely recently, when i fill up it takes ages to register, and then sometimes when i am driving and i know there is fuel in there, it drops and shows nowhere near how much there is, and at the moment it is showing as being empty when I know there is at least 100 miles left!!

    Any ideas of what it could be please???

    Thanks
    Nilz

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Anyone please....I want to see if I can get this sorted over the next couple of days....

    Thanks

  4. #3
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    bump....

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    York
    Posts
    1,653
    Could be the fuel sender in the top of the fuel tank. A bugger to get to and remove.

  6. #5
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Thanks.....

    I have been told that it may be this, any tips on how to get to it and what is involved to get to it, also is the pump in the boot or under the back seat, if so, how easy is it to get to??

  7. #6
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    York
    Posts
    1,653
    Never done the job, but I've seen the results of some. IIRC access is from under the back seats. The unit it's self is supposed to need a special tool to get out. If your too ham fisted you can end up pulling the pump/sender apart and leaving half of it in the tank.

  8. #7
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    OK so would need a professional to do the job then, thats not good, that means more money!!!

    Is the sender just a little swich type thing??

  9. #8
    Jimbo.King's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Leeds
    Posts
    183
    I had the same problem with my fuel sender unit, guage reading empty when it was half full, on the sender unit there is a small link wire to the float arm, this is soldered on and with the arm moving so much it breaks the wire, i put a new one in but could have easily repaired it.

    Once you have removed the cover on the top of the tank you will have to disconect the plug connector that goes to the sender, then put your hand into the tank and run your finger down the side of the sender and you will feel spring loaded plastic lug that you will have to press in then the sender will slide up off the plastic fuel pump housing, re-fit in reverse, it is alot easier if you have a torch so you can see inside the tank.

    2007 A4 3.0tdi Quattro S-line, Lava Grey Pearl, 229+bhp, 6 speed manual, Cruise control, Auto wipers/lights, Parking sensors all round, RNS-E Sat Nav, Heated Volterra leather, Adaptive Bi-Xenon plus headlights, Bluetooth phone prep/voice control, DRL, i-Pod dock, Coming home lights, A4 B5 front spring seat mod, LED DRL/side light/numberplate lights, Window tints, Cupra R front splitter, Black front grill, 3.5" custom tail pipes, 8.5x19 Calibre Excalibre wheels running 225/40/19, ET30-R ET35-F.

  10. #9
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    York
    Posts
    1,653
    Spot on jimbo, couldn't rememeber the exact details. Often people don't know about the plastic lug, so they pull the unit apart.

  11. #10
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Jimbo, thanks for that reply, looks helpful, i dont suppose you know anywhere with diagrams, as im just scared i'll end up breaking something, and is this a diy jobbie that i could do at home, btw im not super technical when it comes to mechanicals on cars??

  12. #11
    Jimbo.King's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Leeds
    Posts
    183
    Where abouts are you in the uk, ill do the job for some tokens if your near Leeds.

    http://www.vagcat.com/epc/cat/au/A4Q...19/50/2646147/

    Number 22's the fuel sender
    Last edited by Jimbo.King; 23rd January 2008 at 21:28.

    2007 A4 3.0tdi Quattro S-line, Lava Grey Pearl, 229+bhp, 6 speed manual, Cruise control, Auto wipers/lights, Parking sensors all round, RNS-E Sat Nav, Heated Volterra leather, Adaptive Bi-Xenon plus headlights, Bluetooth phone prep/voice control, DRL, i-Pod dock, Coming home lights, A4 B5 front spring seat mod, LED DRL/side light/numberplate lights, Window tints, Cupra R front splitter, Black front grill, 3.5" custom tail pipes, 8.5x19 Calibre Excalibre wheels running 225/40/19, ET30-R ET35-F.

  13. #12
    mwarrey's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2003
    Location
    Swansea
    Posts
    281
    A good article on how to do this :-

    http://www.audiworld.com/tech/elec77.shtml

    Mine is starting to do this as well, so I will be attempting a repair myself sometime in the future.

  14. #13
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Guys,

    Thanks for the responses, the pics just make it look even more technical...AAARRRGGHH!!!!

    Not to worry, Jimbo, I am in Brum, but will be in Gomersal over the weekend, if thats near you, do you know how long it will take to do the job, if you did do it, also would i need to get a new sender unit???

    Thanks

  15. #14
    Jimbo.King's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Leeds
    Posts
    183
    If its Gomersal near morley / Dewsbury im 30mins away, the job would take 30mins to a hour max, you would have to get the fuel sender unit from audi, mine was £40 and had to be ordered (overnight delivery).

    2007 A4 3.0tdi Quattro S-line, Lava Grey Pearl, 229+bhp, 6 speed manual, Cruise control, Auto wipers/lights, Parking sensors all round, RNS-E Sat Nav, Heated Volterra leather, Adaptive Bi-Xenon plus headlights, Bluetooth phone prep/voice control, DRL, i-Pod dock, Coming home lights, A4 B5 front spring seat mod, LED DRL/side light/numberplate lights, Window tints, Cupra R front splitter, Black front grill, 3.5" custom tail pipes, 8.5x19 Calibre Excalibre wheels running 225/40/19, ET30-R ET35-F.

  16. #15
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Jimbo thanks for the offer mate, but something has come up in the family, so not going to be coming now, if i can get it done down here I will do, otherwise if im up there soon, ill give you a shout if thats ok??

    Once again, thanks for all your help already....

  17. #16
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Guys, thanks for all your help, I fitted the sender today, was pretty straightforward and the link was spot on....All working ok now so happy days....

    Thanks again

  18. #17
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    OK OK, so the saga continues!!!

    I filled up today £50 and it still wasnt full....and there was about a fiver worths in there already!!!

    So anyway, I got into the car and started it up, it only showed a half tank, but eventually after 5 to 10 minutes the needle creeped up to show just under full tank....

    Now I have changed the fuel sender gauge and it started working instantly, but can someone explain, why its taking so long to register the fuel??

    Thanks
    Nilz

  19. #18
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Anybody please??

    Thanks

  20. #19
    Jimbo.King's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Leeds
    Posts
    183
    Could be a faulty fuel guage, i know the A3 dash suffered from faulty fuel and temp guages, fill the car up and watch the fuel guage, if it takes a while to go to full you could try tapping the top of the dash to see if it goes up any faster, if so it could be a faulty guage.

    2007 A4 3.0tdi Quattro S-line, Lava Grey Pearl, 229+bhp, 6 speed manual, Cruise control, Auto wipers/lights, Parking sensors all round, RNS-E Sat Nav, Heated Volterra leather, Adaptive Bi-Xenon plus headlights, Bluetooth phone prep/voice control, DRL, i-Pod dock, Coming home lights, A4 B5 front spring seat mod, LED DRL/side light/numberplate lights, Window tints, Cupra R front splitter, Black front grill, 3.5" custom tail pipes, 8.5x19 Calibre Excalibre wheels running 225/40/19, ET30-R ET35-F.

  21. #20
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    i had the car on a computer and it said no errors on the dash but i'll keep an eye on it

  22. #21
    AUDI TURBO's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Nov 2007
    Location
    YORKSHIRE
    Posts
    575
    my car jsut developed this fault but £10 in last night now showing got 5 miles left I DONT THINK SO. fuel sender here we come ££££££££&# 163;££££sssssssss
    Modified primera :-)

  23. #22
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    The sender is available from Euros at £45, however i have fitted mine and filled up since, it shows on the gauge now, but im sure the needle is stuck now, as I have done 200 miles and it still shows as being 3/4 of a tank full, whereas normally I would probably be on the 1/4 tank line by now, it even shows as having 300 miles left on the range, which is defo wrong.....so not sure what it could be now!!!

    Any ideas please????

  24. #23
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Anybody please???

  25. #24
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    Does anyone know how to reset the fuel gauge, as it does look like its stuck on the 3/4 mark...and thats no good especially as i do motorway driving everyday....i need to know how much petrol i got...lol....thanks

  26. #25
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    bump...sorry for bumping so soon, but i need to sort this asap.....am booked into the garage tomorrow, but would like to go in knowing what the issue is, rather than getting shafted for something its not if you know what i mean...

  27. #26
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Online
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,509

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    On the old audi 80's there was a chip that went on the rear of the dash causing all sorts of irregular readings, do not know if its true of the A4, i do know that you can get the dash repaiared to fix the faulty guage problem , well according to BBA/BMA (??) remanufacturers

  28. #27
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    OK i took it back and disconnected and reconnected it and it showed up with the real amount, i filled up with some petrol and it showed this, but i dont know how accurate it is, as i did about 50 miles today and it didnt really seem to move again....so frustrating!!!!!

  29. #28
    6th Gear

    Status
    Offline
    Join Date
    Jul 2006
    Posts
    1,562
    I've been putting up with the same problem for over a year now lol

    Fine when the tank is half full or more, but with smaller amounts, the gauge falls to zero and beeps at me every few minutes lol!!!!

    The car is at the garage as I type this, and it's on the chap's 'job list' to fix.

  30. #29
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,062
    OK next update, ive filled up again and once again it has got stuck at the 3/4 mark!!!

    This is a brand new sender unit, so why is this happening, could it be that its a faulty sender unit??

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO