Badger5Sky Insurance
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    2

    1998 A4 concert radio/cd player not working

    Hi,

    I had to get my battery replaced so the radio got locked. I have tried to get it out with the tool but it got stuck and didn't come out. While trying, I think I have snapped a clip or something inside the right-hand side hole to put the removing tool in. Now it wont even power up. It powers up if i push the radio in really hard.

    Anyone got any idea whats wrong with it?? I'd really appreciate some help. Let me know if you didnt really understand wot i said up there i can explain even further.


    Cheers!
    Last edited by zeeshan; 14th January 2008 at 10:53.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    Why were you trying to get it out, Audi can supply the code for £30?
    Yes you've snapped or bent one of the spring clips.
    You need to remove the glovebox and push the unit from behind.
    Alternatively you can prise off the front of the unit which will give you more access to the stuck clip. But basically a real hard push from behind is probably an easier route.

  4. #3
    Blue_Thunder's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Feb 2007
    Location
    Liverpool
    Posts
    1,693
    If it powers up when you push the unit hard, it sounds like you may have a loose connection at the back.
    Mo power, mo problems

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    2
    Thanks for your replys

    I found the software to get the code but i needed the serial number thats written on top of the radio.

    I went to the stealers and they said it'd be £50 to have a look at it and If i've broke something inside than there will be an extra charge for replacing it so that scared me off a bit.

    I will try pushing it out from the back and see if i can get it out but how do i replace the spring clip. it seems that it wont trun on unless its properly clipped in.

  6. #5
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    The clip is nothing to do with it turning on, by pushing it back in you're bunching up the cables at the back and making a connection on the power loom.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO