AH FabricationsChris Nott
Results 1 to 3 of 3

Thread: Clutch problem

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2005
    Location
    lebanon
    Posts
    92

    Clutch problem

    Hello , i changed my clutch and pressure plate and pilote bearing , and now it vabrite a bit in accelaration , is that normal and goes with time? is that possible because of the flywheel? and will goes with time when the clutch take the shape of the flywheel? or any other issue can cose this?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Neutral
    Space Invaders Champion

    Status
    Offline
    Join Date
    Aug 2006
    Posts
    65
    As far as I know you're supposed to changethe flywheel at the same time as changing the clutch. I'm sure some one will be along soon to correct me though.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Oct 2005
    Location
    lebanon
    Posts
    92
    as far as i know i must resurface it but i didnt i just sand blast it a bit , i think this vabrition when i took my foot from pedal is do to slip in the begin , cos it only when i engage the clutch , i think when the clutch will take the shape of the flywheel it will be 100% fine? or some one correct me please

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO