Volks AutosChris Nott
Results 1 to 7 of 7
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Jan 2012
    Location
    Malton
    Posts
    279

    why is my DIS doing what its doing

    On my 2.5 v6 the dis just looked a bit worn out and missed pixels from the top down in a kind of fadey outey sort of way. My Lad's 1.8T did the same thing.

    However - on dearly beloved SE the DIS seems to have horizontal lines that dont light up and then soemtimes vertical lines that dont light up. Bizarrely yesterday when I chugged up and down the rainy M1 to Milton Keynes it all lit up perfectly.

    What causes the DIS to fail and what could be happening on mine that the faiiure is inconsistent?
    Sliver 2000 1.9 Tdi AJM Se Auto Saloon cooking sherry but with CD Changer and now Bluetooth audio connection and boot based Tartan blanket. Now runs at 90 degrees like a good 'un. Quality Cambelt kit fitted - next on list is control arm set.
    Silver 2000 2.5 V6 Tdi Auto Quattro Saloon drowned on 7th August 2012 RIP - but she lives on in the many,many donor parts she gave so that others may live...


  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,993
    Its a known issue on most dis's from the 90s to around 2001 I think.
    The contacts break up in the ribbon cable from the PCB to the screen it self.

    The only way to fix it is to replace the screen.

    Buy one off ebay (Not the chinese cheap version) for about £50, unsolder the old and solder the new in. Done.

    You need a thin soldering iron nib.

    or I can do it for you.

    New Car, New Thread: Scott's Akoya Silver A8
    Gone But Not Forgotten: Audrey's Build Thread

  4. #3
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,350
    Mines temperature related. Some days its completely illegible, other days you car more or less work out what its saying with just the odd line missing.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  5. #4
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    254
    Quote Originally Posted by aragorn View Post
    Mines temperature related. Some days its completely illegible, other days you car more or less work out what its saying with just the odd line missing.
    Mine too. On a long journey or hot day the display is worse.
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  6. #5
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    2,158
    I got a new screen off ebay cost around £45, bit of a fiddly job but well worth the effort.

  7. #6
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,993
    Quote Originally Posted by aragorn View Post
    Mines temperature related. Some days its completely illegible, other days you car more or less work out what its saying with just the odd line missing.
    Quote Originally Posted by spartacus 68 View Post
    Mine too. On a long journey or hot day the display is worse.
    Heat makes a massive difference.

    Bring on the ICE!!

    New Car, New Thread: Scott's Akoya Silver A8
    Gone But Not Forgotten: Audrey's Build Thread

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Jul 2012
    Location
    Guildford
    Posts
    97
    I bought a cheap one from China for £35 and its still going strong 2 years on and looks fine. I used lots of flux when I solderedt to keep any bridges at bay. Use a heat gun to de solder the old unit.

 

 

Similar Threads

  1. Guess what im doing tomorrow!?
    By audi-a6 in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 14
    Last Post: 10th September 2013, 18:19
  2. Replies: 8
    Last Post: 8th June 2010, 12:03
  3. Replies: 29
    Last Post: 2nd June 2010, 12:15
  4. S3 90k Service - What needs doing?
    By VTI_EG_DAN in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 20th February 2009, 21:02
  5. Why does this 5000 quit on its own??
    By Sabre60 in forum Classic Audi Forum
    Replies: 1
    Last Post: 5th May 2004, 01:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO