AH FabricationsJMB Retrofits
Results 1 to 8 of 8

Thread: Speedo Issue

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    20

    Speedo Issue

    Hi guys. I've recently got a b5 A4 2.5 TDi with the AFB V6 engine and 6-speed box. It's front wheel drive if that makes any difference. I've got an issue with the speedo whereby it intermittently stops working. Needle just dies back to 0 regardless of how fast I'm travelling. Only ever lasts a few seconds and then jumps back into life and works as it should. Has anyone come across this problem before or know where to start looking?
    Thanks in advance
    Dave

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Aberdeenshire
    Posts
    592
    Hi it could be an instrument issue or the road speed sensor I would say the best bet would be to get a scan done to point you in the right direction.

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    20
    I scanned it myself and it didn't throw any faults up

  5. #4
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,383
    might be worth checking the plugs/wiring to the speed sensor on the gearbox? Then replacing the sensor if that doesnt show up anything?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  6. #5
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Aberdeenshire
    Posts
    592
    Depending what diagnostic set up you used it might be worthwhile graphing the sensor for loss of signal

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    20
    Thanks guys. At least I know where to start now

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Also the earthing points on the chassis for the speed senser and cluster curcuit, my a3 did the same and it was bad earths, usually previously i would condem the cluster!
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    20
    Thanks mate

 

 

Similar Threads

  1. Speedo issues
    By Den13 in forum A3/S3 Forum (8L Chassis)
    Replies: 20
    Last Post: 1st January 2013, 13:40
  2. Audi A3 1.6 1999 Speedo Issue
    By FMAudia31.6 in forum General Technical / How To
    Replies: 7
    Last Post: 19th September 2012, 14:50
  3. Audi A3 1.6 1999 Speedo Issue
    By FMAudia31.6 in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 2nd September 2012, 17:35
  4. A3 Speedo problems issues 1996-2003
    By caddypete in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 28th December 2011, 12:52
  5. A3 Speedo/Fuel gauge issues
    By 1animal1 in forum A3/S3 Forum (8L Chassis)
    Replies: 46
    Last Post: 28th August 2010, 19:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO