EM TuningAH Fabrications
Results 1 to 39 of 39
Like Tree1Likes
  • 1 Post By B5NUT

Thread: misting up windscreen when heater is on

  1. #1
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869

    misting up windscreen when heater is on

    Today I have been having problems with misting up windscreen, when I put the heating on early this morning the windscreen misted up and there was a very fine layer of mist across the windscreen and the front side windows, I ended up putting the heater on full and on full heat, and had the same problem on the way home. The drive is around 100 miles round trip. The carpet does not feel damp and I check the coolant level this evening and it does not looked like it's dropped any but I am worried the heater core has a very small crack which could be dripping and causing the misting.

    Is there anything I can check, or should be looking for?

    Also is the heat exchanger a dash out job?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    244
    Quote Originally Posted by B5NUT View Post
    Today I have been having problems with misting up windscreen, when I put the heating on early this morning the windscreen misted up and there was a very fine layer of mist across the windscreen and the front side windows, I ended up putting the heater on full and on full heat, and had the same problem on the way home. The drive is around 100 miles round trip. The carpet does not feel damp and I check the coolant level this evening and it does not looked like it's dropped any but I am worried the heater core has a very small crack which could be dripping and causing the misting.

    Is there anything I can check, or should be looking for?

    Also is the heat exchanger a dash out job?
    Hope it's not heater matrix. Link here to piccies from Audifans site... deep breath!
    Brief guide to removing your heater Matrix B5 1997.. pics - Audifans.net
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  4. #3
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    It's not the best of jobs, and could think of better things to do with my time, but had a lot worse over the years. I just wonder if there are any way of checking the matrix before I rip it out. Also anything else I should change while I'm there

  5. #4
    B5 BIKER's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    GALWAY, EIRE
    Posts
    235
    Check Scott b5 page, I think he had the same problem and he did a fab write up with pics regarding the change

  6. #5
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Cheers had a quick look, the job is not that bad just don't want to do it if that's not the problem. I'll PM scott to see how much coolant he was losing. Have to say I've replaced a fair few O-rings over the last few weeks so would not surprise me the matrix is on it's way out.

  7. #6
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,652
    B5NUT, does the car smell of coolant at all?
    If you put it on full and put your hand over the vents do you get any smell or moister on your hands and does that smell/taste of coolant?

    The only evidence I had of a leaking heater matrix is the smell and a slight coolant loss.

    When you buy your heater matrix I would recommend going to Audi for a new one.
    I've heard reports of others not fitting right and causing issues (Westy being the main one).

    Don't forget as well you need to drain your AC gas.
    A4 B5 Double Din, RNS-d, TMC, Full Sports Leather Heated with Leather Door Cards and Lower Door trims all for sale.

    Audrey's Build Thread
    RIP Audrey. She's being broken down.
    New Car, New Thread.
    Scott's Akoya Silver A8

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Thankfully no coolant smell, put a dehumidifier in the car overnight and the car was fine this morning, I am going to replace the air filter and the ECU seals as I've seen water getting into A4's after they have failed.

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Bamfurlong Wigan
    Posts
    199

    My Social Networking

    Add scr8pdo on Google+
    I had same problem on a Volvo years back, first thoughts were heater matrix "******XXX!" anyway I wasnt loosing coolant, it was around this time of year, someone who I knew who was into Volvos told me to flick the aircon on while demisting, I dont know the science but it bloody worked, it could well be a matrix problem you have, check your water level, for damp carpets etc (usual suspects) then if you find it is that a bottle of K-Seal will permenantly cure the swine, I used to buy it in bulk knocking out old bangers, its fixed more headgaskets than I remember and I still know of one 3 or 4 years on running fine and it was a pretty baddun at the time, the stuf is magic

    Also check the battery area aint got a pool of water swilling about there matey, the scuttle drains are known to block then water runs back through the heater fan!

  10. #9
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    Check the scuttle drains are clear.

    Do you run the AC a lot? I've seen cars misting up when the AC is used lots, then turned off.

    Alternatively, if the cars getting damp inside from you getting in with wet clothes or similar, but isnt getting properly dried out, it'll go like that. My brother used to have real trouble with his S4 as most days he only drove about 4 miles to work. The inside of the glass had so much moisture on them they'd ice over on the inside!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  11. #10
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    The car gets over 100miles a day, the AC is just left to Auto and it's just had a regas as I replaced the compressor. I don't leave any wet clothes in the car so I can only think some of the seals are on there way out.

    I'm not going to put k-seal in the car I don't mind replacing the matrix if it has gone, it's just a lot of effort and no visible results (other than a possible leak stopped)

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Bamfurlong Wigan
    Posts
    199

    My Social Networking

    Add scr8pdo on Google+
    Are the matrix a swine to change on these? I remember changing MK5 Cortina ones in nigh on under a minute they were that easy at the time, but times have changed

  13. #12
    1st Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Bamfurlong Wigan
    Posts
    199

    My Social Networking

    Add scr8pdo on Google+
    I thought Id take the old girl through the car wash today ( I know tut tut etc but I not botherered) anyways after I ran it through the top wash (it gets like 2 cycles being the better program) I go in the back to get something and the youngster (2yr old) had left the damned window down around an inch or so, it was drenched in there! Not amused at all :/


    PS He was not onboard at the time.

  14. #13
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    isnt there a rear window lockout switch to stop that exact thing happening?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  15. #14
    1st Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Bamfurlong Wigan
    Posts
    199

    My Social Networking

    Add scr8pdo on Google+
    Dunno mate, its an early car with leccy front windows but manual rears

  16. #15
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    ah fair enough.

    Cars with electric rears have a button to lock them out, so kids in the back cant lower them.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    19
    Daft suggestion but mate of mine had this years back and asked me about it, he had his vents set to recirculate. Switched it to take fresh air in and problem solved.

    I know it sounds stupid but though was worth putting out there.

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    Bamfurlong Wigan
    Posts
    199

    My Social Networking

    Add scr8pdo on Google+
    I remember some cars like this, IIRC old MK2 Jags had them too

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Only use recirculate when in tunnels, or some old banger in front spewing out the cr@p, it was OK today, just a bit on the side windows going to replace the seals at the weekend.

  20. #19
    jbh
    jbh's Avatar
    TDi lover

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Slamannan/ Central Scotland
    Posts
    635
    I use the recirculate when im on the m9 passing Polmont... the landfill at the side of the motorway stinks
    1997 A4 Avant 110 TDi quattro
    1996 A4 Avant 110 TDi breaking

  21. #20
    jcb
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    uk
    Posts
    4,070
    check your pollen filter and scuttles (or just buy a new one, the air smells cleaner after!)
    leaves and crap raising drain levels and a slight amount of water in the pollen filter and your fan is sucking moist air in

  22. #21
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    i seem to havethe same problem

    Blower works but only kicks out cold air no matter where the gauge is set

    Getting too cold to run a car with no heating

    looking at pulling and replacing the matrix

    car off road for a few days (or more) lol

  23. #22
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Figured I would update this thread. The heater matrix is the cause..

    As you can see it must have been a very small leak






    The bottom of the matrix is dry and there was no pool of coolant in the box.



    Removing the matrix has been a proper c**t of a job the engineers at Audi must have been laughing like hell when they designed this setup.



    New heater matrix, note the foam seal on the top of the matrix and along the side are additional parts you need to order and don't come with the matrix.



    Last edited by B5NUT; 28th September 2013 at 11:02.
    spartacus 68 likes this.

  24. #23
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Not get very far today, sheared the bar that goes between the two centre console supports, then spent 3 hours trying to find someone breaking a facelift B5 in the area and thankfully I found one.

    Don't over tighten this bar, or this will happen...



    As far as I got today the rest should be done tomorrow as long as the weather holds.


    Also anyone who has done this job or had the dash out was there any problems with rattles or creaking afterwards.

  25. #24
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    244
    Quote Originally Posted by davy j View Post
    i seem to havethe same problem

    Blower works but only kicks out cold air no matter where the gauge is set

    Getting too cold to run a car with no heating

    looking at pulling and replacing the matrix

    car off road for a few days (or more) lol
    Could be stuck thermostat if you're getting no heat. If thermostat needle doesn't rise (should sit at 90 degrees), then this could be possible cause before hauling out matrix.
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  26. #25
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    244
    Top job B5NUT! Good luck with the reassembly.
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  27. #26
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Thank feck for that, car is back together and at the moment appears to be working fine with no rattles or creaking.

    I did have one problem which threw up this error code
    01271 - Positioning Motor for Temperature Flap (V68)
    41-00 - Blocked or No Voltage

    Turned out to be a lose screen just above where the arm is and it was fouling on the screw.



  28. #27
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,652
    Its not a fun job but I think I got it down to 6 hours for remove and refit.
    The joys of doing it twice in 4-6months lol.

    What's this wood for?


    I noticed bout the foam, little bit annoyed about it. It should have came with the matrix. I never had time to order some so I reused what was on the original one.
    A4 B5 Double Din, RNS-d, TMC, Full Sports Leather Heated with Leather Door Cards and Lower Door trims all for sale.

    Audrey's Build Thread
    RIP Audrey. She's being broken down.
    New Car, New Thread.
    Scott's Akoya Silver A8

  29. #28
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    It was to hold up the steering column, as much as I tried I could not remove the housing without moving the cross member, once that was moved up slightly the housing came straight out. They change to design of some of the dash parts between the PFL & FL so not sure if it had to be moved but made it easier to remove and refit the housing.

    The foam on my unit was destroyed due to the coolant and no chance of reusing it.

  30. #29
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    Thought i would update you on my own problem

    Decided not to pull interior apart and checked hoses instead.

    With a little help from jbh (thanks) managed to get heat out of the system at last

    ended up replacing the thermostat and refil the system with 50/50 mix of antifreeze and water and the got the problem of misting windscreen back (bummer)

    When i went from low temp to high temp i was getting a pile of smoke coming out of the top vent (not nice when you are doing 70) and instant fog on front screen.

    Ended up leaving car running with high temp for half an hour and this seems to have sorted it (hopefully)

  31. #30
    Neutral

    Status
    Offline
    Join Date
    Feb 2013
    Posts
    94
    That looked a nightmare of a job.

  32. #31
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    just stripped mine today

    Pig of a job

    6 hours and still not out

    inaccessible plugs and car fighting me every step of the way

    Next time this happens the best cure.....
    scrap it and get another one LOL

  33. #32
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    If you had to pay someone to do the job on a car our age then you are looking at the car being scrapped, just to many hours labor!

  34. #33
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    14,652
    Its not the best job to do but its worth doing it.
    Saves you loads of money over getting a garage to do and you know everything is put back correct and in the right place.

    After doing mine twice, I'll happily do it again and it scrap the car.
    It seems such a waste for a semi awkward job.
    A4 B5 Double Din, RNS-d, TMC, Full Sports Leather Heated with Leather Door Cards and Lower Door trims all for sale.

    Audrey's Build Thread
    RIP Audrey. She's being broken down.
    New Car, New Thread.
    Scott's Akoya Silver A8

  35. #34
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    car put back together at last

    gonna have to strip the wheel off again as i have no horn lol

    and airbag light on (already arranged to get it reset)

    Thanks jbh

  36. #35
    6th Gear

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    1,869
    Did you disconnect the battery before your started the job? I never got an airbag light on and as the horn is all part of the same harness, I think you may not have a plug not seated correctly, and if that is the case the rest won't work.

  37. #36
    jbh
    jbh's Avatar
    TDi lover

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Slamannan/ Central Scotland
    Posts
    635
    yip I agree with above. check you're plugs Dave you will need the light reset now that its stored a fault but as above something isint right if you have no horn and the airbag light has come on.
    1997 A4 Avant 110 TDi quattro
    1996 A4 Avant 110 TDi breaking

  38. #37
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    just checking everything and no horn!!!!

    gonna take wheel off again today and have a look to see what i missed

  39. #38
    davy j's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2013
    Location
    Edinburgh
    Posts
    50
    ended up the earth unplugged itself within the binacle(under the dials) got horn back but still got airbag light on.

    Battery gets unplugged every time i deal with air bags

  40. #39
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    airbag light will stay on until you reset it.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


 

 

Similar Threads

  1. strange clicking noise when putting heater on
    By tdi-man in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 5th September 2010, 14:14
  2. Windscreen mists up ... drier
    By ashurz in forum Air Conditioning
    Replies: 5
    Last Post: 27th May 2010, 13:37
  3. heater works better when i use my wipers !
    By white.akita in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 3
    Last Post: 9th March 2009, 23:27
  4. windscreen misting up!
    By ian52 in forum A4/S4 forum(B5 Chassis)
    Replies: 4
    Last Post: 28th October 2008, 19:15
  5. Lifting windscreen wipers when washing!
    By benw123 in forum A3/S3/Sportback (8P Chassis)
    Replies: 12
    Last Post: 12th January 2005, 12:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO