JMB RetrofitsVolks Autos
Results 1 to 2 of 2
  1. #1
    LPG Abuser & have VAGCOM

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Essex
    Posts
    180

    Oil Sensor Help needed

    My sump oil level sensor decided to start to fail - sensor faulty on the dis (the one in the sump) - I changed it for a cheapie from Euro Car Parts, I assume that the level sensor worked however I noticed on its first use that the temp sensor on the dash now does not work while driving and only seems to work when the ignition is on - but the engine not running!
    Not knowing how this system works - IS this a known fault with cheapie sensors ? or do I have something else wrong?!
    Thanks!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,390
    Hmm, mine works, but always reads higher with the engine off...

    So you'll pull into a petrol station and shut off, fill up with fuel and get back in and the guage will show 100c. Start the egnine and it drops to 80-90c within a minute or less.

    Maybe yours is doing similar? Remember your oil will take a good 10 miles or more of driving to reach temp, and if you have a faulty thermostat it might never get high enough to display properly.


    Check your coolant temp stays at 90 using the climate diagnostics.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


 

 

Similar Threads

  1. Egt sensor help needed.
    By markyR in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 31st December 2012, 22:01
  2. A3 2.0tdi 2006 sline fan problem and oil leak help needed!!
    By gibbyA3 in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 16th September 2012, 19:01
  3. 3.0 TDI Quattro - Oil Leak, help needed
    By David Cook in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 3
    Last Post: 31st December 2011, 03:21
  4. Urgent Help Needed - Lateral Acc Sensor with pic
    By imported_Stewart in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 29th November 2011, 18:50
  5. 2.0 TDI OIL LEAK!!!!! HELP NEEDED!
    By A3Alice in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 21st January 2010, 00:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO