Chris NottAH Fabrications
Results 1 to 22 of 22
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59

    Help needed! Oil pressure light TQS

    Hi everyone, my A4 hasn't been driven for a month so I took it for a run today, after around 2 miles of driving the red oil pressure light came on, I quickly stopped and switched the engine off and on again but the light has came back on, drove home and the car sounds like a tractor (ticking away) I have checked the oil level and that's fine, also my oil temperature gauge has never worked since owning the car.


    Please help, any advice would be great.

    Sorry if this question has been asked before.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    4th Gear

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    765
    Sounds like pump failure

  4. #3
    5th Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Great Melton Norfolk
    Posts
    1,340
    Was there a beeping or buzzer as well?

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    I hope not, the car was running perfect, I always let it idle up to temperature before driving it, just seems out of the blue that its happened.

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    Yes when the light came on the dash I beeped 3 times as a warning.

  7. #6
    5th Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Great Melton Norfolk
    Posts
    1,340
    Sounds like oil pump pick up blocked /sludged up and starved pump.
    You could take sump off and check if its sludged up and clean pick up pipe.

  8. #7
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,907
    If its over 100k just stick a new pump in when its apart. That light means "turn it off immediately" So you'll have to hope you've not damaged anything else!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  9. #8
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    Would doing an engine flush help at all? Or would running the engine during the flush cause more damage?

  10. #9
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    no needs the pick up cleaning or changing
    i recon you have took the turbo out at least.
    as above means do not drive

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    What you mean took the turbo out?

    The drive home was only 2 miles maximum, so dropping the sump is the only protocol?

    Thanks

  12. #11
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    7,927
    2 mile with the no oil preasure can be very bad
    yes sump off and clean as above if its high miles think about changing the pump aswell

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    Ok I will try that, I hope the turbo isn't goosed as well.

    would it be best to fit a genuine oil pump or has anyone has any experience with eBay ones?

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    What oil would everyone recommend to use after replacing the oil pump?

    Thanks again everyone

  15. #14
    griswold's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    336
    5W40 fully syn regular changes and fit the larger oil filter
    A4 1.8T Quattro sport
    A6 2.4 Avant SE



  16. #15
    griswold's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    336
    eurocarparts large oil filter for 1.8tqs 501440080 £9 free with their own brand oil
    A4 1.8T Quattro sport
    A6 2.4 Avant SE



  17. #16
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    So the sump is now off, the oil pick up pipe is blocked up by all the sludge etc, would you all advise changing the oil pump?

    Has anyone used non genuine pumps?

  18. #17
    5th Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Great Melton Norfolk
    Posts
    1,340
    I would fit new oil pump. Genuine would be better.No idea how much they are though.

  19. #18
    Bradderz_1988's Avatar
    Dont replace it, Upgrade it !!

    Status
    Online
    Join Date
    Aug 2010
    Location
    Westhoughton, Bolton
    Posts
    2,875
    1999 Audi A4 1.8T Quattro Sport - Volcano Black

    Mods - Frankenturbo F4 Kit - THS Decat - Milltek - ECS Crank Pulley - 034 Snub + Bracket/Gbox Mounts - 1Z/S2 Clutch + Flywheel - 007p - ICM + EVAP Delete - S4 B6 345mm Brakes - 300mm Rear Brakes - Goodridge Hoses - LCR Splitter -S4 Bumbers + Skirts/Mouldings - OEM Xenons - Apikol Diff mounts - Polytek'd Rear Diff Mount
    To do - F21 Upgrade - 3" Maf/Saab red Injectors
    WANTED : Cheap 02/52 Passat 1.8T AWT Manual

  20. #19
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    Thought I would update things here, had a few issues when I bought the A4 a few months back, so far I have changed the oil pump, thermostat, coolant temp sensor, rear brake pads, service with bigger oil filter and replaced all 4 springs with eibach ones.

    The car is running great now, I will try and set up a build thread ASAP, thanks for everyone who answered my questions.

    Thanks J

  21. #20
    5th Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Great Melton Norfolk
    Posts
    1,340
    Glad to hear its running well now.

  22. #21
    boost-addict's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    977
    yer glad to hear there was no lasting damage

  23. #22
    Neutral

    Status
    Offline
    Join Date
    Jan 2013
    Posts
    59
    Yeah no lasting damage thankfully, I just replaced the oil pump and good new oil and all seems well for the last 1000 miles or so.

 

 

Similar Threads

  1. help please. oil pressure light :(
    By coatesy in forum A3/S3 Forum (8L Chassis)
    Replies: 21
    Last Post: 26th September 2012, 13:13
  2. Oil pressure light again 1.8t HELP!!
    By Ryan360 in forum A3/S3 Forum (8L Chassis)
    Replies: 25
    Last Post: 4th July 2011, 18:40
  3. Oil Pressure Light
    By filipharvey in forum General Chat
    Replies: 4
    Last Post: 23rd September 2007, 20:52
  4. Help needed !! Engine coil light flashing.
    By Leelacmn in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 11
    Last Post: 4th February 2007, 15:19
  5. urgent help needed pls - ECU light / limp home mode
    By MrCoont in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 24th June 2006, 21:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO