Sky InsuranceJMB Retrofits
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    england, northampton
    Posts
    3

    Issues with Driver Display Red Symbols and White Smelly Smoke

    Hi All

    Not had audi long and have issue with the corrupt display, sometimes have all lines sometimes quite a few gone.

    Anyhow, when you first jump in car DIS goes on and then will display words OK.

    Now one question I managed to turn off the speed warning eventually but when i held in the button on dash I got a few red symbols then a few yellow symbols that couldnt at time work out what any were.

    is this normal???, the display did say OK afterwards. What function does that push button have on left hand side of clocks especially if you hold it in for a few seocnds and then let go.

    Never had EML light on and only thing I do get is fuel light popping up on DIS.

    Reasons for my questions is car is running really rough.

    Real bad smell from exhaust, smells like eggs and sometimes but not always a lot of thick white smoke and it stinks, especially last 2 days as weather outside is really cold.

    Anyone got any ideas on what may be lurking
    Last edited by audistefone; 4th November 2012 at 17:34.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    254
    Lots of issues with DIS displays with missing lines, etc. Replacement guide here: Official DIY 2000 Audi S4 LCD Instrument Cluster Pixel Repair


    Regards white exhaust (I was initially thinking head gasket), but the combination of the smell suggests a sensor issue. Double check the coolant reservoir that it doesn't have oily residue to rule out the gasket. The coolant is G12 and should be red in colour. You haven't said what the car model is, petrol or diesel? Could be coolant temperature sender or Lambda O2 sensor if it's petrol. A scan of the system will identify logged error codes.

    The button on the left side of the dash changes the clock if pulled, and mph speed alarm if pushed.
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2012
    Location
    england, northampton
    Posts
    3
    Quote Originally Posted by spartacus 68 View Post
    Lots of issues with DIS displays with missing lines, etc. Replacement guide here: Official DIY 2000 Audi S4 LCD Instrument Cluster Pixel Repair


    Regards white exhaust (I was initially thinking head gasket), but the combination of the smell suggests a sensor issue. Double check the coolant reservoir that it doesn't have oily residue to rule out the gasket. The coolant is G12 and should be red in colour. You haven't said what the car model is, petrol or diesel? Could be coolant temperature sender or Lambda O2 sensor if it's petrol. A scan of the system will identify logged error codes.

    The button on the left side of the dash changes the clock if pulled, and mph speed alarm if pushed.
    Will take a look in morning

    My car is Audi A4 1.8t Sport Avant 1999 Facelift

    What is the best scanner for audi, I used to have elm for my astra coupe and android apps, what is out there for audi, presume OBD socket is the one in rear next to ash tray.

    is it normal then when pressing button on dash for all instrument symbols to appear, i.e 3 large red ones and numerous yellow ones.

    If there was an issue with oil/coolant and I received a large red symbol whilst driving does this symbol permanently stay on display or does it disappear. If there is no EML surely sensors are working?

  5. #4
    spartacus 68's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Aberdeenshire
    Posts
    254
    Quote Originally Posted by audistefone View Post
    Will take a look in morning

    My car is Audi A4 1.8t Sport Avant 1999 Facelift

    What is the best scanner for audi, I used to have elm for my astra coupe and android apps, what is out there for audi, presume OBD socket is the one in rear next to ash tray.
    Best with a full copy of VAG-com. Yes, OBD socket is behind centre armrest in ashtray.

    Quote Originally Posted by audistefone View Post
    Is it normal then when pressing button on dash for all instrument symbols to appear, i.e 3 large red ones and numerous yellow ones.
    Not in my experience. Normally it's just the speed (mph) symbol, however I haven't tinkered with it lately.

    Quote Originally Posted by audistefone View Post
    If there was an issue with oil/coolant and I received a large red symbol whilst driving does this symbol permanently stay on display or does it disappear. If there is no EML surely sensors are working?
    No, the sensor can be intermittent, but invariably if it's come on it will need dealt with. A scan with VAG-com will throw up the error codes and save you time and money in the long term.
    2002 A2 1.4 TDi SE (125k)
    2001 A4 2.5 TDi Avant Quattro Sport (155k)
    1995 80 TDi Avant SE (175k) Sold

  6. #5
    3rd Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    646
    Quote Originally Posted by audistefone View Post
    Hi All

    Not had audi long and have issue with the corrupt display, sometimes have all lines sometimes quite a few gone.

    Anyhow, when you first jump in car DIS goes on and then will display words OK.

    Now one question I managed to turn off the speed warning eventually but when i held in the button on dash I got a few red symbols then a few yellow symbols that couldnt at time work out what any were.

    is this normal???, the display did say OK afterwards. What function does that push button have on left hand side of clocks especially if you hold it in for a few seocnds and then let go.
    You need a copy of the handbook to help you with the DIS - you should get one online, or second-hand easily enough.

    If you hold the button in with the car stationary, it will do a self test that shows all the symbols in order.
    If you pull the button out, you adjust the clock
    On start up, it performs a Power On Self Test, and displays 'OK' when first turned on
    The other thing to watch is that you can turn off the display if you press the bottom button on the stalk. There are a few threads on that.
    To reset statistics, call up the one you want (eg Average (uses the 'O' with a line through symbol) MPG , press and hold the lower stalk button for a couple of seconds and it will reset to zero.

    As Spartacus said, DIS lines are common. I sent mine away to ECU Testing, and was happy with their service. Others have used others equally happily. It costs about £150 give or take.
    If you try and be clever and just fit a second-hand clock set, you will have lots of trouble trying to code keys and ECUs as the immobiliser is built into the clocks.

    As Spartacus also said, VCDS is THE scanner to get.
    Nigel (NHN) on here sells them - find him in the VCDS forum. Alternatively you can get from RossTech direct. The leads are expensive (couple of hundred quid ) but are worth it IMHO.
    You can get clones off e-bay for £10-£25, but that is norty, and you can have problems getting them to work. If you have a clone lead, any questions on here will bring forth much righteous indignation and little help.
    It is acceptable to get a clone lead, and then download VCDS-Lite from Ross-Tech. This gives basic functions and allows you to try out VCDS on the cheap. You can then buy a license from Ross-Tech ($100 IIRC) that gives more functionality, and if you then buy the real thing form them, they credit you the license fee.
    That was the route I took.
    1999 A4 B5 1.9 TDi FWD Saloon, Green SOLD
    2000 A4 B5 2.5 TDi Quattro Avant, Maroon, 'Panzer' Plated (currently sporting wrecked engine - and gearbox )
    2000 A4 B5 2.5 TDi Quattro Saloon, Blue, 'Panzer' Plated, Cruise Control retrofitted, OEM 6 Disc Changer retrofitted
    2006 A6 Allroad 3.0 TDi Blue, awaiting stuff to be done!

 

 

Similar Threads

  1. Common Issue with the DIS
    By coupe-se in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 8th February 2007, 19:19
  2. Still Having Perfomance issues with my 2.5tdi Allroad
    By Biggles in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 18
    Last Post: 23rd January 2007, 21:32
  3. Driver display - ice?
    By David_Moon in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 20th November 2004, 19:31
  4. Faulty driver display panel
    By DunnerDan in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 11th November 2004, 13:54
  5. Drivers Display
    By imported_Cirus in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 25th August 2004, 22:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO