Sky InsuranceBadger5
Results 1 to 11 of 11
  1. #1
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405

    Red oil can of doom!

    While driving today I had the red oil can of doom light up on the dash. We have just changed the oil and filter and there were signs of sludge When it happened I dipped the clutch and pulled over right away and then limped 1 mile home with out the light on.

    After the oil change I also replaced the dipstick top section as the old one was falling apart. I fear some of the plastic may of dropped down the dip stick hole as it fell apart on Removal how bad would it be if this was the cause?

    Im guessing it's a sump off job with new pick up and oil pump?
    Last edited by Chriscooke; 23rd June 2012 at 00:58.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,378
    sump off and a clean out at the very least, probably worth sticking a new pump in when its apart.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    I have a mechanic mate who's pretty clued up with these engines so I'll get him to do it I think. Any idea how much a new pump would cost? I'm hoping that as he's in the trade he may get it at cost/trade price.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    13
    Check the oil pressure switch. Its on the filter housing the connections may have been disturbed when changing the filter. I got the light on the day after I bought my car and it was just the pressure switch that was leaking

  6. #5
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    Mine was only on intermittently. So doubt that's the problem but will double check. Was hoping it might of been oil level related but guess the other yellow warning light woul be lit.

    Cheers for the tip

  7. #6
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    All fixed. Well fingers crossed anyway

    The oil pick up was absolutely cacked in crap. Will do another oil change in a few hundred miles if it continues to play ball

  8. #7
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Good man.

    You drop the subframe or jack the motor?

  9. #8
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    Cheers Can't take the credit myself unfortunately as a mate did it.

    We undid all the engine mounts and jacked the engine right up using two trolley jacks. The near side mount needed to be removed completely in order to wiggle the sump out as well.

    The rear two bolts on the sump had us stumped for a while also.

  10. #9
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    I now seem to have a slight oil leak we did have two bolts left over so guess they were something important.

    These are the bolts in question.



    I have a hunch they could be from the oil return from the turbo to sump flange. Anyone able to confirm?

  11. #10
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,378
    they look about right for the turbo oil return, pretty easy to look under and see that pipe though, wouldnt even need to jack the car up...

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  12. #11
    Chriscooke's Avatar
    Clueless!

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Taunton
    Posts
    405
    I've messed my back up but will try and have a look shortly. Cheers mate.

 

 

Similar Threads

  1. Red Oil Warning Light Beeping ?
    By AudiJohn in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 15th January 2012, 14:36
  2. 2001 (y reg) a3 1.8t red oil light with 3 accompanying beeps!
    By Metro in forum A3/S3 Forum (8L Chassis)
    Replies: 45
    Last Post: 30th December 2011, 21:15
  3. "Oil Can" Symbol
    By VeeDubDan in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 8th November 2011, 12:28
  4. SHELL OIL..CAN I USE THIS
    By vw754 in forum Diesel forum
    Replies: 0
    Last Post: 11th January 2009, 19:31
  5. Red oil light
    By daz2347 in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 26th April 2007, 23:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO