Sky InsuranceVolks Autos
Results 1 to 3 of 3
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    5

    Rough running A4 1.9 TDI AHU

    Hi all,
    Having some problems with my A4 1.9 tdi, 1999, 189k.
    When I try to start the car the Glow Plug Light only comes on the odd time after turning the key a good few times, if there's no light the car won't start and when the lights on it starts then after a few minutes it has a rough idle issue.
    Had the car scanned with Vag Com and it showed up these issues

    18062-Please check DTC Memory of instrument cluster
    P1654-35-10- - Intermittent

    17964-Charge Pressure Control
    P1556-35-00- Negative Deviation

    17552-Mass Air Flow Sensor (G70)
    P1144-35-10-Open or short to ground - intermittent

    18027-Glow Plug Relay (J52)
    P1619-35-10-Open or short to ground - intermittent

    So I replaced the Mass air flow sensor, Glow plug relay (Mine was relay number 219 not 109) and had the errors cleared. Then tried to start the car but still no glow plug light until a few turns of key then it would start and after a few minutes the rough idle was back again.
    Scanned car again and its now showing 1 issue:

    01314- Engine Control Module
    49-10- No Communication.

    Any help would be great as I'am starting to lose faith.
    Cheers

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Bradderz_1988's Avatar
    Dont replace it, Upgrade it !!

    Status
    Online
    Join Date
    Aug 2010
    Location
    Westhoughton, Bolton
    Posts
    3,109
    IIRC this has been posted before and i think the ecu is the cause of this problem but i may be wrong, i tend to stay away from the derv's lol only petrol runs in my blood.
    1999 Audi A4 1.8T Quattro Sport - Volcano Black

    Mods - Frankenturbo F21 Kit - 3" MAF - Saab Reds - THS Decat - Non Res Milltek - ECS Crank Pulley - 034 Snub + Bracket/Gbox Mounts - 1Z/S2 Clutch + Flywheel - 007p - ICM + EVAP Delete - PFR6Q Plugs - S4 B6 345mm Brakes - 300mm Rear Brakes - Goodridge Hoses - LCR Splitter -S4 Bumbers + Skirts/Mouldings - OEM Xenons - Apikol Diff mounts - Polytek'd Rear Diff Mount
    To do/planned -Eibach pro's - GT2871/76R + FMIC + ME7 (maybe) + Engine/stroker Build

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    5
    Hi Bradderz_1988. Think it could be the ecu, going to do few more checks then maybe order a secondhand one and get it coded to the car.

    Cheers

 

 

Similar Threads

  1. Running rough A4 avant 2.0 TDI B7
    By prs999 in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 3
    Last Post: 2nd November 2011, 14:57
  2. HEEEELLLLPPPP!!!! - Rough running A4 Avant 2.0 TDI SLine (57 Plate)
    By oneightycd in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 20th January 2011, 19:55
  3. vw 1.9 tdi running rough
    By hul71 in forum General Automotive Chat
    Replies: 1
    Last Post: 8th May 2010, 20:39
  4. Why's My 2.0 TDI Running Rough on Idle? (With Vid)
    By kaz219 in forum A3/S3/Sportback (8P Chassis)
    Replies: 48
    Last Post: 8th December 2009, 12:18
  5. Problems with 2.0 tdi running rough when cold
    By Pedro in forum A3/S3/Sportback (8P Chassis)
    Replies: 11
    Last Post: 15th November 2009, 17:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO