Monster MotorsportSky Insurance
Results 1 to 7 of 7
  1. #1
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,384

    Weird ECU/Turbo Lag.

    So, i've noticed this oddness when driving the car hard, in that theres a lag after a gearchange.

    So you go full throttle thru 2nd gear to say 6500rpm, change to third and go full throttle again, and the car starts to accellerate, then after a moment, perhaps 0.5-1seconds, it starts accellerating harder.

    Today i noticed that if you watch the boost guage when this occurs, the needle quickly flicks round to 5psi, and sits there for this 0.5-1sec period, then it sweeps round to 10-12psi and the car stars accellerating more. So clearly its not mechanical lag, as the fact the turbo hits 5psi instantly suggests the turbo has spooled instantly but the wastegate has simply opened at actuator pressure.

    I first noticed this ages ago on the Avant, and put it down to the old turbo being a bit shonky, however i've started noticing shed does it as well.

    First off does anyone else have this phenomenon, and if not, any ideas of the cause?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    Bedford
    Posts
    2,877
    Mine does it too. But i posted on the 8L thread as i saw it there first lol.

    Cactus green 8L S3 - B5 TIP + Jetex, Revised 007p, R32 rear ARB, AP Coilovers, Compbrake rear arms, Full Powerflexed dogbone.

  4. #3
    Bradderz_1988's Avatar
    Dont replace it, Upgrade it !!

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Westhoughton, Bolton
    Posts
    3,138
    Mine used to do that sort off thing before the maf failed it would sort of rev but with no power and sounded like it was sucking in more air ??

    Recently its been ok it just seems to loose power now and then in the top end of gears when giving it some.
    1999 Audi A4 1.8T Quattro Sport - Volcano Black

    Mods - Frankenturbo F21 Kit - 3" MAF - Saab Reds - THS Decat - Non Res Milltek - ECS Crank Pulley - 034 Snub + Bracket/Gbox Mounts - 1Z/S2 Clutch + Flywheel - 007p - ICM + EVAP Delete - PFR6Q Plugs - S4 B6 345mm Brakes - 300mm Rear Brakes - Goodridge Hoses - LCR Splitter -S4 Bumbers + Skirts/Mouldings - OEM Xenons - Apikol Diff mounts - Polytek'd Rear Diff Mount
    To do/planned -Eibach pro's - GT2871/76R + FMIC + ME7 (maybe) + Engine/stroker Build

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    Bedford
    Posts
    2,877
    Did you ever do any N75 logs?

    I fitted a new N75 the other week and it seems to have solved all those issues and changing gear up top and quickly doesnt end up in hesitation/lag anymore so all`s good

    Cactus green 8L S3 - B5 TIP + Jetex, Revised 007p, R32 rear ARB, AP Coilovers, Compbrake rear arms, Full Powerflexed dogbone.

  6. #5
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,384
    Interesting, i've just been ignoring it (lazy etc).

    Might have to get a new N75 then and see if that sorts it.

    It comes and goes though, sometimes you can smoke it thru 1st to 3rd with no problems, other days its really bad. Last month i was coming out of a motorway services, gave it full throttle in first and it totally bogged down, sat there for what seemed like about a week before finally giving me boost and taking off, then 2nd and third both had massive lag after gearchange.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  7. #6
    6th Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    Bedford
    Posts
    2,877
    Aye know what you mean. Mine was the same, some days completely fine and others were terrible but now i`ve not felt it since changing the N75. Thankfully the newest E version is also cheaper at £40odd

    Cactus green 8L S3 - B5 TIP + Jetex, Revised 007p, R32 rear ARB, AP Coilovers, Compbrake rear arms, Full Powerflexed dogbone.

  8. #7
    boost-addict's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Aug 2011
    Posts
    977
    n75 valve 100% best way to check is,disconnect the pipe comming from your acuator. leave it unplugged and block/plug open end on the n75.go for a drive and you will likley leave it like this basicly my theroy is: when changing gear at low revs/part throttle the n75 holds the wastegate open for a second so you dont get a jerky gear change, but it seams the n75 valve or the ecu gets confused and does it randomly, this has been happening to me and i did as above. i dont get this any more and i actually get boost quicker.

 

 

Similar Threads

  1. S3 turbo lag.... Really?
    By tobycruse in forum A3/S3/Sportback (8P Chassis)
    Replies: 42
    Last Post: 28th July 2008, 22:09
  2. turbo lag
    By bigpaul in forum Diesel forum
    Replies: 6
    Last Post: 24th December 2006, 10:32
  3. turbo lag
    By todamnfast07 in forum A4/S4 forum(B5 Chassis)
    Replies: 7
    Last Post: 10th October 2005, 20:18
  4. Turbo Lag
    By Grant in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 17th January 2004, 17:36
  5. TURBO LAG
    By viper in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 17th October 2003, 08:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO