Badger5EM Tuning
Results 1 to 15 of 15
  1. #1
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158

    Exclamation Where is the turn signal flasher unit? (Not the hazard switch relay)

    Hi all,

    On going probs with my indicators, replaced the hazard light switch/relay and the stalks.

    (Original prob - as I indicate left or right all four indicator bulbs flash as if I hit the hazard light switch also both green arrows illuminate at the same time on the dash)

    So its making me think it must be the 'turn signal flasher' unit as it def exists as it has its own 10amp fuse and if the fuse is removed has no effect on the hazard lights just the indicators. So my question where is the flasher unit hidden.

    Cheers

    Jonny
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,369
    The flasher is part of the hazard switch mate.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Cheers Aragorn, thats what I originally thought, having replaced everything I can think off, Im not sure what the next step is. I did shove VCDS on it earlier but nothing new appeared in the error codes just the existing ones. (Brakepedal implausible signal and a resistance too high on driver seatbelt tensioner)

    Cheers
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  5. #4
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,369
    was it a new hazard switch?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  6. #5
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Quote Originally Posted by aragorn View Post
    was it a new hazard switch?
    Nope but was (supposedly taken from a working car) so thats a fair point, any tips on where I could get one from that wont cost me the £40 Audi want?
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    suffolk
    Posts
    249
    Euros do em mate

  8. #7
    B5 BIKER's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    GALWAY, EIRE
    Posts
    241
    £30.30 in germanautopartsdirect.com
    thats where I got mine, genuine parts too

  9. #8
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Cheers for all the replies guys, so no further on at the minute!! So quick recap where were at then.

    No indicators at the mo, signal left or right I get all 4 indicators flashing altogether like Ive pressed the Hazard light switch. Ive replace the hazard relay for a new one (twice), change the stalks from a working car and still the same prob, now..... during the first few months of having the car (from Jan 2011) when locking the car only the passenger side indicators would flash once to confirm the alarm set etc, recently I had a flat battery and the AA jumpstarted me, since then all 4 indicators now flash when locking the car, Ive noticed it still does this when there is no hazard relay in place, so back to my original question ish, where is the unit that is causing the indicators to flash as Im locking the car when the hazard relay is removed, as, to me its the next logical step in the loop?

    Cheers once again

    A very frustrated Jonny!!
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  10. #9
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    I dont suppose it has an aftermarket CL system/Alarm fitted ?

  11. #10
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,369
    Sounds like it does, as a '96 doesnt flash its indicators when locking by default.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  12. #11
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Quote Originally Posted by Byzan Photography View Post
    I dont suppose it has an aftermarket CL system/Alarm fitted ?
    Unfortunately no, its the standard Audi one, no keyfob either just armed and disarmed from a turn of the key in the door lock, so no idea how embedded the alarm is into the car, and how/why its affecting the indicators!!

    Even has the funny button on the drivers pillar and a horn for the alarm in the boot sidewall??
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  13. #12
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Hmm Is it damp in he well with the CL pump in? That's what controls the locking and indicator flash. I suppose by unplugging it, you could see if the indicator function goes back to normal

  14. #13
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,369
    It has to have something extra added, because the standard CL pump/alarm in a '96 does not have the ability to flash the indicators...

    And certainly if it did, it would use the hazard relay. The fact they flash on locking without even the hazard switch connected suggests to me theres definately something aftermarket attached.

    If you want to rule it out, then unplug the central locking pump and see if the indicators still flash...

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  15. #14
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Okies not sure what this means now, removed the central locking pump and the indicators work fine now, ok cant lock the boot with the key but Ill put up with that for a bit. Ive brought the unit into the house popped the lid open but no signs of condensation inside it but there is a bit of damp in the boot.

    Jonny
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  16. #15
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158

    Thumbs up

    Quote Originally Posted by jonnycraig View Post
    Okies not sure what this means now, removed the central locking pump and the indicators work fine now, ok cant lock the boot with the key but Ill put up with that for a bit. Ive brought the unit into the house popped the lid open but no signs of condensation inside it but there is a bit of damp in the boot.

    Jonny
    All fixed (I hope) as I was putting the CL pump back together again I noticed a bit of corrosion on the board between two bits of soldered posts, a rusty/powdery mess, I cleaned it up and a gap appeared so must have been shorting out, put it all back together, shoved the key in the lock.....Nothing!! Started the car for about a minute, tried again :D Bingo... All doors locking and indicators back to sweet L/R independence!!

    Thanks a lot guys, never would thought to have looked at the CL pump as the cause of this.

    Jonny!

    Oh last question while I'm here - What size is the nut in the centre of the steering wheel? :D
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

 

 

Similar Threads

  1. A6 hazard switch / relay constant ticking noise
    By Damianevs in forum General Technical / How To
    Replies: 0
    Last Post: 16th March 2011, 22:51
  2. Hazard switch/flasher relay repair
    By dellboy in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 16th February 2011, 22:38
  3. Changing indicator relay / hazard switch
    By bantam1 in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 24th December 2008, 13:02
  4. Flasher relay????
    By Stepho in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 20th April 2008, 19:34
  5. Changing hazard relay switch on Audi A3?
    By TDI in forum A3/S3 Forum (8L Chassis)
    Replies: 2
    Last Post: 11th August 2006, 09:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO