JMB RetrofitsChris Nott
Results 1 to 8 of 8
  1. #1
    Soupie69uk's Avatar
    Owner

    Status
    Online
    Join Date
    Mar 2004
    Location
    Edinburgh, Scotland
    Posts
    2,751

    Just fitted my K04.

    Hey i just fitted my K04 today took around 4hours.
    The k04 sounds a bit noisier and seems to pull a little better.

    But when the car is spooling up or under load between 2k and 3.5K revs the car cant seem to hold its boost.
    It pulls then stops pulling about a second at a time.

    I havent got and CEL's on and above 3.5K the car pulls really well.

    Any suggestions to this problem would be very helpfull.
    Thanks,
    Paul.

    PS i will post pics in a little while.

    _______________

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    dummi's Avatar
    smoking a6

    Status
    Offline
    Join Date
    Mar 2004
    Location
    brumingham
    Posts
    1,188

    Re: Just fitted my K04.

    have you got it mapped? maybe the wastegate is opening early (total guess)

    what you doing with fpr? keeping stock or upgrading?

    be good to see some pics dude [img]/ubbthreads/images/graemlins/ok.gif[/img]

    btw did you use new turbo drain lines or clean the ones you had? i'm just about to post a thread with this question

  4. #3
    simon_golf_tt's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2004
    Location
    Fife, Scotland
    Posts
    247

    Re: Just fitted my K04.

    Paul - That was quick getting the turbo fitted! Nice one.

    Sorry you have a problem. What does it boost to when it hangs?

  5. #4
    Soupie69uk's Avatar
    Owner

    Status
    Online
    Join Date
    Mar 2004
    Location
    Edinburgh, Scotland
    Posts
    2,751

    Re: Just fitted my K04.

    Not too sure what the boost level is.

    I really do need to get a gauge. I am just running it on my Star Performance remap.

    The oil lines i am using are just the standard ones. The one to the sump took ages to refit!!

    I think the actuator is needing screwed back as i think it must be over boosting.

  6. #5
    Soupie69uk's Avatar
    Owner

    Status
    Online
    Join Date
    Mar 2004
    Location
    Edinburgh, Scotland
    Posts
    2,751

    Re: Just fitted my K04.

    Here are some pics of the K04 and old K03s.

    Old K03s




    New K04



    The K04 is about 2mm bigger in diameter. (Inner edge) Also has different blades.


    Both together





    Engine bay with the turbo etc out.




    K03s rear




    Rear close




    K04 rear



    rear close



    The turbine on the K04 is again bigger here.

    Cant really see that well from the pics but the bit in the middle of the turbine is quite a bit bigger which is a good indication of the difference.

    Cheers folks,
    Paul.

  7. #6
    RichA3Turbo's Avatar
    ...Watching you!

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Earlsfield, London
    Posts
    5,087

    Re: Just fitted my K04.

    a mate of mine fitted a N75J to his standard 1.8T and got the same symptoms... The turbo is boosting past the ECU's tolerance. You will need to get the map adjusted to use it.

    Rich

  8. #7
    Soupie69uk's Avatar
    Owner

    Status
    Online
    Join Date
    Mar 2004
    Location
    Edinburgh, Scotland
    Posts
    2,751

    Re: Just fitted my K04.

    So you think i need to get my car mapped as i am just running it on a K03s chip just now.

    The turbo starts spooling up at about 1.5K revs. Thats what made me think the actuator needed adjusting.

    Cheers,
    Paul

  9. #8
    Soupie69uk's Avatar
    Owner

    Status
    Online
    Join Date
    Mar 2004
    Location
    Edinburgh, Scotland
    Posts
    2,751

    Re: Just fitted my K04.

    Spoke to Star and they say that the car is needing a remap however AmD say that it sounds like the Air mass meter has gone as this is a common fault and to get it checked. The car ran fine before the turbo upgrade and only seems to have a problem between 2k and 3.5k.

    I am getting loads of different answers from lots of difference sources and am gtting a bit confused.

    I am pretty skint at the mo and will not beable to afford a remap for about 3 months as i have to get a FMIC first as well.

    Cheers,
    Paul.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO