JMB RetrofitsChris Nott
Results 1 to 9 of 9
  1. #1
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158

    Exclamation No indicators, lights, wipers or heating when car is running? But fine on ignition!

    Morning guys, weird problem started last night, started the car and the climate unit goes out, headlights go back to side lights only (like Ive just turned the engine off with the lights on) no wipers or indicators. Turn the key off and back to ignition only and it all works normally.

    Is there a faulty relay or anything common that happens. Its making things very awkward getting to work etc and dont fancy calling the AA just yet.

    Any help would be greatly appreciated

    Jonny
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    audiv6quattro's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    East sussex
    Posts
    392
    Hi mate got this on my car aswell but I find if I start car then turn key back a tiny bit everything works, so start car then turn key back only a couple of mm and everything works. My car failed not coz of this I had 3 pages of failures as they list every light not working and wipers etc. Told the garage after and they passed it straight away, try it and hope it helps

  4. #3
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    As above, faulty ignition switch.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  5. #4
    NineNails's Avatar
    Proud sponsor of the snack food industry

    Status
    Offline
    Join Date
    Sep 2006
    Location
    North Wales
    Posts
    579
    Be careful the starter motor is not also staying engaged, it will burn out. Not saying this is exactly your problem here but there is a return spring in the ignition switch unit that can fail.
    2000 1.8t quattro Sport totally standard (ish)

  6. #5
    mwarrey's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2003
    Location
    Swansea
    Posts
    281
    Quote Originally Posted by NineNails View Post
    Be careful the starter motor is not also staying engaged, it will burn out. Not saying this is exactly your problem here but there is a return spring in the ignition switch unit that can fail.
    +1 to that, happened to me. The ignition switch is pretty straight forward to change, its a simple change over no coding or key cutting required. There is a good write up on audiworld tech articles. Its not too expensive either (by Audi standards anyway!)

  7. #6
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158

    Talking

    Cheers guys, absolutely right!

    Knocked the key back a little and all is grand again. Hope it lasts til I get it sorted.

    Thanks again

    Jonny
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  8. #7
    audiv6quattro's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    East sussex
    Posts
    392
    It should be fine for a while mate mines been like it since I bought the car about a year ago

  9. #8
    jonnycraig's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Port Talbot
    Posts
    158
    Quote Originally Posted by mwarrey View Post
    There is a good write up on audiworld tech articles. Its not too expensive either (by Audi standards anyway!)
    Do you have a link to the article Ive had a look and cant find it :/

    Thanks

    Jonny
    1996 A4 B5
    1.9TDI SE



    Gone but not forgotten
    Audi A4 2.5TDI Quattro
    Skoda Octavia 1.9SDI (Wont be missed lol)

  10. #9
    1st Gear

    Status
    Offline
    Join Date
    Sep 2008
    Posts
    186
    Quote Originally Posted by jonnycraig View Post
    Do you have a link to the article Ive had a look and cant find it :/

    Thanks

    Jonny
    There you go Jonny that is the Link I used when mine went A-Wall..

    I got quoted silly money by a Auto Elec firm(I SAW YOU COMING LIMITED)that firm said that it was a days job dropping the Steering Column and lots of made up things to do and they were cheap about £45 an hour so you do the maths..

    Took me about 45 mins and I think the switch was about £20..

    I would not put off doing it though could lose everything when you need it most You in Car Dark Night no Lights Country Lane ..


    It may work for a while but it's too unpredictable not worth the risk I would not go down the street let alone run it for a while..

    Just a Small Tip make sure your Wheels are dead level Steering Wheel at Quarter Three when you pull the Steering Wheel off the Splines..
    Then obviously put it back the same way..

    AudiWorld Tech Articles
    Last edited by THE MONSTER; 30th September 2011 at 21:25.

 

 

Similar Threads

  1. Water pump running on after ignition off & draining battery - help please
    By The Doctor in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 21st May 2011, 08:00
  2. Interior lights and comfort indicators
    By antnee in forum A3/S3 Forum (8L Chassis)
    Replies: 8
    Last Post: 30th January 2011, 00:32
  3. ABS light on = no lights, indicators or wipers. HELP
    By bertracoon in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 18th August 2010, 19:00
  4. Coding to turn on rear lights with front daytime running lights
    By TreborA4 in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 8
    Last Post: 6th April 2010, 21:54
  5. Auto Lights/Wipers v Manual Lights/Wipers
    By A3_SSS in forum A3/S3/Sportback (8P Chassis)
    Replies: 5
    Last Post: 11th July 2009, 13:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO