EM TuningVolks Autos
Results 1 to 9 of 9
  1. #1
    S4_dan's Avatar
    Fire up the Quattro!

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Somewhere in the Howardian Hills!
    Posts
    1,618

    2.8 V6 Acting very strange....

    Drove to work yesterday and the car drove like always.....without missing a beat.
    Started the car after my shift and it started as usual. No problems.

    Set off and during each gear change the revs dropped really low (no red lighhts on dash though). Stopped at some lights and car idled fine......about 20 secs, then dropped. Rev needle went to bottom, red lights came on, quick blip on throttle and it revved slightly but not as much as it would of done normally. Revs back upto circa 750rpm, and same happened few secs later.

    Lights changed and went to set off but as soon as i touched the throttle, the revs dropped to almost stalling. Did this 4 times. So i had to give it some throttle to 3.5k rpm before car would set off without it wanting to stall. Drove 2 miles and at the roundabout, the same thing happened as at the lights. This carried on for the next 3 roundabouts (over 4miles).

    Got it onto a dually and didn't floor it but gave it a little. Pulled up at my mates house 8mins later and it was idling fine. But it really smelt 'eggy' from the cats.

    Drove it for about 45 miles last night and touch wood it didn't try and stall but it has lost power. Acceleration ain't as sharp or repsonsive.

    just scanned it and still only showing the basic throttle settings fault.

    Any other ideas?

    I did remove the black cover on the throttle the other day to see what the tracks were like and all was clean and grease free.

    Going away next weekend to see a mate (and drool over his 2000MY RS4!!) and don't want to be stuck at the side of the road!!

    Cheers,

    Dan
    2002 2.5 V6 Quattro
    Mods Done: Q5 Rear aero wiper. Front ambient light install. Led number plate lens. Towbar with 13pin electrics.
    Mods to complete: Sport shocks to go with Eibach pro springs. Fit 17" 5 star matt black wheels. Fix lack of torque at low revs. Get a custom exhaust system fitted.

    FOR SALE - Eibach Pro Sport springs for a 2.5 V6 B6/7 PM ME.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    audiv6quattro's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    East sussex
    Posts
    392
    Could it be blocked or broken cats or the lambda sensors playing up maybe

  4. #3
    S4_dan's Avatar
    Fire up the Quattro!

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Somewhere in the Howardian Hills!
    Posts
    1,618
    cats are only 4months old. I do have two new lambda's go on but couldn't get the old ones out the other day. (couldn't get a lambda tool on or a spanner onto the sensor to undo) So going to remove the cats and change the sensors that way.

    But not getting a code for the sensors but I used to get fault codes for them! Now vcds says they're working (or at least not throwing a dtc!)
    2002 2.5 V6 Quattro
    Mods Done: Q5 Rear aero wiper. Front ambient light install. Led number plate lens. Towbar with 13pin electrics.
    Mods to complete: Sport shocks to go with Eibach pro springs. Fit 17" 5 star matt black wheels. Fix lack of torque at low revs. Get a custom exhaust system fitted.

    FOR SALE - Eibach Pro Sport springs for a 2.5 V6 B6/7 PM ME.

  5. #4
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    "only" the throttle settings fault?

    Your having throttle problems...

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  6. #5
    S4_dan's Avatar
    Fire up the Quattro!

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Somewhere in the Howardian Hills!
    Posts
    1,618
    Quote Originally Posted by aragorn View Post
    "only" the throttle settings fault?

    Your having throttle problems...
    I've tried doing the TBA via VCDS, no joy. Tried clearing the code, but it comes back straight away. Car hasn't missed a beat whilst this code being present, apart from yesterday.

    Tracks look ok, like you have previously suggested. The TB was given a quick clean when I was rebuilding the top end as it looked clean enough.

    I assume there is nothing else I can try other than replacing the TB with a known working/new one?

    If thats the case, is there another TB I could upgrade to? Like on a BMW, fitting a 2.3 TB to the 2.8, Made a difference as it was a bigger bore etc.
    2002 2.5 V6 Quattro
    Mods Done: Q5 Rear aero wiper. Front ambient light install. Led number plate lens. Towbar with 13pin electrics.
    Mods to complete: Sport shocks to go with Eibach pro springs. Fit 17" 5 star matt black wheels. Fix lack of torque at low revs. Get a custom exhaust system fitted.

    FOR SALE - Eibach Pro Sport springs for a 2.5 V6 B6/7 PM ME.

  7. #6
    audiv6quattro's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Dec 2010
    Location
    East sussex
    Posts
    392
    Good question sorry can't help but I'd like to know the answer to that,

  8. #7
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Being a 2000 its quite likely it has electronic throttle.

    The fact the TB wont adapt and the fault comes back immediately certainly suggests the throttle body is faulty. It has some redundancy built in, which is probably why its never exhibited any issues before, but its probably the culprit.

    BMW deliberately restricted the 2.8 engine for whatever reason, so it made the same power as the old 2.5 with more torque. As a result the inlet and TB can easily be swapped for the 2.5 version for more power. The 2.8 motor in the B5 isnt really restricted like that, so i cant really see any benefit from fitting a larger TB.

    You could try swapping the PCB with another from a spare TB, but i suspect it may be the servomotor itself thats faulty, as if it were the tracks you'd typically get fault codes specifically stating which track was acting up etc.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  9. #8
    S4_dan's Avatar
    Fire up the Quattro!

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Somewhere in the Howardian Hills!
    Posts
    1,618
    Quote Originally Posted by aragorn View Post
    Being a 2000 its quite likely it has electronic throttle.
    Mine is only a 98 model.
    2002 2.5 V6 Quattro
    Mods Done: Q5 Rear aero wiper. Front ambient light install. Led number plate lens. Towbar with 13pin electrics.
    Mods to complete: Sport shocks to go with Eibach pro springs. Fit 17" 5 star matt black wheels. Fix lack of torque at low revs. Get a custom exhaust system fitted.

    FOR SALE - Eibach Pro Sport springs for a 2.5 V6 B6/7 PM ME.

  10. #9
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,389
    Oh right.

    In that case check the electrical connector on the throttle body for corrosion on the pins.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO