JMB RetrofitsAH Fabrications
Results 1 to 14 of 14
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46

    ENGINE COOLING FAN NOT WORKING

    Just run my a4 up in the garage as it has a oil leak , the temp rised untill way past 1/2 on the guage , i put the a/c on to see if the electric fan would come on an cool the engine but it didnt.
    is there a fuse for the fan as the owners manual doesnt show one ?
    has anyone had this fault ?
    maybe the relay has gone , where is it located ?
    thanks for any help

    mark
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    the engine has a large mechanical fan that should be running all the time?

    Does the electric fan spin freely, or does it feel stiff?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    ScottD3's Avatar
    I want your faulty electronics

    Status
    Offline
    Join Date
    Nov 2010
    Location
    English Riviera
    Posts
    15,003
    The viscus fan should be on all the time, Unless your self or previous owner removed it or if the viscus coupling has broken down and not offering any air movement.

    if you use VCDS you can test the electric fan.

    New Car, New Thread: Scott's Akoya Silver A8
    Gone But Not Forgotten: Audrey's Build Thread

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    the viscous fan is spinning , but when i put the a/c on the electric fan did not cut in to keep the a/c condensor cool , which in turn tripped the a/c out due to high pressure.
    the electric fan is free , but i have not got around to putting a direct feed to it , just was asuming the fuse might be blown...
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  6. #5
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    not sure what system the 2.4 has, some of the V6's have two fans an a electronic module under the passenger side chassis leg, which can go wrong.

    Otherwise its probably just a streight forward relay switched circuit.

    Were you stationary when the AC tripped out? If your driving it really shouldnt need the fan to keep it cool.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  7. #6
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    Yes it was in the garage , just thought maybe the fuse has blown ? , but cant find a fuse for the fan ?
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  8. #7
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    Its a big thing, clipped to the bottom of central electrics panel.

    theres also a smaller 5a fuse beside it which powers the relay coils

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  9. #8
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    so i need to take off the lower trim under the steering wheel ?
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  10. #9
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    yep!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  11. #10
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    I got around to removing the lower drivers trim today , checked all the fuses , even the ones part hidden under the dash & swapped the fan relays around with different ones but still no cooling fan....
    under the n/s front chassis let is a resistor type thingy thats alluminium and has 2 terminals bolted to it , one with a single wire and one with 2 wires , whats this is it for the electric fan or headlamps ?
    thanks
    mark
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    reading a bit more into this , i see some cars have a cooling fan control module under the battery mounting , will mine have this unit there ?
    as i washed my car this afternoon and popped the bonnet to do the levels the bulkhead and battery area was about 3 inch deep in water ! so obviously the drain is blocked and now im concerned the module has been under water for some time, making the fans not work ??
    does anyone know if the unit is under the battery ?

    mark
    A4 2.4 SE
    SUBARU LEGACY 4CAM

  13. #12
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    Its under the nearside chassis rail on craigs S4 from memory.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  14. #13
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,370
    Have you checked the fan relay has power, and tried bridging it?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  15. #14
    Neutral

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    46
    no , spent ages looking for my test light yesterday and gave up !
    theres 2 relays , one i presume is a fan run on relay ?
    so under the n/s chassis leg is my fan control unit then i guess , gonna pop it off when it stops raining and have a look at...
    thanks for the help

    mark
    A4 2.4 SE
    SUBARU LEGACY 4CAM

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO