Badger5JMB Retrofits
Results 1 to 7 of 7
  1. #1
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528

    ABS Wheel Speed Sensor "Tone Ring" problem

    So my ABS has been kicking in on and off at low speeds. I think, but am not sure, that I've got some wheel speed sensor issues, but vagcom shows nothing.

    I found this picture online. It's not audi, but different is the setup on an S4?

    1999 S4, MIJ Performance exhaust with 100 cell cats

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,324
    If its triggering randomly at low speeds its probably a corroded or perhaps even cracked ring, and ye, its pretty similar to your image.

    If you have vagcom, you can connect to the ABS controller, and open up measuring blocks, which will show you the signals from each wheel, If you drive along VERY slowly you might be able to see which one is dropping out, as it will likely stay at 0 longer than the others or might jump between a speed and zero.

    If you go much faster than about 10mph vagcom will disconnect from the ABS controller, so you really need to keep it to just crawling along.

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  4. #3
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    cheers. i've noticed vagcom dropping out. didnt know it was speed related. will try it this weekend.

    Any idea what cost I'd be looking at to get a pair of wheel sensor rings? plus fitting? would I need new sensors too?
    1999 S4, MIJ Performance exhaust with 100 cell cats

  5. #4
    Geeman's Avatar
    Low Life

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Grimsby
    Posts
    1,318
    Mine was coming on a low speed as I was braking, about 8mph.

    I replaced the sensor (not the ring) and now it's perfect!

    Hardest part was getting it in the air high enough on axle stands to get underneath it to place the grommet back in under the seat access point!
    NEW 6 cylinder 40mm front springs - £40

    PM me for more info

  6. #5
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    15,324
    Well i guess common sense is needed.

    The rings are part of the CV joints. You basically have to change the CV. The rear CV's on quattro models seem to be prone to the ring cracking, meaning its loose on the shaft and moves around, causing the problem.

    When i got our car the rear had no signal and i stupidly dived in and changed the sensor first rather than properly investigating, turned out to be a shattered ring (it was in two halves lol) and i ended up getting a spare driveshaft from ebay and swapping it over.

    I'd use vagcom to identify the corner, then once identified, you can look at the ring. If the ring looks fine and isnt corroded or owt, then replace the sensor. Otherwise, replace the ring!

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  7. #6
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Swansea, South Wales
    Posts
    528
    Well, I am off on holiday on two weeks. Think I will leave the car with a local garage and ask them to have a look. Hopefully they will know their onions!
    1999 S4, MIJ Performance exhaust with 100 cell cats

  8. #7
    tazzy baby's Avatar
    Rookie

    Status
    Offline
    Join Date
    Feb 2009
    Location
    south wales
    Posts
    545
    Sorry to jump in on this but mine comes on when i go over 60 anything below it stays off but i do get a bit of a fight off the pedal when i try to stop any ideas
    If you give a mouse a cookie......

    He's gonna want a glass of milk....

    vorsprung durch technik

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO