EM TuningMonster Motorsport
Results 1 to 13 of 13
  1. #1
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719

    Help! DIS Coding

    Hi, it's been a while since I posted on Audi-Sport, and first time in the A4 forum (I had an A3 quattro untill recently, but somebody crashed into it, and wrote it off...)

    So, I'm now the proud owner of an A4 B6 1.8T Sport quattro (2001 - 51 plate) and have been eagerly reading about all the mods I can do.

    The first one I've tried is the retrofit DIS (no cruise, just DIS). I've read all of the guides, and felt confident fitting the stalk etc, which I did today. I've just come to the coding part, and I've done the steering angle sensor reset, and recoded the steering wheel (16 on VAGCOM) using the coding help on the VAG COM in conjunction with my existing code. I've also attempted to code Section 17, the instruments, again adapting according to my existing code and the help on VAG COM and on here. I get a small '2' on the central display which seems to indicate DIS is activated. but the stalk doesn't do anything and the display stays on fuel range.

    Now, I've rechecked the instructions, but I could be reading them wrong! I feel so close to getting it sorted, but I'm suspecting my Steering Control Module might be incompatible. Mine is a 8E0 953 549 F, I'm not sure that's compatible? Do I need an 'N' module? I checked with the Audi parts guy when I was ordering the stalk as to what was already fitted, but now understand that his list of parts vs my reg number are current part numbers, not necessarily what's fitted!

    Any ideas anybody? If you need me to scan anything else, or need more info, then please ask.

    EDIT: I should add the only fault code I can see is one relating to the wiper stalk being faulty, I clear it but it comes back. It;s a new stalk from the dealer.
    Last edited by Tooks; 1st July 2010 at 21:29.
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Blackpool and Watford
    Posts
    133
    Lowline
    • Supported Steering Wheels: Standard Steering Wheel (4-Spoke)
    • Supported Features: Trip Computer (does NOT support Cruise Control!)
    • Part Numbers: 8E0-953-549-F 8E0-953-549-S

  4. #3
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Hi, thanks for the reply.

    I'm not familiar with the A4 at all, but is your info telling me my 'F' designation SCSM should support DIS?

    My car has a sport steering wheel if that's relevant?

    Apologies for my brain being overloaded!
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  5. #4
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Ok, now I'm even more puzzled....

    I've done a full scan via VAG-COM, results below;

    ----------------------------------------------------------

    Chassis Type: 8E - Audi A4 B6
    Scan: 01,02,03,08,09,15,16,17,26,36,37,45,46,55,56,63,76

    -------------------------------------------------------------------------------
    Address 01: Engine
    Controller: 8E0 909 518
    Component: 1.8L R4/5VT G 0001
    Coding: 0011701
    Shop #: WSC 63351
    1 Fault Found:
    18107 - Powertrain Data Bus: Missing Message from Steering Wheel Electronics
    P1699 - 008 - Implausible Signal
    Readiness: 0000 0000

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes
    Controller: 8E0 614 517 A
    Component: ABS/ESP allrad 1726
    Coding: 04275
    Shop #: WSC 06435
    No fault code found.

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC
    Controller: 8E0 820 043
    Component: A4 Klimaautomat 0712
    Coding: 00000
    Shop #: WSC 63351
    No fault code found.

    -------------------------------------------------------------------------------
    Address 09: Cent. Elect.
    Controller: 8E0 907 279 C
    Component: int. Lastmodul RDW 0203
    Coding: 00101
    Shop #: WSC 63351
    1 Fault Found:
    01326 - Control Module for Multi-Function Steering Wheel (J453)
    49-10 - No Communications - Intermittent

    -------------------------------------------------------------------------------
    Skipping Address 15-Airbags

    -------------------------------------------------------------------------------
    Address 16: Steering wheel
    Controller: 8E0 953 549 F
    Component: Lenksulenmodul 0308
    Coding: 01011
    Shop #: WSC 00554
    2 Faults Found:
    00888 - Wiper Switch for Intermittent Operation (E22)
    37-00 - Faulty
    01044 - Control Module Incorrectly Coded
    35-10 - - - Intermittent

    -------------------------------------------------------------------------------
    Address 17: Instruments
    Controller: 8E0 920 950 G
    Component: KOMBI+WEGFAHRS. RB4 D22
    Coding: 01400
    Shop #: WSC 00554
    WAUZZZ8E42A135204 AUZ6Z0A0189317
    No fault code found.

    -------------------------------------------------------------------------------
    Address 45: Inter. Monitor
    Controller: 8E0 951 177
    Component: Innenraumueberw. 0504
    Coding: 00001
    Shop #: WSC 00000
    1 Fault Found:
    01463 - Alarm triggered by Sensor for anti-theft alarm System
    81-00 - Open

    -------------------------------------------------------------------------------
    Address 46: Central Conv.
    Controller: 8E0 959 433 AJ
    Component: Komfortgert T9F 0617
    Coding: 06859
    Shop #: WSC 63351
    No fault code found.

    -------------------------------------------------------------------------------
    Address 56: Radio
    Controller: 8E0 035 152
    Component: chorus II GRO 0006
    Coding: 00000
    Shop #: WSC 63351
    No fault code found.

    End --------------------------------------------------------------------------------------------------


    The fault codes at Engine 01 and Cent Elec 09, are they related as they seem to say?

    Is it plausible that my car at some point had a multi-function steering wheel, and this was swapped out for a standard sports wheel at some point?



    This is all getting rather worrying...
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  6. #5
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    Check your steering wheel coding, but most important that you didn't bend any of the connector pins on the steering wheel and corresponding modules..like i did...
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Blackpool and Watford
    Posts
    133
    • you are saying 01011

    which is sport wheel, no tiptronic, board computer, no rear wiper

    looks good to me, would deffo check wiring plug is in correctly and pins arent bent as said before as the ECU knows its there, intermittently might be because you have pulled the power out once.

    • 0?xxx: Steering Wheel
      • 0 = Standard (without Multifunction)
      • 1 = 3-Spoke Steering Wheel (Sport Steering Wheel)
      • 2 = Multifunction Steering Wheel with Radio Control
      • 3 = Multifunction Steering Wheel with Radio/Telephone Control
      • 4 = Multifunction Steering Wheel with Radio/Telephone/Voice Control
      • 5 = Multifunction Steering Wheel with Radio/Voice Control
    • 0x?xx: Options
      • +1 = Tiptronic
    • 0xx?x: Board Computer & Cruise Control
      • 0 = Board Computer & Cruise Control not installed
      • 1 = Board Computer installed
      • 2 = Cruise Control installed
      • 4 = Board Computer & Cruise Control installed
    • 0xxx?: Rear Wiper (Chassis)
      • 1 = Rear Wiper not installed (Sedan/Cabriolet)
      • 2 = Rear Wiper installed (Avant)
    Last edited by blackpool1974; 3rd July 2010 at 11:22.

  8. #7
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Thanks again for the assistance everybody.

    I've been through the coding procedure twice more, just to make sure, and I get to the point where I get a '2' vsible on the DIS, but I can't switch it to 1 and the rocker doesn't switch between modes.

    As suggested, I'm going to dismantle everything again, and check the wiring connectors and pins etc.

    I'm assuming then, if that all checks out, that it could be a faulty stalk, even though it's new, and/or the SCSM?
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  9. #8
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Ok, took the wheel off again this morning, disconnected everything, checked for bent pins etc, reassembled everything, went through the whole coding procedure again - still not working!

    Not sure what to do next. Maybe get them to exchange the stalk, or maybe try an 'N' SCSM?

    Might have to give up on this one to be honest....
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  10. #9
    swarcup's Avatar
    5th Gear
    Breakout Champion

    Status
    Online
    Join Date
    Sep 2009
    Location
    beverley,East yorkshire
    Posts
    1,268
    have a read through this, it has all the info you should need http://www.tyresmoke.net/forum/audi-...ise-a4-b6.html
    2.5tdi Avant Q S 180 - 19" RS6 reps - chrome mirrors - ambient light package - cruise and dis retrofit - chrome side repeaters - front sline lowr conversion with cupra r splitter - rear lower valance with twin cut outs and exhaust tips - rs4 rear antiroll bar - puddle and footwell lights - sline door blades - fully colour coded - b8 autodimming mirror on custom window adapter - geuine aero wiper upgrade - genuine heated mirror upgrade

  11. #10
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Quote Originally Posted by swarcup View Post
    have a read through this, it has all the info you should need http://www.tyresmoke.net/forum/audi-...ise-a4-b6.html
    Thanks for the link, but that's a thread I've read many times both before and after I fitted the stalk!

    I retro fitted cruise to my old A3, and that went without a hitch including the coding. I'm really starting to think this is a hardware thing, maybe the SCSM or the stalk.

    Are there any other modules I need to check the coding on first, other than ABS, Steering Wheel and Instruments as detailed on the instructions in the various threads?
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Blackpool and Watford
    Posts
    133
    On the steering wheel measuring blocks are there any blocks that monitor you pressing the dis clicker

    on, off etc

  13. #12
    technics100's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Co Antrim
    Posts
    773
    Hi,

    I have installed just DIS like you, my SWCM is a S code and DIS works fine. Here is my post, the coding seems to be the same as yours..

    http://www.audi-sport.net/vb/showthr...o-fit-Question

    Hope it helps


    2003 Silver A2 1.4 TDi - 65mpg & 30 a year to tax - ;-)
    2003 Atlas Grey A4 2.0 S-line - gone
    2000 Goodwood Green S6 4.2 V8 - gone

  14. #13
    4th Gear

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Lincolnshire
    Posts
    719
    Just thought I'd update this thread as I now have DIS working.

    Basically, I found an 'S' coded SCSM cheap on eBay, so thought I'd give that a go as it was the only thing I hadn't tried.

    I fitted it, recoded everything, and now I have a fully working DIS!!

    Although my original SCSM was an 'F' code which should have supported DIS, for whatever reason it didn't, maybe because mine is an early car? (2001MY) Either that, or it was faulty.

    I've also managed to remove the other fault codes around missing steering wheel comms by deactivating cruise (it isn't fitted to my vehicle).

    So, I suppose the lesson from this is that not all SCSM's support DIS even though they should and/or they can go wrong!

    Thanks for all the ideas and advice along the way folks!
    Last edited by Tooks; 24th August 2010 at 13:11.
    Audi S3 - 2002MY - Denim Blue - Gone
    VW Polo GTI - 2011MY - Candy White - Here

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO