Volks AutosSky Insurance
Results 1 to 13 of 13
  1. #1
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149

    g85 steering angle sensor prob

    So i installed my dis stalk tonight. all appears to be working fine except the g85 problem and the steering wheel is tight/rubbing. I tried to do the alighnment thing but can get no measurment readings from the sensor. I re-used my steering module so i know its good. I am at a loss as to what it could be, any ideas ? (I am getting a g85 error in vag com) Is it possible to put it in wrong ? break a wire ? over tighten something ?
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,716
    Well 1st what are the logged faults so we can see them for sure, the exact log aswell please, without every module, just the faulting ones.

    Also, check your pins havnt been bent when refitting any parts as this happens aswell, as me & another forum member found on another members A4 recently, who got someone else to do the 1st stage of the job which is identical to what you're trying to acheive.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  4. #3
    6th Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Lancaster
    Posts
    1,621
    The rubbing is because you've not pushed the stalks back far enough.
    Look up through where the steering column adjuster is. You can see the allen key that holds the stalks on. Undo, push back, tighten up.

    The faults, I had this problem. I did the alignment as told. I logged in with the car details. 09### you can get the type you need from the sticker in the tyre well. Log in, Code with the right option. Then log in with the 40168 (from memory, so check) and do the rest as you've been reading to do.
    Atlas Grey A4 2.5 TDI Quattro Sport.
    Mods so far: Cruise control, DIS, Heated Mirrors, Tuning box, Xenonx, Centre Arm Rest, MFSW, RNS-E, SDS and Aero Wipers.
    To do: None yet.
    Next: Auto dip rearview mirror and Folding Mirrors.

  5. #4
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    I was debating with myself if i had push it far enough back. IIRC the error as 0038, faulty g85 sensor. As for login and coding the last owner had kindly removed the sticker so i had to work it out myself, 1.9tdi with 15" brakes ? when i go to do the alignment having logged in I go to 01 and get error. but when i do measuring blocks the wheels register movment but i get nothing from the steering wheel at all, so i have either broken a pin, not pushed back enough or damaged a connetion on the sscm. Going to try again later, ihave another sscm as back up :D Another think i noticed is when i try to flash full beams the stalk has to be pulled back much further than the last one. Could this be related ?
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  6. #5
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149

    Post

    okay, getting there now, i hadn't put whole thing back together correctly . Now i have ( i had misaligned a plug, pushing the column out too far and rubbing against the wheel. Now my main problem is coding the abs module . The sticker is missing from my boot is anyone sure of the correct login and coding for a 1.9tdi 04 ? btw, fixed the highbeams, corroded contact on the stalk end
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  7. #6
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    here are the error codes i'm getting..


    Saturday,08,May,2010,19:02:55:51586
    VCDS Version: Release 908.2
    d6
    Address 03: ABS Brakes Labels: 8E0-614-517.lbl
    Control Module Part Number: 8E0 614 517
    Component and/or Version: ABS/ESP front 3429
    Software Coding: 00000
    Work Shop Code: WSC 00000
    2 Faults Found:

    00778 - Steering Angle Sensor (G85)
    66-10 - Not Matched - Intermittent
    01044 - Control Module Incorrectly Coded
    35-00 - -
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Lancaster
    Posts
    1,621
    They're the normal faults that just require the coding as suggested.
    Atlas Grey A4 2.5 TDI Quattro Sport.
    Mods so far: Cruise control, DIS, Heated Mirrors, Tuning box, Xenonx, Centre Arm Rest, MFSW, RNS-E, SDS and Aero Wipers.
    To do: None yet.
    Next: Auto dip rearview mirror and Folding Mirrors.

  9. #8
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    getting better;
    after finding the proper codes for my car, logged in, coded, then and this is the bit i was missing, re login using 40168.... 001, go. so now back to 2 orange lights as opposed to a 3rd red ( handbrake ) I will just drive a bit now and let the sensor calibrate itself....
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  10. #9
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    All done.. Everything working now. I don't know how i missed it. I think i'll write a how too.
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  11. #10
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,685

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Glad you got it sorted.

    Quote Originally Posted by defsix View Post
    I think i'll write a how too.
    Always appreciated!
    Ingolstance Read about my A6 HERE.

  12. #11
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,716
    Quote Originally Posted by defsix View Post
    I think i'll write a how too.
    Ross-Tech beat you to it, minus the incorrect fitment :

    http://wiki.ross-tech.com/wiki/index...ch_5.7)#Coding

    http://wiki.ross-tech.com/wiki/index...ch_8.0)#Coding

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  13. #12
    defsix's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    149
    ok, everything has been working fine since this modification, however i am having a problem getting the steering wheel centred with the wheels. When performing calibration i first lock left then right, then drive 20m then centre the wheel, but when i do this the car isn't 100% straight. perform calibration , everything seems ok. But my car still is steering to one side. Should the steering wheel be straight or the wheels when doing this ? I thought it was the steering wheel so i took it off and adjusted it but it's off to the other side. Am i missing something here ?
    AUDI A4 Avant 1.9TDi Sport
    | RS4 RARB - RS6 18" - SLCR Spolier - HID's / Laminex / DRL's - Ext LED lighting - Ambient Lighting F+R - Dension300 / iPod Touch - Siemens Bluetooth - DIS - Cruise|

  14. #13
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,716
    Yeah, get it aligned.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO