Volks AutosMonster Motorsport
Results 1 to 13 of 13
  1. #1
    audimatt's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Posts
    38

    Problems, problems, problems!

    I need help!

    My car is developing new problems on a daily basis! :/

    Basically the heaters in my car wouldn't work- its a 1.8T by the way...

    First of all, the coolant temperature sensor broke- replaced that
    Then, on the same day, found out the thermostat was broken (OH, and ALL the housing) - replaced that. Still no heating.
    Anyway, after finding out the water pump impellar was broken.. I've had to have a new pump (obviously), new cambelt tensioners etc. I thought I may aswell have an oil change carried out too..

    Had the car back about 2 days, drove about 50 miles.. and now the Oil light has come on, this has literally just happened so haven't had time to check the oil- but it doesn't sound tappy etc.. running so smooth.

    Anyway, my mechanic is my Dad and he said that the Oil light came on when he was driving it home- he checked the oil and it was perfect. So back to the garage it went , had another oil change to be certain it was all alright.

    And now the Oil light is back on.... Is there a sensor that might have been broken?

    Any help would be appreciated

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    A4 Cabriolet 1.8T Owner

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Wisbech
    Posts
    86
    Maybe the sensor in the bottom of sump is disconnected or broken or the oil pressure switch near the oil filter? Give them a check first!
    Daniel.

  4. #3
    A4 nut's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    wolverhampton
    Posts
    352
    Hi ive had that problem twice after services on two cars first on a 225 TT and on my 1.8t A4 cab unfortunately it was my oil pick up pipe being blocked midland vw tell me that it is a common fault on the 1.8t engine. keep a eye on it and any top end noises stop using it straight away. But hope it is your oil pressure switch.

  5. #4
    LIVERPOOL

    Status
    Offline
    Join Date
    Jul 2009
    Location
    LIVERPOOL
    Posts
    39
    It does sound like it could be the oil pipe blocked like A4 nut said it is common on the 1.8T's. Is it the big red oil light and is your yellow EML on? If it is both I wouldn't drive it at all, could be costly and it looks like you've spent enough.

    Good luck

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Sep 2009
    Location
    london
    Posts
    87
    check the oil pump strainer.....(lookslike the mesh u get on a tea bag strainer) if thats blocked up get it cleaned up asap or you'll end up like me n replace a whole engine an turbo!
    -Shaz-

  7. #6
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    ill second the above, only just got mine back, completely blocked, starved the engine and wiped the turbo out
    LOTS DONE, LOTS SPENT !!!!

  8. #7
    J7USS's Avatar
    Shuddup Foooool!!

    Status
    Offline
    Join Date
    Oct 2006
    Location
    LEICESTER
    Posts
    3,671
    Ill 3rd that...im still feeling the bite over my knackered engine over 2 yrs ago on my other 1.8T.

  9. #8
    audimatt's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Posts
    38
    Cheers for your replies! Its been a couple days now and the Oil light hasnt come back on, and it seems to be running fine, and driving well.
    So i'm assuming its a faulty switch?

    Are these expensive?!
    Cheers

  10. #9
    staggspeed's Avatar
    staggspeed

    Status
    Offline
    Join Date
    Sep 2009
    Location
    somerset
    Posts
    56
    MY OIL LIGHT USED TO DO THAT,SOMETIMES IT WOULD STAY OUT FOR A COUPLE OF WEEKS,IT WAS THE CRAP IN THE SUMP BEING PICKED UP AND THE DROPPED AGAIN WHEN THE ENGINE STOPPED HAD A NEW OIL PUMP AND PICK UP 2 WEEKS AGO,ALONG WITH A NEW CAMBELT,TENSIONER,WATER PUMP,2 BOTTOM ARMS,2 CV JOINTS,AND A NEW RADIATOR,I SHOULD HATE THE BLOODY CAR,BUT CANT HELP LOVING IT,1.8T AVANT SPORT BY THE WAY,SANTORIN BLUE, WITH FULL LEATHER.

  11. #10
    audimatt's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Posts
    38
    Yeah, i hated it for a couple days.. but love it again now! So if it was the Oil pump.. does that mean I'll have to have the cambelt off again?!
    Sorry if thats a stupid question, i only know the basics..

  12. #11
    staggspeed's Avatar
    staggspeed

    Status
    Offline
    Join Date
    Sep 2009
    Location
    somerset
    Posts
    56
    NO,YOU DONT HAVE TO TOUCH THE CAMBELT BUT ITS NOT THE NICEST OF JOBS,TOOK ME ABOUT 6 HOURS,BUT I EXPECT SOME OF THE GUYS ON HERE COULD DO IT FASTER.

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Nov 2007
    Location
    southport
    Posts
    31
    [QUOTE=audimatt;870270]I need help!

    Anyway, my mechanic is my Dad [/QUOTE]

    My dad needs to change his line of work! Oil driller is no use to me dont even get a discount card for fule

  14. #13
    audimatt's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jun 2007
    Posts
    38
    Haha yeah, it's lucky he is! Just finished college so have no money at all!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO