JMB RetrofitsEM Tuning
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    4

    Hot and Cold Heater A4 tdi.

    a4 hot and cold heater !
    Hi, Can anyone shine a light on my heater/climate fault ? The car is an a4 2002 b5 tdi. The temp gauge only rises to around 70 , econ light on dash will not switch off , fan is on from start up, and the real poser , both settings on hi on the climate. Passenger side all vents hot air, drivers side all vents cold air . had a diagnostic which shows r/hand flap acctuator fault. Took out glove box and found motors ok . took out drivers lower shelf but no sign of any motors.

    Do all the motors on n/s operate all vents ?
    Can thermostat be faulty ?

    Really need some help people, getting cool out there ! Thanks in advance.
    Chris a4.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    hi im new to audi but iv had my heater probs i think the motors are just one side
    and iv found they do stick shut or open as my top one did i think if you can just take a few of the motor arms of like i did and clean them up and wigal the flaps by hand this may help to free them up if thats the prob hope this helps

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    4
    cheers simon, will try that in the morning, just as a matter of interest , after you fixed your fault did the temp gauge alter to 90 or could that still be a faulty stat ?

    regards , chris.

  5. #4
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    i didnt have a problem with that side of it just the shuters sticking
    but im thinking its your stat thats doing that side of it

  6. #5
    190 S LINE QUATTRO

    Status
    Offline
    Join Date
    Nov 2009
    Location
    somerset
    Posts
    81
    The temp setting for passenger side is the left lower servo with the red arm, remove glovebox to access. the one that does the drivers side is on the drivers side, remove drivers lower trim to access. Remove the motor and put 12 volts to pins 5 and 6, reverse polarity to go other way. Servos sometimes stick. Not related to coolant temp, probably your stat.

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    15
    hi, sounds like a senor fault to me. im not sure on your car, but today i had to change the rear water flange on the block as it was split. once i had changed it and tried to bleed the engine up, i notice the fan was on without the engine being hot...after scratching my head, i rang a friend at AUDI, he told me the temp senor in the flange goes faulty and results in fan running.

    I changed this then, proceed to bleed the coolant, remember to open the bleed nipple and the matrix pipe pin hole. (or you'll get air locks) *TIP* if you give the engine gas and the heaters get hot, you got an airlock.

    p.s i got a 2001 2.0SE A4

    hope this helps.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2009
    Posts
    4
    Thanks for the reply, so you can access the units with just the lower trim removed, no dash removal ? would it be safe to assume that it is the red arm that operates the flap like on the passenger side ?

    cheers chris.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO