JMB RetrofitsAH Fabrications
Results 1 to 6 of 6
  1. #1
    AndymacA4's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    154

    Dodgy front door electrics, help needed.

    Hi all, I have noticed a weird electrical glitch with my front passenger side door.

    The speakers work, the door locks and unlocks as it should, but the door doesn't show as open on the info. system, and the interior light doesn't come on when the door is open either.

    Also the door edge red warning marker light has stopped coming on.

    Anyone had experience of this problem, or any ideas of where the dodgy connector is likely to be?

    My Alfa Romeos all had the door switch in the car body. The Audi has no switch in the door jam so I guess it is in the door somewhere.

    I'll need to fix it as I assume the alarm won;t register if the door is opened unless the interior sensors pick up movement now. All other doors front and rear working fine.

    Any help appreciated.
    Ta

    Andy
    Fiat Stilo 2.4 Abarth 170bhp and climbing!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1wheelonly's Avatar
    cabriolet

    Status
    Offline
    Join Date
    Oct 2007
    Location
    The Lounge
    Posts
    2,062
    andy,
    if it helps i had a aerial fault on my car once and found it to be a breakdown in the wire inside the rubber sleeve between the car body and the boot, this could possibly be the same for you between the car and the door, try fiddling/wiggling around with it a bit to see if you can make a contact with a dodgy wire, if it does then the dis would display the door open once a good contact was made, even if you only got a quick flash then youd know that the fault was there.
    worth a try untill someone more knowledgable comes along mate!
    LOTS DONE, LOTS SPENT !!!!

  4. #3
    a4 2.4 se's Avatar
    V6

    Status
    Offline
    Join Date
    Aug 2006
    Location
    Leicester
    Posts
    110
    You have an faulty switch . the switch is built into the lock , poss try spraying wd40 in the lock . i have the same fault on my rear door its work ok now

    paz

  5. #4
    AndymacA4's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    154
    Sweet, many thanks, will go spray it lots, can you see anything of the switch without taking the door to bits? Is there a bit you can manually poke with a screwdriver to get it moving again?

    Ta

    Andy
    Fiat Stilo 2.4 Abarth 170bhp and climbing!

  6. #5
    a4 2.4 se's Avatar
    V6

    Status
    Offline
    Join Date
    Aug 2006
    Location
    Leicester
    Posts
    110
    No you need to have door to bits

  7. #6
    AndymacA4's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    154
    Lovely, I truely hate taking doors to bits, I always forget to put something back!
    Fiat Stilo 2.4 Abarth 170bhp and climbing!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO