Chris NottVolks Autos
Results 1 to 12 of 12
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3

    Tail lights turn on unexpectedly....draining battery

    I have a 2004 A4 Cabriolet that has tail light issues. I can park the car, turn the lights off, and walk away, but the tails lights may turn on in my absense draining the battery. The center brake light does not turn on, so I have ruled out the brakelight switch. Does anyone have any ideas as to what may be causing this problem?
    Last edited by ward0166; 3rd December 2008 at 02:16. Reason: spelling

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    evilscotsman's Avatar
    Space Cowboy

    Status
    Offline
    Join Date
    May 2008
    Location
    Fife, Scotland
    Posts
    1,345
    its a weird one, just a guess but could be the convenience module under the passenger seat or the lighting switch itself?

    question, is it both tail lights or just one? No sidelights at the front when this happens?

    The reason I asked about this, is when you park an audi, if you leave the indicator stalk clicked one way or the other, the parking (tail & side) lights will illuminate when you switch off, leaving a tail and sidelight on continually, unless you click the indicator stalk off...........
    Last edited by evilscotsman; 3rd December 2008 at 10:16.
    B4 TDI - old skool project / daily driver...if it ain't broke, it's probably an Audi...


  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3
    Both tail lights come on. Also, my wife said that the front fog lights were on when it happened to her. I didn't notice fog lights being on when it happened to me. Of course, the repair shop cannot recreate the problem........

  5. #4
    docurley's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2003
    Location
    UK, London, SE
    Posts
    3,824
    Could be the brake light switch on the pedal playing up.
    Black Audi RS4 2006 Exclusive edition, Black optic option (stock for now)

  6. #5
    4th Gear

    Status
    Offline
    Join Date
    Aug 2004
    Location
    Aberdeenshire
    Posts
    740
    Quote Originally Posted by docurley View Post
    Could be the brake light switch on the pedal playing up.
    I second that. You'd be surprised the odd behaviour that little switch can cause!

    As has also been stated, check the light switch and convenience module. I assume your garage have scanned for error codes???

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3
    i actually just started having this same problem, originally thought it might have had something to do with my trunk latch not working properly but i took it to audi and had that fixed and they didn't find any issues with my tail lights...last night the lights cut on yet again and this morning i have a dead battery.

    for me, none of the front lights turn on at all when this problem occurs, it is just the outward brake lights. I'm not too car savvy so could someone explain where and how to check the convenience module and light switch?

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3
    i just returned from the audi dealer and had my brake light switch replaced...hoping for good results...ill let you know how it turns out

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3
    I had the brakelight switch replaced..... the lights came on again last night. I think we can definitely rule out the brakelight switch, now. Any other ideas???
    Last edited by ward0166; 5th December 2008 at 10:24. Reason: spelling

  10. #9
    docurley's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2003
    Location
    UK, London, SE
    Posts
    3,824
    Rear carpets are not wet by any chance?
    Black Audi RS4 2006 Exclusive edition, Black optic option (stock for now)

  11. #10
    evilscotsman's Avatar
    Space Cowboy

    Status
    Offline
    Join Date
    May 2008
    Location
    Fife, Scotland
    Posts
    1,345
    the main lighting switch that you put the main and fogs on with, I reckon its collapsed inside. My mk1 golf used to start by itself as the ignition switch collapsed inside and the car would crank and start with the keys in my pocket lol
    B4 TDI - old skool project / daily driver...if it ain't broke, it's probably an Audi...


  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2008
    Posts
    3
    well its been almost a week and im no longer having problems...all they switched for me was the brake light switch.

    maybe its your convenience module? not sure what else it could be as my problem seems to be fixed now (knock on wood)

  13. #12
    "Stick a V8 in it!"

    Status
    Online
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,943
    Convenience module doesn't touch the brake light circuits, so if its the brake lamps that are coming on its not that.

    The main lighting switch doesn't discriminate front/rear outputs, so again, if the fronts aren't coming on, its not that.

    You need to find out whether its the brake or side circuits that go live, take a multimeter to it next time they come on and see which it is?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO