Monster MotorsportAH Fabrications
Page 1 of 2 12 LastLast
Results 1 to 40 of 64
Like Tree2Likes

Thread: HELP! windscreen demister

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Mar 2004
    Location
    scarborough
    Posts
    50

    Question HELP! windscreen demister

    Hi Guys,
    Hope someone can point me in the right direction,please! I have a 2003 2.5tdi quattro sport,when I press the button for the windscreen demister,no air comes out of the vent on top of the dash,only through each end of the fascia vents,but not the middle two.. As you can imagine,this is doing my head in,especially at this time of year,it is a nightmare trying to keep the screen clear.Even at running temp and on auto,the screen will not clear. Please has anyone any ideas? I realise it's not like the old days when cables used to snap or sieze up.. Thanks for taking the time to read this,and thanks in advance for any suggestions..
    Regards, Blackwood

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Nickynibbles's Avatar
    Damn it where's 7th gear when you need it?!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Hampshire
    Posts
    846
    Does the fan speed increase & the button light up when you press it? If not then you could have a switch problem. If it does then try pressing the up arrow with the climate in auto mode and turn the fan speed up. Do you hear the vents changing position & feel the air coming out of the screen vents? If not then you've probably got a stuck or broken vent actuator. The actuators are easily visible on the side of the centre console when you take the glove box out. Vagcom can of course check what the problem is precisely.
    A4 3.0 Quattro Sport - Gone & missed everyday!

    Current road going missile.....

    ........Smart Roadster - arguably the most fun you can have in a car without using lube!!

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Mar 2004
    Location
    scarborough
    Posts
    50

    Thumbs up Thanks!

    Thanks for your reply,very appreciated. I've tried all your suggestions already,so guess it's a vent actuater that's the problem..At least it sounds like a straight forward fix (fingers crossed!) as I had visions of the complete dash out,not a good day.. My local garage has a code reader,though not vagcom,so will try that tomorrow and see if it shows anything up. Once again,thanks for your help..Don't suppose you've any idea how hard these actuators are to replace?
    Regards, blackwood

  5. #4
    Nickynibbles's Avatar
    Damn it where's 7th gear when you need it?!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Hampshire
    Posts
    846
    I replaced one recently and they're a doddle to change! In my case it turned out to be unnecessary as the existing actuator was working perfectly well, I mis-diagnosed a fault code on vagcom and the stealer wouldnt take it back! Only trouble is they're about £65 to replace!!

    If you take out the glove box (5 x bolt screws, 3 inside top edge, other 2 at the bottom corners underneath) and you'll see the 3 actuators on the side of the centre console. They're each held in place by 3 small bolt screws so just undo the wiring lead & the 3 bolts and its off! Reverse to replace obviously! I'll check the part number for the one i've got spare now in case its any good for you, we can come to some arrangement so to speak!
    A4 3.0 Quattro Sport - Gone & missed everyday!

    Current road going missile.....

    ........Smart Roadster - arguably the most fun you can have in a car without using lube!!

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Mar 2004
    Location
    scarborough
    Posts
    50

    Thumbs up Thanks!

    Thanks for your help,I had the car to my mate today,he has a bosch tester,like vagcom I guess. Anyway,sure enough,it came up with a fault to the flap motor,blocked or no voltage. I bit the bullet and ordered one from my stealer,73 inc vat etc,it'll be here tomorrow... D'oh!! Thanks for your kind offer though,very appreciated! Law of sod I guess.. I hope that's what's required,and sounds like a piece of p*ss to do. Again,many thanks for all your help,and for taking the time to reply. I hope this may have been of help to someone else,it seems to be a common fault,as the stealer said he's supplied 3 of these in the last 2 weeks..
    Regards, Blackwood

  7. #6
    kashiskash's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    34

    same problem

    Hi Nickynibbles I have an Audi A4 avant 1.9 tdi sport (2003) with exactly the same problem can you let me know if you have the correct part still for sale?

    Paul

  8. #7
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I would PM him mate, he hasnt been seen on here for a good while.
    Ingolstance Read about my A6 HERE.

  9. #8
    kashiskash's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    34

    windscreen demister

    Good idea mate, I'll do that right now and make a new thread on the topic as its a nightmare of a problem as specialy at this time of year.

  10. #9
    simon.m's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    2,746
    hi i had the same problem with my a4 all i did was take the clove box out when its out you can see all the motors and its the top one you want if when you push the button it dont make any sound its the motor but if like mine it just got stuck.
    you can take the arm off of it and move it by hand to free it up and should be ok
    you can also leave it open if the motor is dead till you have time and cash for a new one
    typertony likes this.

  11. #10
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    typical!! only read this thread last night then low and behold no air through the windscreen demister vent today


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  12. #11
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Mine did this on Saturday, absolutely nothing. Since then it has been fine, so don't lose heart
    Ingolstance Read about my A6 HERE.

  13. #12
    pjmspeedy's Avatar
    Dude, what's mine say ?

    Status
    Offline
    Join Date
    Apr 2008
    Location
    North West
    Posts
    1,057
    Quote Originally Posted by markyzs180 View Post
    typical!! only read this thread last night then low and behold no air through the windscreen demister vent today
    I saw that you posted, so I thought I would come and have a look.....wish I hadn't bothered now just in case it happens to me!
    Audi A4 1.8T Sport Cabriolet-Full black leather(Electric & heated),RNS-E,BOSE, OEM Bluetooth,RS4 Mirrors,RS4 FBMFSW,RS4 Pedals,RS4 RARB,Cruise Control,B7 Rear Lights,Ally Inlays,18" RS6 Alloys,HID's/Auto lights with dimming rear view mirror,Coming home lights,Ambient light pack & Rear parking sensors.

    For all your VAG OEM PARTS send me a PM or e-mail me at vagoemparts@ymail.com

  14. #13
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    It seems to be me trialling these common problems at the moment, so you should be ok!
    Ingolstance Read about my A6 HERE.

  15. #14
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Quote Originally Posted by quattrojames View Post
    Mine did this on Saturday, absolutely nothing. Since then it has been fine, so don't lose heart
    mine was fine this morning at 5am, then when i came out of work at 4pm with the windscreen suitably misted up, nothing! air blasting out of the side vents but nothing from the centre? kept hitting the demist button on the way home and after about 20 mins it worked! went out again a few hours later, nothing!! hopefully just a sticking flap or something and itr'll fix itself like yours!


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  16. #15
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I think I'm going to pop my glovebox out (again!) and spray a bit of lubricant on the adjuster to make sure, as it's a pita when it steams up.

    At least you can lower the roof and stand up if needs be!
    Ingolstance Read about my A6 HERE.

  17. #16
    kashiskash's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    34

    REAR DEMISTER

    What about the rear side windows at the back of the Avant it has the Demisting wire running through it but it dosn't seem to do anything,
    Has anyone any info on this?

  18. #17
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I've always understood that to be the FM radio aerial.
    Ingolstance Read about my A6 HERE.

  19. #18
    kashiskash's Avatar
    Neutral

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    34
    ah right that makes sense mate

  20. #19
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Quote Originally Posted by quattrojames View Post

    At least you can lower the roof and stand up if needs be!

    hahaha i didn't think of that !!


    think i'll be doing the same as you at the weekend......


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  21. #20
    PetrolDave's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2003
    Location
    U.K.
    Posts
    1,470
    Quote Originally Posted by kashiskash View Post
    What about the rear side windows at the back of the Avant it has the Demisting wire running through it but it dosn't seem to do anything,
    Has anyone any info on this?
    There's two wires in those windows.

    As well as the radio/TV aerials, the other wires are the glass break detectors for the alarm.
    2006 RS4 Avant (Phantom Black), RNS-E (2010 version inc SDS, HW 070, SW 0220) with AMI (250GB hard disk), Bluetooth + iPhone 5

  22. #21
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    I whipped off ther glovebox today then sat there watching the motors do their stuff while pressing the buttons on the cc unit, then the one that controls the flap for the demister stuck???!!!??? when i switched the ignition off/on the motor seemed to reset itself and then worked ok again? think i narrowed it down to a bad connection as it seemed to fail after the air had been directed to your feet (the down arrow!) I gave the connection a quick shot of good old wd40 and it didn;t fail after that, but time will tell!!!, i'll add a pick of where the motors are on a cab to this post when i've took it off my camera........


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  23. #22
    pjmspeedy's Avatar
    Dude, what's mine say ?

    Status
    Offline
    Join Date
    Apr 2008
    Location
    North West
    Posts
    1,057
    Well done for trying these things first Mark for us Cab owners

    Keep up the good work
    Audi A4 1.8T Sport Cabriolet-Full black leather(Electric & heated),RNS-E,BOSE, OEM Bluetooth,RS4 Mirrors,RS4 FBMFSW,RS4 Pedals,RS4 RARB,Cruise Control,B7 Rear Lights,Ally Inlays,18" RS6 Alloys,HID's/Auto lights with dimming rear view mirror,Coming home lights,Ambient light pack & Rear parking sensors.

    For all your VAG OEM PARTS send me a PM or e-mail me at vagoemparts@ymail.com

  24. #23
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Quote Originally Posted by pjmspeedy View Post
    Well done for trying these things first Mark for us Cab owners

    Keep up the good work

    My fault for buying a nail LOL

    For the Cab Lads heres a pic of the servo's, the one with the rather impressive green linkage is the one that moves the flap for windscreen demister.



    As there seems to be two revived older threads about this subject at the moment I will just add simon2004's cheap solution to this if your servo motor has completely died, take the motor off and move the linkage by hand so that the air is coming out the demister vents! This will save you having to fork out 70+ for a new motor just before Xmas !!!
    Last edited by markyzs180; 5th December 2009 at 14:38.
    Lizard-Racing likes this.


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  25. #24
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Nice one Mark! I've not done mine yet (seems to be working fine now) but I can't see it being very different in the other models either.
    Ingolstance Read about my A6 HERE.

  26. #25
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Quote Originally Posted by quattrojames View Post
    Nice one Mark! I've not done mine yet (seems to be working fine now) but I can't see it being very different in the other models either.
    Thats what I was thinking James, should all be the same or VERY similar.

    And it dawned on me earlier when reading one of your posts on this subject, I also had my glovebox off a couple of days before this happened!! Just wondering whether I caught the connector putting it back on, you know how awkward they can be and I was doing it in the dark!!!


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  27. #26
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Its certainly a coincidence we both had the same problem within a couple of days after taking the gloveboxes out
    Ingolstance Read about my A6 HERE.

  28. #27
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Oh well my glory lasted exactly two short trips!!! worked ok on first journey, failed on the second guess the old glovebox will be off again tomorrow!! think i'll time how long it takes to put it back on then start a new thread to see who's the fastest!


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  29. #28
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    I took the glovebox off again and took the servo off its mounting points then tested it and it worked fine every time? I can only think that a) the servo has lost some of its power or b) the internal flap is sticking and the servo isn't powerful enough to budge it!

    Anyway, not having the time or inclination to investigate this further I left the servo off its mounting points and manually moved the lever to the open position!!! Heres a pic of where you need to move it to....




    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  30. #29
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    I did mine a few days ago Mark, I just sprayed WD40 on all the pivot points - it's worked fine since touch wood ...
    Ingolstance Read about my A6 HERE.

  31. #30
    3rd Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Shirley, Solihull
    Posts
    542
    Quote Originally Posted by quattrojames View Post
    I did mine a few days ago Mark, I just sprayed WD40 on all the pivot points - it's worked fine since touch wood ...
    I did sit there thinking 'just spray it with wd40 and it'll be fine' but to be honest I needed to use it every day this week and didn't want to be messing about at 5am trying to clear the windscreen if it didn't work!! I'll have a proper look at it over christmas, maybe!!! Fingers crossed yours is sorted now, did you time yourself putting the glovebox back on? I bet were the fastest on the forum now


    Available soon in the For Sale Section.....

    RS4 Pedals - Drivers side mirror mounting/wiring
    B6 Cab Front Grills - Drivers side B6 Cab Headlamp
    Moro Blue Mirror Caps - Full set of Cab Windscreen Surrounds
    Symphony 6 disc Head - Unit Full set of B6 Cab Manuals inc Leather Wallet
    N/S B6 Rear Lamp - RS6 Auto Brake Pedal

    PM for more details.......

  32. #31
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2009
    Posts
    1
    Thanks for solutions to this chaps.

    I found that disconnecting the motor in full demist postion resulted in noise in the cruise and disconnecting motor in half demist postion resulted in poor windsceen demisting from cold.

    The part number is 8E2820511B, this has been superseeded by 8E2820511G which suggests there's been a design issue with it.

    Breakers have them for 35. I got my 'B' model from www.audibreakers.co.uk

    'nirroltd' on e-bay has a 'G' model on his shop for the same price.

    Rgds

  33. #32
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2007
    Posts
    10
    Hello All

    Well I just had the same prob. I took the glove box off and the green servo and gave it all a wiggle and its all working now???? But whats the red one for, I've taken the servo of its mountings and gone thru all the setting but I can't make it move

    I've VCDS should I do a zero reset thinger (Is that explained somewhere?)

  34. #33
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Quote Originally Posted by crewrest View Post

    The part number is 8E2820511B, this has been superseeded by 8E2820511G which suggests there's been a design issue with it.

    Breakers have them for 35. I got my 'B' model from www.audibreakers.co.uk

    'nirroltd' on e-bay has a 'G' model on his shop for the same price.

    Rgds
    Mine has virtually died a death now it seems. That seller has a D model for 35 - anyone know if I'd be better off buying one of the later models from TPS or somewhere?
    Ingolstance Read about my A6 HERE.

  35. #34
    "Stick a V8 in it!"

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Glenrothes, Fife, Scotland
    Posts
    14,900
    Is D the correct part?

    2000 A4 1.8T Sport Quattro Avant, Berry Pearl
    2000 A4 1.8T Sport Quattro Saloon, Black-ish
    1997 S4 - PPC £999 Challenge Track Car Build
    TD5 Land Rover Defender build


  36. #35
    BASS 666's Avatar
    BMW aye right dead on..

    Status
    Offline
    Join Date
    Sep 2010
    Location
    belfast
    Posts
    463
    i bought one last year james from TPS 75 quid but it was for the right hand side beside the pedals. **** me what a nightmare to fit.
    2002 1.9 tdi 130ish brake a4. full reiger body kit, 19 inch rs6 avant rims, eibach springs, home made grill, full leather interior, centre arm rest, quad powerflow exausts, a few engine mods, chrome door mirrors, aero wipers, s line door blades.

  37. #36
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Quote Originally Posted by aragorn View Post
    Is D the correct part?
    My understanding is that the suffix on the end of a part number is as a result of product evolution unless someone can tell me otherwise...?
    Ingolstance Read about my A6 HERE.

  38. #37
    quattrojames's Avatar
    Moderator

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Dorset
    Posts
    13,698

    My Social Networking

    Follow quattrojames On Twitter Add quattrojames on Facebook
    Quote Originally Posted by BASS 666 View Post
    i bought one last year james from TPS 75 quid but it was for the right hand side beside the pedals. **** me what a nightmare to fit.
    I've heard thats about what they cost, the one I'm after is from the passenger footwell so isn't too bad.
    Ingolstance Read about my A6 HERE.

  39. #38
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    2
    Quote Originally Posted by BASS 666 View Post
    i bought one last year james from TPS 75 quid but it was for the right hand side beside the pedals. **** me what a nightmare to fit.

    do you have a photo of where the motor is by the pedals... mine has broken aswell.. have had the shrouding off, but cant quite see

  40. #39
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    2
    scratch that, got it out, now just need to buy/fit and work out why the lincage snapped off it in the first place

  41. #40
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Posts
    1
    Thanks so much for your clear instructions and photo, I had the same problem with My demister. I removed the glove box, removed de-fective motor, reconnected it, it worked a couple of times and died again, so I suspected the motor had got weak in its old age, so ordered one from Audi after trying EVERYWHERE else without success including Bosch, Valeo, and a number of Motor factor shops, for 90, put it in, reconnected green arm, re-installed Glovebox job done! Thanks again!

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO